]> git.pld-linux.org Git - packages/epydoc.git/blob - epydoc.spec
d19e9aaf5e3f591d5de7c2c1ca5e86fb42225bd1
[packages/epydoc.git] / epydoc.spec
1 Summary:        Tool for generating API documentation for Python modules
2 Summary(pl):    Narzêdzie do generowania dokumentacji API modu³ów Pythona
3 Name:           epydoc
4 Version:        2.0
5 Release:        1
6 License:        MIT
7 Group:          Development/Languages/Python
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  fbb0bd482a872795c59f897b699f9549
10 URL:            http://epydoc.sourceforge.net/
11 BuildRequires:  python-modules >= 2.2.1
12 BuildRequires:  rpm-pythonprov
13 %pyrequires_eq  python-modules
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 epydoc is a tool for generating API documentation for Python modules,
19 based on their docstrings. For an example of epydoc's output, see the
20 API documentation for epydoc itself (html, pdf). A lightweight markup
21 language called epytext can be used to format docstrings and to add
22 information about specific fields, such as parameters and instance
23 variables. epydoc also understands docstrings written in
24 ReStructuredText, Javadoc and plaintext.
25
26 %description -l pl
27 epydoc jest narzêdziem do generowania dokumentacji API modu³ów Pythona
28 w oparciu o ich wewnêtrzne opisy (docstrings). Jako przyk³ad wyniku
29 jego dzia³ania mo¿na obejrzeæ jego w³asn± dokumentacjê (html, pdf).
30 epytext wywo³ywany przez prosty jêzyk znaczników mo¿e s³u¿yæ do
31 formatowania wewnêtrznych opisów oraz do dodawania informacji o
32 konkretnych polach, takich jak parametry i zmienne instancji. epydoc
33 rozumie równie¿ wewnêtrzne opisy stworzone w ReStructuredText, Javadoc
34 i w postaci czystego tekstu.
35
36 %package gui
37 Summary:        GUI for epydoc
38 Summary(pl):    Interfejs graficzny dla epydoc
39 Group:          Development/Languages/Python
40 Requires:       %{name} = %{version}
41 %pyrequires_eq  python-tkinter
42
43 %description gui
44 epydoc is a tool for generating API documentation for Python modules,
45 based on their docstrings. For an example of epydoc's output, see the
46 API documentation for epydoc itself (html, pdf). A lightweight markup
47 language called epytext can be used to format docstrings and to add
48 information about specific fields, such as parameters and instance
49 variables. epydoc also understands docstrings written in
50 ReStructuredText, Javadoc and plaintext.
51
52 This package contains GUI program for epydoc.
53
54 %description gui -l pl
55 epydoc jest narzêdziem do generowania dokumentacji API modu³ów Pythona
56 w oparciu o ich wewnêtrzne opisy (docstrings). Jako przyk³ad wyniku
57 jego dzia³ania mo¿na obejrzeæ jego w³asn± dokumentacjê (html, pdf).
58 epytext wywo³ywany przez prosty jêzyk znaczników mo¿e s³u¿yæ do
59 formatowania wewnêtrznych opisów oraz do dodawania informacji o
60 konkretnych polach, takich jak parametry i zmienne instancji. epydoc
61 rozumie równie¿ wewnêtrzne opisy stworzone w ReStructuredText, Javadoc
62 i w postaci czystego tekstu.
63
64 Ten pakiet zawiera graficzny interfejs u¿ytkownika (GUI) dla epydoc.
65
66 %prep
67 %setup -q
68
69 %build
70 python setup.py build
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT%{_mandir}/man1
75
76 python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
77
78 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc doc/*
86 %attr(755,root,root) %{_bindir}/epydoc
87
88 %dir %{py_sitedir}/epydoc
89 %{py_sitedir}/epydoc/*.py[co]
90 %exclude %{py_sitedir}/epydoc/gui.py[co]
91
92 %dir %{py_sitedir}/epydoc/markup
93 %{py_sitedir}/epydoc/markup/*.py[co]
94
95 %{_mandir}/man1/epydoc.*
96
97 %files gui
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/epydocgui
100 %{py_sitedir}/epydoc/gui.py[co]
101
102 %{_mandir}/man1/epydocgui.*
This page took 0.071539 seconds and 3 git commands to generate.