]> git.pld-linux.org Git - packages/epydoc.git/blob - epydoc.spec
- rel 1
[packages/epydoc.git] / epydoc.spec
1 Summary:        Tool for generating API documentation for Python modules
2 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji API modułów Pythona
3 Name:           epydoc
4 Version:        3.0.1
5 Release:        1
6 License:        MIT
7 Group:          Development/Languages/Python
8 Source0:        http://dl.sourceforge.net/epydoc/%{name}-%{version}.zip
9 # Source0-md5:  43223b2139c59ec60f064564bea82bf4
10 URL:            http://epydoc.sourceforge.net/
11 BuildRequires:  python-modules >= 2.2.1
12 BuildRequires:  unzip
13 %pyrequires_eq  python-modules
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 epydoc is a tool for generating API documentation for Python modules,
19 based on their docstrings. For an example of epydoc's output, see the
20 API documentation for epydoc itself (html, pdf). A lightweight markup
21 language called epytext can be used to format docstrings and to add
22 information about specific fields, such as parameters and instance
23 variables. epydoc also understands docstrings written in
24 ReStructuredText, Javadoc and plaintext.
25
26 %description -l pl.UTF-8
27 epydoc jest narzędziem do generowania dokumentacji API modułów Pythona
28 w oparciu o ich wewnętrzne opisy (docstrings). Jako przykład wyniku
29 jego działania można obejrzeć jego własną dokumentację (html, pdf).
30 epytext wywoływany przez prosty język znaczników może służyć do
31 formatowania wewnętrznych opisów oraz do dodawania informacji o
32 konkretnych polach, takich jak parametry i zmienne instancji. epydoc
33 rozumie również wewnętrzne opisy stworzone w ReStructuredText, Javadoc
34 i w postaci czystego tekstu.
35
36 %package gui
37 Summary:        GUI for epydoc
38 Summary(pl.UTF-8):      Interfejs graficzny dla epydoc
39 Group:          Development/Languages/Python
40 Requires:       %{name} = %{version}-%{release}
41 %pyrequires_eq  python-tkinter
42
43 %description gui
44 epydoc is a tool for generating API documentation for Python modules,
45 based on their docstrings. For an example of epydoc's output, see the
46 API documentation for epydoc itself (html, pdf). A lightweight markup
47 language called epytext can be used to format docstrings and to add
48 information about specific fields, such as parameters and instance
49 variables. epydoc also understands docstrings written in
50 ReStructuredText, Javadoc and plaintext.
51
52 This package contains GUI program for epydoc.
53
54 %description gui -l pl.UTF-8
55 epydoc jest narzędziem do generowania dokumentacji API modułów Pythona
56 w oparciu o ich wewnętrzne opisy (docstrings). Jako przykład wyniku
57 jego działania można obejrzeć jego własną dokumentację (html, pdf).
58 epytext wywoływany przez prosty język znaczników może służyć do
59 formatowania wewnętrznych opisów oraz do dodawania informacji o
60 konkretnych polach, takich jak parametry i zmienne instancji. epydoc
61 rozumie również wewnętrzne opisy stworzone w ReStructuredText, Javadoc
62 i w postaci czystego tekstu.
63
64 Ten pakiet zawiera graficzny interfejs użytkownika (GUI) dla epydoc.
65
66 %prep
67 %setup -q
68
69 %build
70 python setup.py build
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT%{_mandir}/man1
75
76 python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
77
78 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
79
80 %py_postclean
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc doc/*
88 %attr(755,root,root) %{_bindir}/*
89 %{_mandir}/man1/epydoc.*
90 %{py_sitescriptdir}/epydoc
91 %{py_sitescriptdir}/*.egg-info
92 %exclude %{py_sitescriptdir}/epydoc/gui.py[co]
93
94 %files gui
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_bindir}/epydocgui
97 %{py_sitescriptdir}/epydoc/gui.py[co]
98 %{_mandir}/man1/epydocgui.*
This page took 0.142418 seconds and 3 git commands to generate.