]> git.pld-linux.org Git - packages/epydoc.git/blob - epydoc.spec
- gui subpackage
[packages/epydoc.git] / epydoc.spec
1 %include        /usr/lib/rpm/macros.python
2
3 Summary:        Tool for generating API documentation for Python modules
4 Name:           epydoc
5 Version:        2.0
6 Release:        1
7 License:        MIT
8 Group:          Development/Languages/Python
9 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10 # Source0-md5:  fbb0bd482a872795c59f897b699f9549
11 URL:            http://epydoc.sourceforge.net/
12 BuildRequires:  python-modules >= 2.2.1
13 BuildRequires:  rpm-pythonprov
14 %pyrequires_eq  python-modules
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Epydoc is a tool for generating API documentation for Python modules, based
20 on their docstrings. For an example of epydoc's output, see the API
21 documentation for epydoc itself (html, pdf). A lightweight markup language
22 called epytext can be used to format docstrings and to add information
23 about specific fields, such as parameters and instance variables.  Epydoc
24 also understands docstrings written in ReStructuredText, Javadoc and
25 plaintext.
26
27 %package gui
28 Summary:        GUI for Epydoc
29 Group:          Development/Languages/Python
30 Requires:       %{name} = %{version}
31 %pyrequires_eq  tkinter
32
33 %description gui
34 Epydoc is a tool for generating API documentation for Python modules, based
35 on their docstrings. For an example of epydoc's output, see the API
36 documentation for epydoc itself (html, pdf). A lightweight markup language
37 called epytext can be used to format docstrings and to add information
38 about specific fields, such as parameters and instance variables.  Epydoc
39 also understands docstrings written in ReStructuredText, Javadoc and
40 plaintext.
41
42 This package contains GUI program for Epydoc.
43
44 %prep
45 %setup -q
46
47 %build
48 python setup.py build
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_mandir}/man1
53
54 python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
55
56 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc doc/*
64 %attr(755,root,root) %{_bindir}/epydoc
65
66 %dir %{py_sitedir}/epydoc
67 %{py_sitedir}/epydoc/*.py[co]
68 %exclude %{py_sitedir}/epydoc/gui.py[co]
69
70 %dir %{py_sitedir}/epydoc/markup
71 %{py_sitedir}/epydoc/markup/*.py[co]
72
73 %{_mandir}/man1/epydoc.*
74
75 %files gui
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_bindir}/epydocgui
78 %{py_sitedir}/epydoc/gui.py[co]
79
80 %{_mandir}/man1/epydocgui.*
This page took 0.088585 seconds and 3 git commands to generate.