]> git.pld-linux.org Git - packages/epydoc.git/blob - epydoc.spec
- mass commit: remove obsolete BR: rpm-pythonprov
[packages/epydoc.git] / epydoc.spec
1 Summary:        Tool for generating API documentation for Python modules
2 Summary(pl):    Narzêdzie do generowania dokumentacji API modu³ów Pythona
3 Name:           epydoc
4 Version:        2.1
5 Release:        2
6 License:        MIT
7 Group:          Development/Languages/Python
8 Source0:        http://dl.sourceforge.net/epydoc/%{name}-%{version}.tar.gz
9 # Source0-md5:  94c494426c47496ee4d1ed26b580a5a7
10 Patch0:         %{name}-failed_identifiers.patch
11 URL:            http://epydoc.sourceforge.net/
12 BuildRequires:  python-modules >= 2.2.1
13 %pyrequires_eq  python-modules
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 epydoc is a tool for generating API documentation for Python modules,
19 based on their docstrings. For an example of epydoc's output, see the
20 API documentation for epydoc itself (html, pdf). A lightweight markup
21 language called epytext can be used to format docstrings and to add
22 information about specific fields, such as parameters and instance
23 variables. epydoc also understands docstrings written in
24 ReStructuredText, Javadoc and plaintext.
25
26 %description -l pl
27 epydoc jest narzêdziem do generowania dokumentacji API modu³ów Pythona
28 w oparciu o ich wewnêtrzne opisy (docstrings). Jako przyk³ad wyniku
29 jego dzia³ania mo¿na obejrzeæ jego w³asn± dokumentacjê (html, pdf).
30 epytext wywo³ywany przez prosty jêzyk znaczników mo¿e s³u¿yæ do
31 formatowania wewnêtrznych opisów oraz do dodawania informacji o
32 konkretnych polach, takich jak parametry i zmienne instancji. epydoc
33 rozumie równie¿ wewnêtrzne opisy stworzone w ReStructuredText, Javadoc
34 i w postaci czystego tekstu.
35
36 %package gui
37 Summary:        GUI for epydoc
38 Summary(pl):    Interfejs graficzny dla epydoc
39 Group:          Development/Languages/Python
40 Requires:       %{name} = %{version}
41 %pyrequires_eq  python-tkinter
42
43 %description gui
44 epydoc is a tool for generating API documentation for Python modules,
45 based on their docstrings. For an example of epydoc's output, see the
46 API documentation for epydoc itself (html, pdf). A lightweight markup
47 language called epytext can be used to format docstrings and to add
48 information about specific fields, such as parameters and instance
49 variables. epydoc also understands docstrings written in
50 ReStructuredText, Javadoc and plaintext.
51
52 This package contains GUI program for epydoc.
53
54 %description gui -l pl
55 epydoc jest narzêdziem do generowania dokumentacji API modu³ów Pythona
56 w oparciu o ich wewnêtrzne opisy (docstrings). Jako przyk³ad wyniku
57 jego dzia³ania mo¿na obejrzeæ jego w³asn± dokumentacjê (html, pdf).
58 epytext wywo³ywany przez prosty jêzyk znaczników mo¿e s³u¿yæ do
59 formatowania wewnêtrznych opisów oraz do dodawania informacji o
60 konkretnych polach, takich jak parametry i zmienne instancji. epydoc
61 rozumie równie¿ wewnêtrzne opisy stworzone w ReStructuredText, Javadoc
62 i w postaci czystego tekstu.
63
64 Ten pakiet zawiera graficzny interfejs u¿ytkownika (GUI) dla epydoc.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 %build
71 python setup.py build
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_mandir}/man1
76
77 python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
78
79 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
80
81 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*.py" | xargs rm
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc doc/*
89 %attr(755,root,root) %{_bindir}/epydoc
90
91 %dir %{py_sitescriptdir}/epydoc
92 %{py_sitescriptdir}/epydoc/*.py[co]
93 %dir %{py_sitescriptdir}/epydoc/test
94 %{py_sitescriptdir}/epydoc/test/*.py[co]
95 %exclude %{py_sitescriptdir}/epydoc/gui.py[co]
96
97 %dir %{py_sitescriptdir}/epydoc/markup
98 %{py_sitescriptdir}/epydoc/markup/*.py[co]
99
100 %{_mandir}/man1/epydoc.*
101
102 %files gui
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_bindir}/epydocgui
105 %{py_sitescriptdir}/epydoc/gui.py[co]
106
107 %{_mandir}/man1/epydocgui.*
This page took 0.055625 seconds and 3 git commands to generate.