]> git.pld-linux.org Git - packages/epsilon.git/blob - epsilon.spec
- updated to 20080813 snap
[packages/epsilon.git] / epsilon.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       0.9.9.044
6 %define         edje_ver        0.9.9.044
7 %define         epeg_ver        0.9.1.043
8 %define         evas_ver        0.9.9.044
9 %define         _snap   20080813
10
11 Summary:        Enlightened Thumbnail Generator
12 Summary(pl.UTF-8):      Oświecony generator miniaturek obrazów
13 Name:           epsilon
14 Version:        0.3.0.013
15 Release:        0.%{_snap}.1
16 License:        BSD
17 Group:          X11/Libraries
18 Source0:        %{name}-%{version}-%{_snap}.tar.bz2
19 # Source0-md5:  b677b9c39aa2d5b467503faffd4b4879
20 URL:            http://enlightenment.org/
21 # ecore-con ecore-evas ecore-file
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  ecore-devel >= %{ecore_ver}
25 BuildRequires:  edje-devel >= %{edje_ver}
26 BuildRequires:  epeg-devel >= %{epeg_ver}
27 BuildRequires:  evas-devel >= %{evas_ver}
28 BuildRequires:  imlib2-devel >= 1.0.0
29 BuildRequires:  libpng-devel >= 1.2.0
30 BuildRequires:  libtool
31 BuildRequires:  perl-base
32 BuildRequires:  pkgconfig
33 BuildRequires:  xine-lib-devel >= 1:1.0.0
34 Requires:       %{name}-libs = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %undefine       __cxx
38
39 %description
40 Epsilon is a small, display independent, and quick thumbnailing
41 library. The lib itself conforms to the standard put forth by
42 freedesktop.org . You can find out more information about it at
43 http://triq.net/~jens/thumbnail-spec/index.html .
44
45 Epeg offers very noticeable speed increases to this standard, but it
46 is only available if the input image is a JPEG file. If the file is
47 anything other than jpg, the traditional freedesktop.org thumbnailing
48 will occur. To show the speed increase epeg offers, Epsilon can be
49 built with and without epeg.
50
51 %description -l pl.UTF-8
52 Epsilon to mała, niezależna od ekranu i szybka biblioteka do
53 generowania miniaturek obrazów. Sama biblioteka jest zgodna ze
54 standardem opracowanym przez freedesktop.org . Więcej informacji
55 można znaleźć pod adresem
56 http://triq.net/~jens/thumbnail-spec/index.html .
57
58 Epeg oferuje bardzo zauważalne przyspieszenie w stosunku do tego
59 standardu, ale jest ono dostępne tylko jeśli obrazek jest plikiem
60 JPEG. Jeśli plik jest innego typu, zostanie użyte tradycyjne
61 zachowanie freedesktop.org . Aby pokazać przyspieszenie oferowane
62 przez epeg, Epsilon może być zbudowany z lub bez epeg.
63
64 %package libs
65 Summary:        Epsilon library
66 Summary(pl.UTF-8):      Biblioteka Epsilon
67 Group:          X11/Libraries
68 Requires:       ecore-con >= %{ecore_ver}
69 Requires:       ecore-evas >= %{ecore_ver}
70 Requires:       ecore-file >= %{ecore_ver}
71 Requires:       edje-libs >= %{edje_ver}
72 Requires:       epeg-libs >= %{epeg_ver}
73 Requires:       evas >= %{evas_ver}
74 Requires:       imlib2 >= 1.0.0
75
76 %description libs
77 Epsilon library.
78
79 %description libs -l pl.UTF-8
80 Biblioteka Epsilon.
81
82 %package devel
83 Summary:        Epsilon header file
84 Summary(pl.UTF-8):      Plik nagłówkowy Epsilon
85 Group:          X11/Development/Libraries
86 Requires:       %{name}-libs = %{version}-%{release}
87 # ecore-con ecore-evas ecore-file
88 Requires:       ecore-devel >= %{ecore_ver}
89 Requires:       edje-devel >= %{edje_ver}
90 Requires:       epeg-devel >= %{epeg_ver}
91 Requires:       evas-devel >= %{evas_ver}
92 Requires:       imlib2-devel >= 1.0.0
93 Requires:       libpng-devel >= 1.2.0
94
95 %description devel
96 Epsilon thumbnailer development header.
97
98 %description devel -l pl.UTF-8
99 Plik nagłówkowy biblioteki Epsilon generującej miniaturki obrazów.
100
101 %package static
102 Summary:        Static Epsilon library
103 Summary(pl.UTF-8):      Statyczna biblioteka Epsilon
104 Group:          X11/Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description static
108 Static Epsilon library.
109
110 %description static -l pl.UTF-8
111 Statyczna biblioteka Epsilon.
112
113 %package plugin-xine
114 Summary:        XINE-based thumbnailer for Epsilon
115 Summary(pl.UTF-8):      Oparty na XINE generator miniaturek dla Epsilona
116 Group:          Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118 Requires:       xine-lib >= 1:1.0.0
119
120 %description plugin-xine
121 XINE-based thumbnailer for Epsilon. It supports MPEG, AVI, WMV and
122 QuickTime files.
123
124 Oparty na XINE generator miniaturek dla Epsilona. Obsługuje pliki
125 MPEG, AVI, WMV i QuickTime.
126
127 %prep
128 %setup -q -n %{name}-%{version}-%{_snap}
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         %{!?with_static_libs:--disable-static}
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 rm -f $RPM_BUILD_ROOT%{_libdir}/epsilon/plugins/*.{la,a}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   libs -p /sbin/ldconfig
152 %postun libs -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc AUTHORS COPYING README
157 %attr(755,root,root) %{_bindir}/epsilon
158 %attr(755,root,root) %{_bindir}/epsilon_thumbd
159 %attr(755,root,root) %{_bindir}/epsilon_thumb_test
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libepsilon.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libepsilon.so.0
165 %dir %{_libdir}/epsilon
166 %dir %{_libdir}/epsilon/plugins
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libepsilon.so
171 %{_libdir}/libepsilon.la
172 %{_includedir}/Epsilon*.h
173 %{_pkgconfigdir}/epsilon.pc
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libepsilon.a
179 %endif
180
181 %files plugin-xine
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/epsilon/plugins/xine_thumbnailer.so
This page took 0.086509 seconds and 3 git commands to generate.