]> git.pld-linux.org Git - packages/epsilon.git/blob - epsilon.spec
- updated to 0.3.0.008
[packages/epsilon.git] / epsilon.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightened Thumbnail Generator
6 Summary(pl.UTF-8):      Oświecony generator miniaturek obrazów
7 Name:           epsilon
8 Version:        0.3.0.008
9 Release:        1
10 License:        BSD
11 Group:          X11/Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  ba946584d90357f98402456e0fee9dcf
14 URL:            http://enlightenment.org/
15 # ecore-con ecore-evas ecore-file
16 BuildRequires:  ecore-devel >= 0.9.9.038
17 BuildRequires:  edje-devel >= 0.5.0.038
18 BuildRequires:  epeg-devel >= 0.9.0.008
19 BuildRequires:  evas-devel >= 0.9.9.038
20 BuildRequires:  imlib2-devel >= 1.0.0
21 BuildRequires:  libpng-devel >= 1.2.0
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 BuildRequires:  xine-lib-devel >= 1:1.0.0
25 Requires:       %{name}-libs = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %undefine       __cxx
29
30 %description
31 Epsilon is a small, display independent, and quick thumbnailing
32 library. The lib itself conforms to the standard put forth by
33 freedesktop.org . You can find out more information about it at
34 http://triq.net/~jens/thumbnail-spec/index.html .
35
36 Epeg offers very noticeable speed increases to this standard, but it
37 is only available if the input image is a JPEG file. If the file is
38 anything other than jpg, the traditional freedesktop.org thumbnailing
39 will occur. To show the speed increase epeg offers, Epsilon can be
40 built with and without epeg.
41
42 %description -l pl.UTF-8
43 Epsilon to mała, niezależna od ekranu i szybka biblioteka do
44 generowania miniaturek obrazów. Sama biblioteka jest zgodna ze
45 standardem opracowanym przez freedesktop.org . Więcej informacji
46 można znaleźć pod adresem
47 http://triq.net/~jens/thumbnail-spec/index.html .
48
49 Epeg oferuje bardzo zauważalne przyspieszenie w stosunku do tego
50 standardu, ale jest ono dostępne tylko jeśli obrazek jest plikiem
51 JPEG. Jeśli plik jest innego typu, zostanie użyte tradycyjne
52 zachowanie freedesktop.org . Aby pokazać przyspieszenie oferowane
53 przez epeg, Epsilon może być zbudowany z lub bez epeg.
54
55 %package libs
56 Summary:        Epsilon library
57 Summary(pl.UTF-8):      Biblioteka Epsilon
58 Group:          X11/Libraries
59 Requires:       ecore-con >= 0.9.9.038
60 Requires:       ecore-evas >= 0.9.9.038
61 Requires:       ecore-file >= 0.9.9.038
62 Requires:       edje-libs >= 0.5.0.038
63 Requires:       epeg-libs >= 0.9.0.008
64 Requires:       evas >= 0.9.9.038
65 Requires:       imlib2 >= 1.0.0
66
67 %description libs
68 Epsilon library.
69
70 %description libs -l pl.UTF-8
71 Biblioteka Epsilon.
72
73 %package devel
74 Summary:        Epsilon header file
75 Summary(pl.UTF-8):      Plik nagłówkowy Epsilon
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-libs = %{version}-%{release}
78 # ecore-con ecore-evas ecore-file
79 Requires:       ecore-devel >= 0.9.9.038
80 Requires:       edje-devel >= 0.5.0.038
81 Requires:       epeg-devel >= 0.9.0.008
82 Requires:       evas-devel >= 0.9.9.038
83 Requires:       imlib2-devel >= 1.0.0
84 Requires:       libpng-devel >= 1.2.0
85
86 %description devel
87 Epsilon thumbnailer development header.
88
89 %description devel -l pl.UTF-8
90 Plik nagłówkowy biblioteki Epsilon generującej miniaturki obrazów.
91
92 %package static
93 Summary:        Static Epsilon library
94 Summary(pl.UTF-8):      Statyczna biblioteka Epsilon
95 Group:          X11/Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static Epsilon library.
100
101 %description static -l pl.UTF-8
102 Statyczna biblioteka Epsilon.
103
104 %package plugin-xine
105 Summary:        XINE-based thumbnailer for Epsilon
106 Summary(pl.UTF-8):      Oparty na XINE generator miniaturek dla Epsilona
107 Group:          Libraries
108 Requires:       %{name}-libs = %{version}-%{release}
109 Requires:       xine-lib >= 1:1.0.0
110
111 %description plugin-xine
112 XINE-based thumbnailer for Epsilon. It supports MPEG, AVI, WMV and
113 QuickTime files.
114
115 Oparty na XINE generator miniaturek dla Epsilona. Obsługuje pliki
116 MPEG, AVI, WMV i QuickTime.
117
118 %prep
119 %setup -q
120
121 %build
122 %configure \
123         %{!?with_static_libs:--disable-static}
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 rm -f $RPM_BUILD_ROOT%{_libdir}/epsilon/plugins/*.{la,a}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   libs -p /sbin/ldconfig
138 %postun libs -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS COPYING README
143 %attr(755,root,root) %{_bindir}/epsilon
144 %attr(755,root,root) %{_bindir}/epsilon_thumbd
145 %attr(755,root,root) %{_bindir}/epsilon_thumb_test
146
147 %files libs
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libepsilon.so.*.*.*
150 %dir %{_libdir}/epsilon
151 %dir %{_libdir}/epsilon/plugins
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/epsilon-config
156 %attr(755,root,root) %{_libdir}/libepsilon.so
157 %{_libdir}/libepsilon.la
158 %{_includedir}/Epsilon*.h
159 %{_pkgconfigdir}/epsilon.pc
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libepsilon.a
165 %endif
166
167 %files plugin-xine
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/epsilon/plugins/xine_thumbnailer.so
This page took 0.038407 seconds and 3 git commands to generate.