]> git.pld-linux.org Git - packages/epiphany.git/blobdiff - epiphany.spec
- look for plugins in xulrunner directory not in mozilla one
[packages/epiphany.git] / epiphany.spec
index 9af80b632de52266437186ade838f2d95f00ac14..e69edeede8c2cb64ed3391deff3ab32ca9922858 100644 (file)
@@ -1,67 +1,93 @@
 #
-%define                basever 2.16
+#Conditional build:
+%bcond_with    webkit          # Build with experimental webkit suppor instead of xulrunner
+#
+%define                basever         2.24
 Summary:       Epiphany - gecko-based GNOME web browser
 Summary(es.UTF-8):     Epiphany - navigador Web de GNOME basado en gecko
 Summary(pl.UTF-8):     Epiphany - przeglądarka WWW dla GNOME
 Name:          epiphany
-Version:       2.16.2
-Release:       2
+Version:       2.24.1
+Release:       3
 License:       GPL v2
 Group:         X11/Applications/Networking
-Source0:       http://ftp.gnome.org/pub/gnome/sources/epiphany/%{basever}/%{name}-%{version}.tar.bz2
-# Source0-md5: 6d4ca4c3c1fb52b432ad3f5006866b6b
-Patch0:                %{name}-first-tab.patch
-Patch1:                %{name}-desktop.patch
-Patch2:                %{name}-pld-homepage.patch
-Patch3:                %{name}-configure.patch
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.24/%{name}-%{version}.tar.bz2
+# Source0-md5: 3276f4ca4bef98606f84fc64ce46c9c4
+Patch0:                %{name}-pld-homepage.patch
+Patch1:                %{name}-configure.patch
+Patch2:                %{name}-ti-agent.patch
+Patch3:                %{name}-agent.patch
+Patch4:                %{name}-lt.patch
+Patch5:                %{name}-libxul.patch
+Patch7:                %{name}-build_date.patch
+Patch8:                %{name}-xulrunner-plugins-dir.patch
 URL:           http://www.gnome.org/projects/epiphany/
-BuildRequires: GConf2-devel >= 2.16.0
-BuildRequires: ORBit2-devel >= 1:2.14.3
+BuildRequires: GConf2-devel >= 2.20.0
+BuildRequires: NetworkManager-devel
+BuildRequires: ORBit2-devel >= 1:2.14.9
 BuildRequires: autoconf >= 2.59
-BuildRequires: automake >= 1.8
-BuildRequires: dbus-glib-devel >= 0.71-2
-BuildRequires: gnome-common >= 2.12.0
-BuildRequires: gnome-desktop-devel >= 2.16.1
-BuildRequires: gnome-doc-utils >= 0.8.0
-BuildRequires: gnome-vfs2-devel >= 2.16.2
-BuildRequires: gtk+2-devel >= 2:2.10.6
-BuildRequires: gtk-doc >= 1.7
-BuildRequires: intltool >= 0.35.0
+BuildRequires: automake >= 1:1.9
+BuildRequires: dbus-glib-devel >= 0.73
+BuildRequires: enchant-devel >= 1.0
+BuildRequires: gnome-common >= 2.20.0
+BuildRequires: gnome-desktop-devel >= 2.20.0
+BuildRequires: gnome-doc-utils >= 0.12.0
+BuildRequires: gnome-vfs2-devel >= 2.22.0
+BuildRequires: gtk+2-devel >= 2:2.12.0
+BuildRequires: gtk-doc >= 1.8
+%if %{with webkit}
+BuildRequires: gtk-webkit-devel
+BuildRequires: libssh2-devel
+%endif
+BuildRequires: intltool >= 0.36.2
 BuildRequires: iso-codes >= 0.53
-BuildRequires: libglade2-devel >= 1:2.6.0
-BuildRequires: libgnomeprintui-devel >= 2.12.1
-BuildRequires: libgnomeui-devel >= 2.16.1
+BuildRequires: libglade2-devel >= 1:2.6.2
+BuildRequires: libgnomeprintui-devel >= 2.18.0
+BuildRequires: libgnomeui-devel >= 2.22.0
 BuildRequires: libtool
-BuildRequires: libxslt-devel >= 1.1.17
-BuildRequires: xulrunner-devel >= 1.8.0.4
-BuildRequires: xulrunner
+BuildRequires: libxml2-devel >= 1:2.6.28
+BuildRequires: libxslt-devel >= 1.1.20
 BuildRequires: pkgconfig
-BuildRequires: python-gnome-devel >= 2.16.2
-BuildRequires: python-pygtk-devel >= 2.10.3
+BuildRequires: python-gnome-devel >= 2.20.0
+BuildRequires: python-pygtk-devel >= 2:2.12.0
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(find_lang) >= 1.23
 BuildRequires: rpmbuild(macros) >= 1.311
 BuildRequires: scrollkeeper
 BuildRequires: startup-notification-devel >= 0.8
-Requires(post,preun):  GConf2 >= 2.16.0
+%if %{without webkit}
+BuildRequires: xulrunner
+BuildRequires: xulrunner-devel >= 1.9.0.1-1
+%endif
 Requires(post,postun): desktop-file-utils
-Requires(post,postun): gtk+2 >= 2:2.10.6
+Requires(post,postun): gtk+2
 Requires(post,postun): hicolor-icon-theme
 Requires(post,postun): scrollkeeper
-Requires:      dbus >= 0.91
-Requires:      gnome-icon-theme >= 2.16.0.1
-Requires:      gtk+2 >= 2:2.10.6
-Requires:      libgnomeui >= 2.16.1
+Requires(post,preun):  GConf2
+Requires:      dbus >= 1.0.2
+Requires:      gnome-icon-theme >= 2.22.0
+Requires:      libgnomeui >= 2.22.0
+%if %{without webkit}
 %requires_eq   xulrunner
+%endif
 Obsoletes:     python-epiphany
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%if %{without webkit}
 # can be provided by mozilla or mozilla-embedded
 %define                _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
+# we have strict deps for it
+%define                _noautoreq      libxpcom.so
+%endif
 
 %description
 GNOME browser based on Gecko (Mozilla rendering engine).
 
 %description -l es.UTF-8
-Navigador Web de GNOME basado en Gecko (el engine plasmante de Mozilla).
+Navigador Web de GNOME basado en Gecko (el engine plasmante de
+Mozilla).
 
 %description -l pl.UTF-8
 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
@@ -73,8 +99,8 @@ Summary(es.UTF-8):    Ficheros de cabecera de Epiphany
 Summary(pl.UTF-8):     Pliki nagłówkowe Epiphany
 Group:         X11/Applications/Networking
 # doesn't require base
-Requires:      gtk+2-devel >= 2:2.10.6
-Requires:      libxslt-devel >= 1.1.17
+Requires:      gtk+2-devel >= 2:2.12.0
+Requires:      libxslt-devel >= 1.1.20
 
 %description devel
 Epiphany header files for plugin development.
@@ -101,8 +127,15 @@ Dokumentacja API Epiphany.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%if "%{pld_release}" == "ti"
 %patch2 -p1
+%else
 %patch3 -p1
+%endif
+%patch4 -p1
+%patch5 -p1
+%patch7 -p1
+%patch8 -p1
 
 %build
 %{__gnome_doc_prepare}
@@ -117,8 +150,14 @@ Dokumentacja API Epiphany.
 %configure \
        --disable-schemas-install \
        --enable-dbus \
-       --enable-gtk-doc \
+       %{?!with_webkit:--enable-gtk-doc} \
+       --enable-network-manager \
        --enable-python \
+       %if %{with webkit}
+       --with-engine=webkit \
+       %else
+       --with-gecko=libxul-embedding \
+       %endif
        --with-html-dir=%{_gtkdocdir}
 %{__make}
 
@@ -131,8 +170,9 @@ install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
        HTML_DIR=%{_gtkdocdir}
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
+rm -rf $RPM_BUILD_ROOT%{_iconsdir}/LowContrastLargePrint
 
-%find_lang %{name} --with-gnome
+%find_lang %{name} --with-gnome --with-omf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -164,17 +204,18 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/services/*.service
 %{_datadir}/%{name}
 %{_desktopdir}/*.desktop
-%{_iconsdir}/hicolor/*/*/*.png
+%{_iconsdir}/*/*/apps/*.*
 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
 %{_sysconfdir}/gconf/schemas/epiphany.schemas
-%{_omf_dest_dir}/*
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/%{basever}
 %dir %{_libdir}/%{name}/%{basever}/extensions
+%if %{without webkit}
 %dir %{_libdir}/%{name}/%{basever}/plugins
 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
+%endif
 %{_mandir}/man1/*
 
 %files devel
This page took 0.10389 seconds and 4 git commands to generate.