]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
c6b5b5f8dfc0ff38267b86516b26352381b6a26c
[packages/epiphany.git] / epiphany.spec
1 #
2 #Conditional build:
3 %bcond_with     webkit          # Build with experimental webkit suppor instead of xulrunner
4 #
5 %define         basever         2.24
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es.UTF-8):      Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl.UTF-8):      Epiphany - przeglądarka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.24.1
11 Release:        2
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.24/%{name}-%{version}.tar.bz2
15 # Source0-md5:  3276f4ca4bef98606f84fc64ce46c9c4
16 Patch0:         %{name}-pld-homepage.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-ti-agent.patch
19 Patch3:         %{name}-agent.patch
20 Patch4:         %{name}-lt.patch
21 Patch5:         %{name}-libxul.patch
22 Patch7:         %{name}-build_date.patch
23 URL:            http://www.gnome.org/projects/epiphany/
24 BuildRequires:  GConf2-devel >= 2.20.0
25 BuildRequires:  NetworkManager-devel
26 BuildRequires:  ORBit2-devel >= 1:2.14.9
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake >= 1:1.9
29 BuildRequires:  dbus-glib-devel >= 0.73
30 BuildRequires:  enchant-devel >= 1.0
31 BuildRequires:  gnome-common >= 2.20.0
32 BuildRequires:  gnome-desktop-devel >= 2.20.0
33 BuildRequires:  gnome-doc-utils >= 0.12.0
34 BuildRequires:  gnome-vfs2-devel >= 2.22.0
35 BuildRequires:  gtk+2-devel >= 2:2.12.0
36 BuildRequires:  gtk-doc >= 1.8
37 %if %{with webkit}
38 BuildRequires:  gtk-webkit-devel
39 BuildRequires:  libssh2-devel
40 %endif
41 BuildRequires:  intltool >= 0.36.2
42 BuildRequires:  iso-codes >= 0.53
43 BuildRequires:  libglade2-devel >= 1:2.6.2
44 BuildRequires:  libgnomeprintui-devel >= 2.18.0
45 BuildRequires:  libgnomeui-devel >= 2.22.0
46 BuildRequires:  libtool
47 BuildRequires:  libxml2-devel >= 1:2.6.28
48 BuildRequires:  libxslt-devel >= 1.1.20
49 BuildRequires:  pkgconfig
50 BuildRequires:  python-gnome-devel >= 2.20.0
51 BuildRequires:  python-pygtk-devel >= 2:2.12.0
52 BuildRequires:  rpm >= 4.4.9-56
53 BuildRequires:  rpmbuild(find_lang) >= 1.23
54 BuildRequires:  rpmbuild(macros) >= 1.311
55 BuildRequires:  scrollkeeper
56 BuildRequires:  startup-notification-devel >= 0.8
57 %if %{without webkit}
58 BuildRequires:  xulrunner
59 BuildRequires:  xulrunner-devel >= 1.9.0.1-1
60 %endif
61 Requires(post,postun):  desktop-file-utils
62 Requires(post,postun):  gtk+2
63 Requires(post,postun):  hicolor-icon-theme
64 Requires(post,postun):  scrollkeeper
65 Requires(post,preun):   GConf2
66 Requires:       dbus >= 1.0.2
67 Requires:       gnome-icon-theme >= 2.22.0
68 Requires:       libgnomeui >= 2.22.0
69 %if %{without webkit}
70 %requires_eq    xulrunner
71 %endif
72 Obsoletes:      python-epiphany
73 # sr@Latn vs. sr@latin
74 Conflicts:      glibc-misc < 6:2.7
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %if %{without webkit}
78 # can be provided by mozilla or mozilla-embedded
79 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
80 # we have strict deps for it
81 %define         _noautoreq      libxpcom.so
82 %endif
83
84 %description
85 GNOME browser based on Gecko (Mozilla rendering engine).
86
87 %description -l es.UTF-8
88 Navigador Web de GNOME basado en Gecko (el engine plasmante de
89 Mozilla).
90
91 %description -l pl.UTF-8
92 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
93 interpretacji stron Mozilli).
94
95 %package devel
96 Summary:        Epiphany header files
97 Summary(es.UTF-8):      Ficheros de cabecera de Epiphany
98 Summary(pl.UTF-8):      Pliki nagłówkowe Epiphany
99 Group:          X11/Applications/Networking
100 # doesn't require base
101 Requires:       gtk+2-devel >= 2:2.12.0
102 Requires:       libxslt-devel >= 1.1.20
103
104 %description devel
105 Epiphany header files for plugin development.
106
107 %description devel -l es.UTF-8
108 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
109
110 %description devel -l pl.UTF-8
111 Pliki nagłówkowe Epiphany do tworzenia wtyczek.
112
113 %package apidocs
114 Summary:        Epiphany API documentation
115 Summary(pl.UTF-8):      Dokumentacja API Epiphany
116 Group:          Documentation
117 Requires:       gtk-doc-common
118
119 %description apidocs
120 Epiphany API documentation.
121
122 %description apidocs -l pl.UTF-8
123 Dokumentacja API Epiphany.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129 %if "%{pld_release}" == "ti"
130 %patch2 -p1
131 %else
132 %patch3 -p1
133 %endif
134 %patch4 -p1
135 %patch5 -p1
136 %patch7 -p1
137
138 %build
139 %{__gnome_doc_prepare}
140 %{__gnome_doc_common}
141 %{__glib_gettextize}
142 %{__intltoolize}
143 %{__libtoolize}
144 %{__aclocal} -I m4
145 %{__autoheader}
146 %{__automake}
147 %{__autoconf}
148 %configure \
149         --disable-schemas-install \
150         --enable-dbus \
151         %{?!with_webkit:--enable-gtk-doc} \
152         --enable-network-manager \
153         --enable-python \
154         %if %{with webkit}
155         --with-engine=webkit \
156         %else
157         --with-gecko=libxul-embedding \
158         %endif
159         --with-html-dir=%{_gtkdocdir}
160 %{__make}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT \
168         HTML_DIR=%{_gtkdocdir}
169
170 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
171 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/LowContrastLargePrint
172
173 %find_lang %{name} --with-gnome --with-omf
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post
179 %gconf_schema_install epiphany-fonts.schemas
180 %gconf_schema_install epiphany-lockdown.schemas
181 %gconf_schema_install epiphany-pango.schemas
182 %gconf_schema_install epiphany.schemas
183 %scrollkeeper_update_post
184 %update_desktop_database_post
185 %update_icon_cache hicolor
186
187 %preun
188 %gconf_schema_uninstall epiphany-fonts.schemas
189 %gconf_schema_uninstall epiphany-lockdown.schemas
190 %gconf_schema_uninstall epiphany-pango.schemas
191 %gconf_schema_uninstall epiphany.schemas
192
193 %postun
194 %scrollkeeper_update_postun
195 %update_desktop_database_postun
196 %update_icon_cache hicolor
197
198 %files -f %{name}.lang
199 %defattr(644,root,root,755)
200 %doc AUTHORS ChangeLog NEWS README
201 %attr(755,root,root) %{_bindir}/*
202 %{_datadir}/dbus-1/services/*.service
203 %{_datadir}/%{name}
204 %{_desktopdir}/*.desktop
205 %{_iconsdir}/*/*/apps/*.*
206 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
207 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
208 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
209 %{_sysconfdir}/gconf/schemas/epiphany.schemas
210 %dir %{_libdir}/%{name}
211 %dir %{_libdir}/%{name}/%{basever}
212 %dir %{_libdir}/%{name}/%{basever}/extensions
213 %if %{without webkit}
214 %dir %{_libdir}/%{name}/%{basever}/plugins
215 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
216 %endif
217 %{_mandir}/man1/*
218
219 %files devel
220 %defattr(644,root,root,755)
221 %{_aclocaldir}/*
222 %{_includedir}/epiphany
223 %{_pkgconfigdir}/*.pc
224 %{_datadir}/pygtk/*/defs/epiphany.defs
225
226 %files apidocs
227 %defattr(644,root,root,755)
228 %{_gtkdocdir}/*
This page took 0.053981 seconds and 2 git commands to generate.