]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
a7edb49281e7946db48ba4b386c1e718c2b8d890
[packages/epiphany.git] / epiphany.spec
1 #
2 #Conditional build:
3 %bcond_with     webkit          # Build with experimental webkit suppor instead of xulrunner
4 #
5 %define         basever         2.22
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es.UTF-8):      Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl.UTF-8):      Epiphany - przeglądarka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.22.3
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.22/%{name}-%{version}.tar.bz2
15 # Source0-md5:  7d058b57cb3e992889e456848fcc89a9
16 Patch0:         %{name}-pld-homepage.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-ti-agent.patch
19 Patch3:         %{name}-agent.patch
20 Patch4:         %{name}-lt.patch
21 Patch5:         %{name}-libxul.patch
22 Patch6:         %{name}-ssl_oldapi.patch
23 URL:            http://www.gnome.org/projects/epiphany/
24 BuildRequires:  GConf2-devel >= 2.20.0
25 BuildRequires:  NetworkManager-devel
26 BuildRequires:  ORBit2-devel >= 1:2.14.9
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake >= 1:1.9
29 BuildRequires:  dbus-glib-devel >= 0.73
30 BuildRequires:  enchant-devel >= 1.0
31 BuildRequires:  gnome-common >= 2.20.0
32 BuildRequires:  gnome-desktop-devel >= 2.20.0
33 BuildRequires:  gnome-doc-utils >= 0.12.0
34 BuildRequires:  gnome-vfs2-devel >= 2.22.0
35 BuildRequires:  gtk+2-devel >= 2:2.12.0
36 BuildRequires:  gtk-doc >= 1.8
37 %if %{with webkit}
38 BuildRequires:  gtk-webkit-devel
39 BuildRequires:  libssh2-devel
40 %endif
41 BuildRequires:  intltool >= 0.36.2
42 BuildRequires:  iso-codes >= 0.53
43 BuildRequires:  libglade2-devel >= 1:2.6.2
44 BuildRequires:  libgnomeprintui-devel >= 2.18.0
45 BuildRequires:  libgnomeui-devel >= 2.22.0
46 BuildRequires:  libtool
47 BuildRequires:  libxml2-devel >= 1:2.6.28
48 BuildRequires:  libxslt-devel >= 1.1.20
49 BuildRequires:  pkgconfig
50 BuildRequires:  python-gnome-devel >= 2.20.0
51 BuildRequires:  python-pygtk-devel >= 2:2.12.0
52 BuildRequires:  rpm >= 4.4.9-56
53 BuildRequires:  rpmbuild(find_lang) >= 1.23
54 BuildRequires:  rpmbuild(macros) >= 1.311
55 BuildRequires:  scrollkeeper
56 BuildRequires:  startup-notification-devel >= 0.8
57 %if %{without webkit}
58 BuildRequires:  xulrunner
59 BuildRequires:  xulrunner-devel >= 1.9.0.1-1
60 %endif
61 Requires(post,postun):  desktop-file-utils
62 Requires(post,postun):  gtk+2
63 Requires(post,postun):  hicolor-icon-theme
64 Requires(post,postun):  scrollkeeper
65 Requires(post,preun):   GConf2
66 Requires:       dbus >= 1.0.2
67 Requires:       gnome-icon-theme >= 2.22.0
68 Requires:       libgnomeui >= 2.22.0
69 %if %{without webkit}
70 %requires_eq    xulrunner
71 %endif
72 Obsoletes:      python-epiphany
73 # sr@Latn vs. sr@latin
74 Conflicts:      glibc-misc < 6:2.7
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %if %{without webkit}
78 # can be provided by mozilla or mozilla-embedded
79 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
80 # we have strict deps for it
81 %define         _noautoreq      libxpcom.so
82 %endif
83
84 %description
85 GNOME browser based on Gecko (Mozilla rendering engine).
86
87 %description -l es.UTF-8
88 Navigador Web de GNOME basado en Gecko (el engine plasmante de
89 Mozilla).
90
91 %description -l pl.UTF-8
92 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
93 interpretacji stron Mozilli).
94
95 %package devel
96 Summary:        Epiphany header files
97 Summary(es.UTF-8):      Ficheros de cabecera de Epiphany
98 Summary(pl.UTF-8):      Pliki nagłówkowe Epiphany
99 Group:          X11/Applications/Networking
100 # doesn't require base
101 Requires:       gtk+2-devel >= 2:2.12.0
102 Requires:       libxslt-devel >= 1.1.20
103
104 %description devel
105 Epiphany header files for plugin development.
106
107 %description devel -l es.UTF-8
108 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
109
110 %description devel -l pl.UTF-8
111 Pliki nagłówkowe Epiphany do tworzenia wtyczek.
112
113 %package apidocs
114 Summary:        Epiphany API documentation
115 Summary(pl.UTF-8):      Dokumentacja API Epiphany
116 Group:          Documentation
117 Requires:       gtk-doc-common
118
119 %description apidocs
120 Epiphany API documentation.
121
122 %description apidocs -l pl.UTF-8
123 Dokumentacja API Epiphany.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129 %if "%{pld_release}" == "ti"
130 %patch2 -p1
131 %else
132 %patch3 -p1
133 %endif
134 %patch4 -p1
135 %patch5 -p1
136 %patch6 -p1
137
138 sed -i -e 's#sr@Latn#sr@latin#' po/LINGUAS
139 mv po/sr@{Latn,latin}.po
140
141 %build
142 %{__gnome_doc_prepare}
143 %{__gnome_doc_common}
144 %{__glib_gettextize}
145 %{__intltoolize}
146 %{__libtoolize}
147 %{__aclocal} -I m4
148 %{__autoheader}
149 %{__automake}
150 %{__autoconf}
151 %configure \
152         --disable-schemas-install \
153         --enable-dbus \
154         %{?!with_webkit:--enable-gtk-doc} \
155         --enable-network-manager \
156         --enable-python \
157         %if %{with webkit}
158         --with-engine=webkit \
159         %else
160         --with-gecko=libxul-embedding \
161         %endif
162         --with-html-dir=%{_gtkdocdir}
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
168
169 %{__make} install \
170         DESTDIR=$RPM_BUILD_ROOT \
171         HTML_DIR=%{_gtkdocdir}
172
173 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
174 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/LowContrastLargePrint
175
176 %find_lang %{name} --with-gnome --with-omf
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post
182 %gconf_schema_install epiphany-fonts.schemas
183 %gconf_schema_install epiphany-lockdown.schemas
184 %gconf_schema_install epiphany-pango.schemas
185 %gconf_schema_install epiphany.schemas
186 %scrollkeeper_update_post
187 %update_desktop_database_post
188 %update_icon_cache hicolor
189
190 %preun
191 %gconf_schema_uninstall epiphany-fonts.schemas
192 %gconf_schema_uninstall epiphany-lockdown.schemas
193 %gconf_schema_uninstall epiphany-pango.schemas
194 %gconf_schema_uninstall epiphany.schemas
195
196 %postun
197 %scrollkeeper_update_postun
198 %update_desktop_database_postun
199 %update_icon_cache hicolor
200
201 %files -f %{name}.lang
202 %defattr(644,root,root,755)
203 %doc AUTHORS ChangeLog NEWS README
204 %attr(755,root,root) %{_bindir}/*
205 %{_datadir}/dbus-1/services/*.service
206 %{_datadir}/%{name}
207 %{_desktopdir}/*.desktop
208 %{_iconsdir}/*/*/apps/*.*
209 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
210 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
211 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
212 %{_sysconfdir}/gconf/schemas/epiphany.schemas
213 %dir %{_libdir}/%{name}
214 %dir %{_libdir}/%{name}/%{basever}
215 %dir %{_libdir}/%{name}/%{basever}/extensions
216 %if %{without webkit}
217 %dir %{_libdir}/%{name}/%{basever}/plugins
218 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
219 %endif
220 %{_mandir}/man1/*
221
222 %files devel
223 %defattr(644,root,root,755)
224 %{_aclocaldir}/*
225 %{_includedir}/epiphany
226 %{_pkgconfigdir}/*.pc
227 %{_datadir}/pygtk/*/defs/epiphany.defs
228
229 %files apidocs
230 %defattr(644,root,root,755)
231 %{_gtkdocdir}/*
This page took 0.048822 seconds and 2 git commands to generate.