]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
964894867e59f5f7543ea833f77a8d97fa5f93d7
[packages/epiphany.git] / epiphany.spec
1 #
2 #Conditional build:
3 %bcond_with     webkit          # Build with experimental webkit suppor instead of xulrunner
4 #
5 %define         basever         2.22
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es.UTF-8):      Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl.UTF-8):      Epiphany - przeglądarka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.22.0
11 Release:        6
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.22/%{name}-%{version}.tar.bz2
15 # Source0-md5:  81ad67d1ad706930a295a7ed9887bf5f
16 Patch0:         %{name}-pld-homepage.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-agent.patch
19 URL:            http://www.gnome.org/projects/epiphany/
20 BuildRequires:  GConf2-devel >= 2.20.0
21 BuildRequires:  NetworkManager-devel
22 BuildRequires:  ORBit2-devel >= 1:2.14.9
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake >= 1:1.9
25 BuildRequires:  dbus-glib-devel >= 0.73
26 BuildRequires:  enchant-devel >= 1.0
27 BuildRequires:  gnome-common >= 2.20.0
28 BuildRequires:  gnome-desktop-devel >= 2.20.0
29 BuildRequires:  gnome-doc-utils >= 0.12.0
30 BuildRequires:  gnome-vfs2-devel >= 2.22.0
31 BuildRequires:  gtk+2-devel >= 2:2.12.0
32 BuildRequires:  gtk-doc >= 1.8
33 %if %{with webkit}
34 BuildRequires:  gtk-webkit-devel
35 BuildRequires:  libssh2-devel
36 %endif
37 BuildRequires:  intltool >= 0.36.2
38 BuildRequires:  iso-codes >= 0.53
39 BuildRequires:  libglade2-devel >= 1:2.6.2
40 BuildRequires:  libgnomeprintui-devel >= 2.18.0
41 BuildRequires:  libgnomeui-devel >= 2.22.0
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.28
44 BuildRequires:  libxslt-devel >= 1.1.20
45 BuildRequires:  pkgconfig
46 BuildRequires:  python-gnome-devel >= 2.20.0
47 BuildRequires:  python-pygtk-devel >= 2:2.12.0
48 BuildRequires:  rpmbuild(find_lang) >= 1.23
49 BuildRequires:  rpmbuild(macros) >= 1.311
50 BuildRequires:  scrollkeeper
51 BuildRequires:  startup-notification-devel >= 0.8
52 %if %{without webkit}
53 BuildRequires:  xulrunner
54 BuildRequires:  xulrunner-devel >= 1.8.1.6-1.20070731.2
55 %endif
56 Requires(post,postun):  desktop-file-utils
57 Requires(post,postun):  gtk+2
58 Requires(post,postun):  hicolor-icon-theme
59 Requires(post,postun):  scrollkeeper
60 Requires(post,preun):   GConf2
61 Requires:       dbus >= 1.0.2
62 Requires:       gnome-icon-theme >= 2.22.0
63 Requires:       libgnomeui >= 2.22.0
64 %if %{without webkit}
65 %requires_eq    xulrunner
66 %endif
67 Obsoletes:      python-epiphany
68 # sr@Latn vs. sr@latin
69 Conflicts:      glibc-misc < 6:2.7
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %if %{without webkit}
73 # can be provided by mozilla or mozilla-embedded
74 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
75 # we have strict deps for it
76 %define         _noautoreq      libxpcom.so
77 %endif
78
79 %description
80 GNOME browser based on Gecko (Mozilla rendering engine).
81
82 %description -l es.UTF-8
83 Navigador Web de GNOME basado en Gecko (el engine plasmante de
84 Mozilla).
85
86 %description -l pl.UTF-8
87 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
88 interpretacji stron Mozilli).
89
90 %package devel
91 Summary:        Epiphany header files
92 Summary(es.UTF-8):      Ficheros de cabecera de Epiphany
93 Summary(pl.UTF-8):      Pliki nagłówkowe Epiphany
94 Group:          X11/Applications/Networking
95 # doesn't require base
96 Requires:       gtk+2-devel >= 2:2.12.0
97 Requires:       libxslt-devel >= 1.1.20
98
99 %description devel
100 Epiphany header files for plugin development.
101
102 %description devel -l es.UTF-8
103 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe Epiphany do tworzenia wtyczek.
107
108 %package apidocs
109 Summary:        Epiphany API documentation
110 Summary(pl.UTF-8):      Dokumentacja API Epiphany
111 Group:          Documentation
112 Requires:       gtk-doc-common
113
114 %description apidocs
115 Epiphany API documentation.
116
117 %description apidocs -l pl.UTF-8
118 Dokumentacja API Epiphany.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123 %patch1 -p1
124 %patch2 -p1
125
126 sed -i -e 's#sr\@Latn#sr\@latin#' po/LINGUAS
127 mv po/sr\@{Latn,latin}.po
128
129 %build
130 %{__gnome_doc_prepare}
131 %{__gnome_doc_common}
132 %{__glib_gettextize}
133 %{__intltoolize}
134 %{__libtoolize}
135 %{__aclocal} -I m4
136 %{__autoheader}
137 %{__automake}
138 %{__autoconf}
139 %configure \
140         --disable-schemas-install \
141         --enable-dbus \
142         %{?!with_webkit:--enable-gtk-doc} \
143         --enable-network-manager \
144         --enable-python\
145         --enable-spell-checker \
146         %{?with_webkit:--with-engine=webkit} \
147         --with-html-dir=%{_gtkdocdir}
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT \
156         HTML_DIR=%{_gtkdocdir}
157
158 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
159 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/LowContrastLargePrint
160
161 %find_lang %{name} --with-gnome --with-omf
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post
167 %gconf_schema_install epiphany-fonts.schemas
168 %gconf_schema_install epiphany-lockdown.schemas
169 %gconf_schema_install epiphany-pango.schemas
170 %gconf_schema_install epiphany.schemas
171 %scrollkeeper_update_post
172 %update_desktop_database_post
173 %update_icon_cache hicolor
174
175 %preun
176 %gconf_schema_uninstall epiphany-fonts.schemas
177 %gconf_schema_uninstall epiphany-lockdown.schemas
178 %gconf_schema_uninstall epiphany-pango.schemas
179 %gconf_schema_uninstall epiphany.schemas
180
181 %postun
182 %scrollkeeper_update_postun
183 %update_desktop_database_postun
184 %update_icon_cache hicolor
185
186 %files -f %{name}.lang
187 %defattr(644,root,root,755)
188 %doc AUTHORS ChangeLog NEWS README
189 %attr(755,root,root) %{_bindir}/*
190 %{_datadir}/dbus-1/services/*.service
191 %{_datadir}/%{name}
192 %{_desktopdir}/*.desktop
193 %{_iconsdir}/*/*/apps/*.*
194 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
195 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
196 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
197 %{_sysconfdir}/gconf/schemas/epiphany.schemas
198 %dir %{_libdir}/%{name}
199 %dir %{_libdir}/%{name}/%{basever}
200 %dir %{_libdir}/%{name}/%{basever}/extensions
201 %if %{without webkit}
202 %dir %{_libdir}/%{name}/%{basever}/plugins
203 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
204 %endif
205 %{_mandir}/man1/*
206
207 %files devel
208 %defattr(644,root,root,755)
209 %{_aclocaldir}/*
210 %{_includedir}/epiphany
211 %{_pkgconfigdir}/*.pc
212 %{_datadir}/pygtk/*/defs/epiphany.defs
213
214 %files apidocs
215 %defattr(644,root,root,755)
216 %{_gtkdocdir}/*
This page took 0.354009 seconds and 2 git commands to generate.