]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
70bc01afecf5f644ff5fd622bcdc2293522ef8f8
[packages/epiphany.git] / epiphany.spec
1 #
2 #Conditional build:
3 %bcond_with     webkit          # Build with experimental webkit suppor instead of xulrunner
4 #
5 %define         basever         2.22
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es.UTF-8):      Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl.UTF-8):      Epiphany - przeglądarka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.22.1.1
11 Release:        2
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.22/%{name}-%{version}.tar.bz2
15 # Source0-md5:  24bb8c430a6165b9c43a2ed0452cc6a5
16 Patch0:         %{name}-pld-homepage.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-agent.patch
19 URL:            http://www.gnome.org/projects/epiphany/
20 BuildRequires:  GConf2-devel >= 2.20.0
21 BuildRequires:  NetworkManager-devel
22 BuildRequires:  ORBit2-devel >= 1:2.14.9
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake >= 1:1.9
25 BuildRequires:  dbus-glib-devel >= 0.73
26 BuildRequires:  enchant-devel >= 1.0
27 BuildRequires:  gnome-common >= 2.20.0
28 BuildRequires:  gnome-desktop-devel >= 2.20.0
29 BuildRequires:  gnome-doc-utils >= 0.12.0
30 BuildRequires:  gnome-vfs2-devel >= 2.22.0
31 BuildRequires:  gtk+2-devel >= 2:2.12.0
32 BuildRequires:  gtk-doc >= 1.8
33 %if %{with webkit}
34 BuildRequires:  gtk-webkit-devel
35 BuildRequires:  libssh2-devel
36 %endif
37 BuildRequires:  intltool >= 0.36.2
38 BuildRequires:  iso-codes >= 0.53
39 BuildRequires:  libglade2-devel >= 1:2.6.2
40 BuildRequires:  libgnomeprintui-devel >= 2.18.0
41 BuildRequires:  libgnomeui-devel >= 2.22.0
42 BuildRequires:  libicu-devel
43 BuildRequires:  libtool
44 BuildRequires:  libxml2-devel >= 1:2.6.28
45 BuildRequires:  libxslt-devel >= 1.1.20
46 BuildRequires:  pkgconfig
47 BuildRequires:  python-gnome-devel >= 2.20.0
48 BuildRequires:  python-pygtk-devel >= 2:2.12.0
49 BuildRequires:  rpmbuild(find_lang) >= 1.23
50 BuildRequires:  rpmbuild(macros) >= 1.311
51 BuildRequires:  scrollkeeper
52 BuildRequires:  startup-notification-devel >= 0.8
53 %if %{without webkit}
54 BuildRequires:  xulrunner
55 BuildRequires:  xulrunner-devel >= 1.8.1.6-1.20070731.2
56 %endif
57 Requires(post,postun):  desktop-file-utils
58 Requires(post,postun):  gtk+2
59 Requires(post,postun):  hicolor-icon-theme
60 Requires(post,postun):  scrollkeeper
61 Requires(post,preun):   GConf2
62 Requires:       dbus >= 1.0.2
63 Requires:       gnome-icon-theme >= 2.22.0
64 Requires:       libgnomeui >= 2.22.0
65 %if %{without webkit}
66 %requires_eq    xulrunner
67 %endif
68 Obsoletes:      python-epiphany
69 # sr@Latn vs. sr@latin
70 Conflicts:      glibc-misc < 6:2.7
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %if %{without webkit}
74 # can be provided by mozilla or mozilla-embedded
75 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
76 # we have strict deps for it
77 %define         _noautoreq      libxpcom.so
78 %endif
79
80 %description
81 GNOME browser based on Gecko (Mozilla rendering engine).
82
83 %description -l es.UTF-8
84 Navigador Web de GNOME basado en Gecko (el engine plasmante de
85 Mozilla).
86
87 %description -l pl.UTF-8
88 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
89 interpretacji stron Mozilli).
90
91 %package devel
92 Summary:        Epiphany header files
93 Summary(es.UTF-8):      Ficheros de cabecera de Epiphany
94 Summary(pl.UTF-8):      Pliki nagłówkowe Epiphany
95 Group:          X11/Applications/Networking
96 # doesn't require base
97 Requires:       gtk+2-devel >= 2:2.12.0
98 Requires:       libxslt-devel >= 1.1.20
99
100 %description devel
101 Epiphany header files for plugin development.
102
103 %description devel -l es.UTF-8
104 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
105
106 %description devel -l pl.UTF-8
107 Pliki nagłówkowe Epiphany do tworzenia wtyczek.
108
109 %package apidocs
110 Summary:        Epiphany API documentation
111 Summary(pl.UTF-8):      Dokumentacja API Epiphany
112 Group:          Documentation
113 Requires:       gtk-doc-common
114
115 %description apidocs
116 Epiphany API documentation.
117
118 %description apidocs -l pl.UTF-8
119 Dokumentacja API Epiphany.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124 %patch1 -p1
125 %patch2 -p1
126
127 sed -i -e 's#sr\@Latn#sr\@latin#' po/LINGUAS
128 mv po/sr\@{Latn,latin}.po
129
130 %build
131 %{__gnome_doc_prepare}
132 %{__gnome_doc_common}
133 %{__glib_gettextize}
134 %{__intltoolize}
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoheader}
138 %{__automake}
139 %{__autoconf}
140 %configure \
141         --disable-schemas-install \
142         --enable-dbus \
143         %{?!with_webkit:--enable-gtk-doc} \
144         --enable-network-manager \
145         --enable-python\
146         --enable-spell-checker \
147         %{?with_webkit:--with-engine=webkit} \
148         --with-html-dir=%{_gtkdocdir}
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT \
157         HTML_DIR=%{_gtkdocdir}
158
159 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
160 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/LowContrastLargePrint
161
162 %find_lang %{name} --with-gnome --with-omf
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 %gconf_schema_install epiphany-fonts.schemas
169 %gconf_schema_install epiphany-lockdown.schemas
170 %gconf_schema_install epiphany-pango.schemas
171 %gconf_schema_install epiphany.schemas
172 %scrollkeeper_update_post
173 %update_desktop_database_post
174 %update_icon_cache hicolor
175
176 %preun
177 %gconf_schema_uninstall epiphany-fonts.schemas
178 %gconf_schema_uninstall epiphany-lockdown.schemas
179 %gconf_schema_uninstall epiphany-pango.schemas
180 %gconf_schema_uninstall epiphany.schemas
181
182 %postun
183 %scrollkeeper_update_postun
184 %update_desktop_database_postun
185 %update_icon_cache hicolor
186
187 %files -f %{name}.lang
188 %defattr(644,root,root,755)
189 %doc AUTHORS ChangeLog NEWS README
190 %attr(755,root,root) %{_bindir}/*
191 %{_datadir}/dbus-1/services/*.service
192 %{_datadir}/%{name}
193 %{_desktopdir}/*.desktop
194 %{_iconsdir}/*/*/apps/*.*
195 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
196 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
197 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
198 %{_sysconfdir}/gconf/schemas/epiphany.schemas
199 %dir %{_libdir}/%{name}
200 %dir %{_libdir}/%{name}/%{basever}
201 %dir %{_libdir}/%{name}/%{basever}/extensions
202 %if %{without webkit}
203 %dir %{_libdir}/%{name}/%{basever}/plugins
204 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
205 %endif
206 %{_mandir}/man1/*
207
208 %files devel
209 %defattr(644,root,root,755)
210 %{_aclocaldir}/*
211 %{_includedir}/epiphany
212 %{_pkgconfigdir}/*.pc
213 %{_datadir}/pygtk/*/defs/epiphany.defs
214
215 %files apidocs
216 %defattr(644,root,root,755)
217 %{_gtkdocdir}/*
This page took 0.080081 seconds and 2 git commands to generate.