]> git.pld-linux.org Git - packages/entrance.git/blob - entrance.spec
- pl for themes, strict internal deps
[packages/entrance.git] / entrance.spec
1 #
2 # TODO:
3 #  - when WM finishes to load entrance process fork's (or simply finishes)
4 #    so entranced thinks session has finished and restarts login greeter
5 #
6 Summary:        Enlightened display manager
7 Summary(pl):    O¶wiecony zarz±dca ekranu
8 Name:           entrance
9 Version:        0.9.0.004
10 %define _snap   20051029
11 Release:        1.%{_snap}.1
12 License:        BSD
13 Group:          X11/Applications
14 #Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
15 Source0:        http://sparky.homelinux.org/snaps/enli/e17/apps/%{name}-%{_snap}.tar.bz2
16 # Source0-md5:  6d98baf539649abbe3124a02574fe87f
17 Source1:        %{name}.init
18 Source2:        %{name}.Xsession
19 Source3:        %{name}.gen-conf
20 Patch0:         %{name}-conf.in.patch
21 URL:            http://enlightenment.org/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  edje
25 BuildRequires:  esmart-devel
26 BuildRequires:  libtool
27 BuildRequires:  pam-devel
28 BuildRequires:  sed >= 4.0
29 Requires:       /bin/bash
30 Requires(post,preun):   /sbin/chkconfig
31 Requires:       ecore
32 Requires:       %{name}-theme
33 Requires:       pam
34 Requires:       sessreg
35 Requires:       xinitrc-ng
36 Obsoletes:      X11-xdm
37 Obsoletes:      kdm
38 Obsoletes:      gdm
39 Obsoletes:      wdm
40 Obsoletes:      xdm
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Entrance is the Enlightenment Display Manager. And like Enlightenment,
45 it takes beauty and customization to levels that KDM and GDM can only
46 dream about... and without the bloat.
47
48 %description -l pl
49 Entrance to zarz±dca ekranu (Display Manager) dla Enlightenmenta.
50 Podobnie jak Enlightenment ma piêkno i mo¿liwo¶ci konfiguracji, o
51 jakich KDM czy GDM mog± tylko pomarzyæ... i to bez narzutu.
52
53 %package theme-default
54 Summary:        Default Entrance theme
55 Summary(pl):    Domy¶lny motyw Entrance
56 Group:          X11/Applications
57 Requires:       %{name} = %{version}-%{release}
58 Provides:       %{name}-theme
59
60 %description theme-default
61 Default Entrance theme.
62
63 %description theme-default -l pl
64 Domy¶lny motyw Entrance.
65
66 %package theme-Nebulous
67 Summary:        Nebulous Entrance theme
68 Summary(pl):    Motyw Entrance Nebulous
69 Group:          X11/Applications
70 Requires:       %{name} = %{version}-%{release}
71 Provides:       %{name}-theme
72
73 %description theme-Nebulous
74 Nebulous Entrance theme.
75
76 %description theme-Nebulous -l pl
77 Motyw Entrance Nebulous.
78
79 %package theme-darkrock
80 Summary:        Darkrock Entrance theme
81 Summary(pl):    Motyw Entrance Darkrock
82 Group:          X11/Applications
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       %{name}-theme
85
86 %description theme-darkrock
87 Darkrock Entrance theme.
88
89 %description theme-darkrock -l pl
90 Motyw Entrance Darkrock.
91
92 %package theme-taillights
93 Summary:        Taillights Entrance theme
94 Summary(pl):    Motyw Entrance Taillights
95 Group:          X11/Applications
96 Requires:       %{name} = %{version}-%{release}
97 Provides:       %{name}-theme
98
99 %description theme-taillights
100 Taillights Entrance theme.
101
102 %description theme-taillights -l pl
103 Motyw Entrance Taillights.
104
105 %prep
106 %setup -q -n %{name}
107 %patch0 -p1
108 mv data/images/sessions/enlightenment{,DR17}.png
109 sed 's/enlightenment.png/enlightenmentDR17.png/' \
110         -i data/images/sessions/Makefile.am
111
112 sed '/PACKAGE_CFG_DIR/s@"${sysconfdir}"@"${localstatedir}/lib/${PACKAGE}"@' \
113         -i configure.in
114 sed -n '/xsession="You should reconfigure --with-xsession"/!p' \
115         -i configure.in
116 sed 's|/bin/sh|/bin/bash|g' \
117         -i src/daemon/spawner.c
118
119 %build
120 %{__libtoolize}
121 %{__aclocal} -I m4
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         --with-xsession=%{_sysconfdir}/X11/%{name}/Xsession
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/X11/%{name},/etc/rc.d/init.d,%{_var}/lib/%{name}}
136 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/entrance
137 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/Xsession
138 install %{SOURCE3} \
139         $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/generate-config
140 install data/config/build_config.sh.in \
141         $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/
142 touch $RPM_BUILD_ROOT%{_var}/lib/%{name}/entrance_config.cfg
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 /sbin/chkconfig --add entrance
149 if [ -f /var/lock/subsys/entrance ]; then
150         echo "Run \"/etc/rc.d/init.d/entrance restart\" to restart entrance." >&2
151 else
152         echo "Run \"/etc/rc.d/init.d/entrance start\" to start entrance." >&2
153 fi
154
155 %preun
156 if [ "$1" = "0" ]; then
157         if [ -f /var/lock/subsys/entrance ]; then
158                 /etc/rc.d/init.d/entrance stop >&2
159         fi
160         /sbin/chkconfig --del entrance
161 fi
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS COPYING* README
166 %attr(754,root,root) /etc/rc.d/init.d/entrance
167 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/entrance
168 %attr(755,root,root) %{_bindir}/entrance*
169 %attr(755,root,root) %{_sbindir}/entranced
170 %dir %{_datadir}/%{name}
171 %{_datadir}/%{name}/images
172 %dir %{_datadir}/%{name}/themes
173 %{_datadir}/%{name}/users
174 %dir %{_sysconfdir}/X11/%{name}
175 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/Xsession
176 %attr(755,root,root) %{_sysconfdir}/X11/%{name}/generate-config
177 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/build_config.sh.in
178 %dir %{_var}/lib/%{name}
179 %ghost %{_var}/lib/%{name}/entrance_config.cfg
180
181 %files theme-default
182 %defattr(644,root,root,755)
183 %{_datadir}/%{name}/themes/default.edj
184
185 %files theme-Nebulous
186 %defattr(644,root,root,755)
187 %{_datadir}/%{name}/themes/Nebulous.edj
188
189 %files theme-darkrock
190 %defattr(644,root,root,755)
191 %{_datadir}/%{name}/themes/darkrock.edj
192
193 %files theme-taillights
194 %defattr(644,root,root,755)
195 %{_datadir}/%{name}/themes/taillights.edj
This page took 0.083225 seconds and 3 git commands to generate.