]> git.pld-linux.org Git - packages/entrance.git/blob - entrance.spec
- added TODO, entrance works but is unusable
[packages/entrance.git] / entrance.spec
1 #
2 # TODO:
3 #  - when WM finishes to load entrance process fork's (or simply finishes)
4 #    so entranced thinks session has finished and restarts login greeter
5 #
6 Summary:        Enlightened display manager
7 Summary(pl):    O¶wiecony zarz±dca ekranu
8 Name:           entrance
9 Version:        0.9.0.004
10 %define _snap   20051029
11 Release:        1.%{_snap}.1
12 License:        BSD
13 Group:          X11/Applications
14 #Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
15 Source0:        http://sparky.homelinux.org/snaps/enli/e17/apps/%{name}-%{_snap}.tar.bz2
16 # Source0-md5:  6d98baf539649abbe3124a02574fe87f
17 Source1:        %{name}.init
18 Source2:        %{name}.Xsession
19 Source3:        %{name}.gen-conf
20 Patch0:         %{name}-conf.in.patch
21 URL:            http://enlightenment.org/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  edje
25 BuildRequires:  esmart-devel
26 BuildRequires:  libtool
27 BuildRequires:  pam-devel
28 BuildRequires:  sed >= 4.0
29 Requires:       /bin/bash
30 Requires(post,preun):   /sbin/chkconfig
31 Requires:       ecore
32 Requires:       %{name}-theme
33 Requires:       pam
34 Requires:       sessreg
35 Requires:       xinitrc-ng
36 Obsoletes:      X11-xdm
37 Obsoletes:      kdm
38 Obsoletes:      gdm
39 Obsoletes:      wdm
40 Obsoletes:      xdm
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Entrance is the Enlightenment Display Manager. And like Enlightenment,
45 it takes beauty and customization to levels that KDM and GDM can only
46 dream about... and without the bloat.
47
48 %description -l pl
49 Entrance to zarz±dca ekranu (Display Manager) dla Enlightenmenta.
50 Podobnie jak Enlightenment ma piêkno i mo¿liwo¶ci konfiguracji, o
51 jakich KDM czy GDM mog± tylko pomarzyæ... i to bez narzutu.
52
53 %package theme-default
54 Summary:        Default Entrance theme
55 Group:          X11/Applications
56 Requires:       %{name}
57 Provides:       %{name}-theme
58
59 %description theme-default
60 Default Entrance theme.
61
62 %package theme-Nebulous
63 Summary:        Nebulous Entrance theme
64 Group:          X11/Applications
65 Requires:       %{name}
66 Provides:       %{name}-theme
67
68 %description theme-Nebulous
69 Nebulous Entrance theme.
70
71 %package theme-darkrock
72 Summary:        Darkrock Entrance theme
73 Group:          X11/Applications
74 Requires:       %{name}
75 Provides:       %{name}-theme
76
77 %description theme-darkrock
78 Darkrock Entrance theme.
79
80 %package theme-taillights
81 Summary:        Taillights Entrance theme
82 Group:          X11/Applications
83 Requires:       %{name}
84 Provides:       %{name}-theme
85
86 %description theme-taillights
87 Taillights Entrance theme.
88
89 %prep
90 %setup -q -n %{name}
91 %patch0 -p1
92 mv data/images/sessions/enlightenment{,DR17}.png
93 sed 's/enlightenment.png/enlightenmentDR17.png/' \
94         -i data/images/sessions/Makefile.am
95
96 sed '/PACKAGE_CFG_DIR/s@"${sysconfdir}"@"${localstatedir}/lib/${PACKAGE}"@' \
97         -i configure.in
98 sed -n '/xsession="You should reconfigure --with-xsession"/!p' \
99         -i configure.in
100 sed 's|/bin/sh|/bin/bash|g' \
101         -i src/daemon/spawner.c
102
103 %build
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --with-xsession=%{_sysconfdir}/X11/%{name}/Xsession
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/X11/%{name},/etc/rc.d/init.d,%{_var}/lib/%{name}}
120 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/entrance
121 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/Xsession
122 install %{SOURCE3} \
123         $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/generate-config
124 install data/config/build_config.sh.in \
125         $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/
126 touch $RPM_BUILD_ROOT%{_var}/lib/%{name}/entrance_config.cfg
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 /sbin/chkconfig --add entrance
133 if [ -f /var/lock/subsys/entrance ]; then
134         echo "Run \"/etc/rc.d/init.d/entrance restart\" to restart entrance." >&2
135 else
136         echo "Run \"/etc/rc.d/init.d/entrance start\" to start entrance." >&2
137 fi
138
139 %preun
140 if [ "$1" = "0" ]; then
141         if [ -f /var/lock/subsys/entrance ]; then
142                 /etc/rc.d/init.d/entrance stop >&2
143         fi
144         /sbin/chkconfig --del entrance
145 fi
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS COPYING* README
150 %attr(754,root,root) /etc/rc.d/init.d/entrance
151 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/entrance
152 %attr(755,root,root) %{_bindir}/entrance*
153 %attr(755,root,root) %{_sbindir}/entranced
154 %dir %{_datadir}/%{name}
155 %{_datadir}/%{name}/images
156 %dir %{_datadir}/%{name}/themes
157 %{_datadir}/%{name}/users
158 %dir %{_sysconfdir}/X11/%{name}
159 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/Xsession
160 %attr(755,root,root) %{_sysconfdir}/X11/%{name}/generate-config
161 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/build_config.sh.in
162 %dir %{_var}/lib/%{name}
163 %ghost %{_var}/lib/%{name}/entrance_config.cfg
164
165 %files theme-default
166 %defattr(644,root,root,755)
167 %{_datadir}/%{name}/themes/default.edj
168
169 %files theme-Nebulous
170 %defattr(644,root,root,755)
171 %{_datadir}/%{name}/themes/Nebulous.edj
172
173 %files theme-darkrock
174 %defattr(644,root,root,755)
175 %{_datadir}/%{name}/themes/darkrock.edj
176
177 %files theme-taillights
178 %defattr(644,root,root,755)
179 %{_datadir}/%{name}/themes/taillights.edj
This page took 0.04347 seconds and 3 git commands to generate.