]> git.pld-linux.org Git - packages/entrance.git/blob - entrance.spec
- unified preamble in %changelog
[packages/entrance.git] / entrance.spec
1 %define         ecore_ver       0.9.9.044
2 %define         edje_ver        0.9.9.044
3 %define         efreet_ver      0.0.3.005
4 %define         esmart_ver      0.9.0.043
5 %define         evas_ver        0.9.9.044
6
7 %define         _snap   20080823
8
9 Summary:        Enlightened display manager
10 Summary(pl.UTF-8):      Oświecony zarządca ekranu
11 Name:           entrance
12 Version:        0.9.9.043
13 Release:        0.%{_snap}.1
14 License:        BSD
15 Group:          X11/Applications
16 Source0:        %{name}-%{version}-%{_snap}.tar.bz2
17 # Source0-md5:  8c33ec9d4890dab98ad620333cedff1a
18 Source1:        %{name}.init
19 Source2:        %{name}.Xsession
20 URL:            http://enlightenment.org/
21 BuildRequires:  autoconf >= 2.59-9
22 BuildRequires:  automake >= 1.6
23 # ecore ecore-evas ecore-file ecore-ipc ecore-config
24 BuildRequires:  ecore-devel >= %{ecore_ver}
25 BuildRequires:  edje >= %{edje_ver}
26 BuildRequires:  edje-devel >= %{edje_ver}
27 BuildRequires:  efreet-devel >= %{efreet_ver}
28 # esmart_container esmart_text_entry
29 BuildRequires:  esmart-devel >= %{esmart_ver}
30 BuildRequires:  evas-devel >= %{evas_ver}
31 BuildRequires:  evas-loader-jpeg >= %{evas_ver}
32 BuildRequires:  libtool
33 BuildRequires:  pam-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  sed >= 4.0
36 Requires(post,preun):   /sbin/chkconfig
37 Requires:       %{name}-libs = %{version}-%{release}
38 Requires:       %{name}-theme
39 #Requires:      /bin/bash
40 Requires:       ecore >= %{ecore_ver}
41 Requires:       efreet >= %{efreet_ver}
42 Requires:       evas-engine-software_x11 >= %{evas_ver}
43 Requires:       evas-loader-eet >= %{evas_ver}
44 Requires:       pam
45 Requires:       sessreg
46 Requires:       xinitrc-ng
47 Provides:       XDM
48 # disappeared from 0.9.0.009
49 Obsoletes:      entrance-theme-Nebulous < 0.9.0.009
50 Obsoletes:      entrance-theme-taillights < 0.9.0.009
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Entrance is the Enlightenment Display Manager. And like Enlightenment,
55 it takes beauty and customization to levels that KDM and GDM can only
56 dream about... and without the bloat.
57
58 %description -l pl.UTF-8
59 Entrance to zarządca ekranu (Display Manager) dla Enlightenmenta.
60 Podobnie jak Enlightenment ma piękno i możliwości konfiguracji, o
61 jakich KDM czy GDM mogą tylko pomarzyć... i to bez narzutu.
62
63 %package libs
64 Summary:        Entrance library
65 Summary(pl.UTF-8):      Biblioteka Entrance
66 Group:          X11/Libraries
67 Requires:       ecore-config >= %{ecore_ver}
68 Requires:       ecore-desktop >= %{ecore_ver}
69 Requires:       ecore-evas >= %{ecore_ver}
70 Requires:       ecore-file >= %{ecore_ver}
71 Requires:       ecore-ipc >= %{ecore_ver}
72
73 %description libs
74 Entrance library.
75
76 %description libs -l pl.UTF-8
77 Biblioteka Entrance.
78
79 %package devel
80 Summary:        Header file for Entrance library
81 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Entrance
82 Group:          X11/Development/Libraries
83 Requires:       %{name}-libs = %{version}-%{release}
84 # ecore-evas ecore-file ecore-ipc ecore-config ecore-desktop
85 Requires:       ecore-devel >= %{ecore_ver}
86
87 %description devel
88 Header file for Entrance library.
89
90 %description devel -l pl.UTF-8
91 Plik nagłówkowy biblioteki Entrance.
92
93 %package static
94 Summary:        Static Entrance library
95 Summary(pl.UTF-8):      Statyczna biblioteka Entrance
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static Entrance library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka Entrance.
104
105 %package theme-default
106 Summary:        Default Entrance theme
107 Summary(pl.UTF-8):      Domyślny motyw Entrance
108 Group:          X11/Applications
109 Requires:       %{name} = %{version}-%{release}
110 Provides:       %{name}-theme
111
112 %description theme-default
113 Default Entrance theme.
114
115 %description theme-default -l pl.UTF-8
116 Domyślny motyw Entrance.
117
118 %package theme-darkrock
119 Summary:        Darkrock Entrance theme
120 Summary(pl.UTF-8):      Motyw Entrance Darkrock
121 Group:          X11/Applications
122 Requires:       %{name} = %{version}-%{release}
123 Provides:       %{name}-theme
124
125 %description theme-darkrock
126 Darkrock Entrance theme.
127
128 %description theme-darkrock -l pl.UTF-8
129 Motyw Entrance Darkrock.
130
131 %prep
132 %setup -q -n %{name}-%{version}-%{_snap}
133
134 %build
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140 %configure \
141         --with-pam-config=entrance \
142         --with-vt=9 \
143         --with-xsession=%{_datadir}/%{name}/Xsession \
144         --with-xbin=%{_bindir}
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},/etc/rc.d/init.d}
154 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/entrance
155 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/entrance/Xsession
156 install data/config/build_config.sh $RPM_BUILD_ROOT%{_datadir}/%{name}
157 sed -e 's|./entrance_config.cfg|%{_sysconfdir}/entrance_config.cfg|g' -i $RPM_BUILD_ROOT%{_datadir}/%{name}/build_config.sh
158 install data/config/entrance_config.cfg $RPM_BUILD_ROOT/%{_sysconfdir}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post
164 /sbin/chkconfig --add entrance
165 if [ -f /var/lock/subsys/entrance ]; then
166         echo "Run \"service entrance restart\" to restart entrance." >&2
167 else
168         echo "Run \"service entrance start\" to start entrance." >&2
169 fi
170
171 %preun
172 if [ "$1" = "0" ]; then
173         if [ -f /var/lock/subsys/entrance ]; then
174                 /etc/rc.d/init.d/entrance stop >&2
175         fi
176         /sbin/chkconfig --del entrance
177 fi
178
179 %post   libs -p /sbin/ldconfig
180 %postun libs -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS COPYING ChangeLog README README.edje TODO
185 %attr(754,root,root) /etc/rc.d/init.d/entrance
186 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/entrance
187 %attr(755,root,root) %{_bindir}/entrance
188 %attr(755,root,root) %{_bindir}/entrance_edit
189 %attr(755,root,root) %{_bindir}/entrance_edit-config
190 %attr(755,root,root) %{_bindir}/entrance_wrapper
191 %attr(755,root,root) %{_sbindir}/entranced
192 %dir %{_libdir}/%{name}
193 %attr(755,root,root) %{_libdir}/%{name}/entrance_login
194 %dir %{_datadir}/%{name}
195 %{_datadir}/%{name}/images
196 %dir %{_datadir}/%{name}/themes
197 %{_datadir}/%{name}/users
198 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/entrance_config.cfg
199 %attr(755,root,root) %{_datadir}/%{name}/build_config.sh
200 %attr(755,root,root) %{_datadir}/%{name}/Xsession
201
202 %files libs
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/libentrance_edit.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libentrance_edit.so.0
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libentrance_edit.so
210 %{_libdir}/libentrance_edit.la
211 %{_includedir}/Entrance_Edit.h
212
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libentrance_edit.a
216
217 %files theme-default
218 %defattr(644,root,root,755)
219 %{_datadir}/%{name}/themes/default.edj
220
221 %files theme-darkrock
222 %defattr(644,root,root,755)
223 %{_datadir}/%{name}/themes/darkrock.edj
This page took 0.079105 seconds and 3 git commands to generate.