]> git.pld-linux.org Git - packages/entrance.git/blob - entrance.spec
255dd08115b274a7b09661bcd112b5799a94404e
[packages/entrance.git] / entrance.spec
1 #
2 # TODO:
3 #  - when WM finishes to load entrance process fork's (or simply finishes)
4 #    so entranced thinks session has finished and restarts login greeter
5 #
6 Summary:        Enlightened display manager
7 Summary(pl):    O¶wiecony zarz±dca ekranu
8 Name:           entrance
9 Version:        0.9.0.007
10 #%define        _snap   20060307
11 Release:        1
12 #.%{_snap}.1
13 License:        BSD
14 Group:          X11/Applications
15 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
16 # Source0-md5:  b789d09fa76e76a6466a786f0628d0ff
17 #Source0:       http://sparky.homelinux.org/snaps/enli/e17/apps/%{name}-%{_snap}.tar.bz2
18 Source1:        %{name}.init
19 Source2:        %{name}.Xsession
20 Source3:        %{name}.gen-conf
21 Patch0:         %{name}-conf.in.patch
22 Patch1:         %{name}-use_bash.patch
23 URL:            http://enlightenment.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  edje
27 BuildRequires:  esmart-devel
28 BuildRequires:  libtool
29 BuildRequires:  pam-devel
30 BuildRequires:  sed >= 4.0
31 Requires:       /bin/bash
32 Requires(post,preun):   /sbin/chkconfig
33 Requires:       ecore
34 Requires:       %{name}-theme
35 Requires:       pam
36 Requires:       sessreg
37 Requires:       xinitrc-ng
38 Obsoletes:      X11-xdm
39 Obsoletes:      kdm
40 Obsoletes:      gdm
41 Obsoletes:      wdm
42 Obsoletes:      xdm
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Entrance is the Enlightenment Display Manager. And like Enlightenment,
47 it takes beauty and customization to levels that KDM and GDM can only
48 dream about... and without the bloat.
49
50 %description -l pl
51 Entrance to zarz±dca ekranu (Display Manager) dla Enlightenmenta.
52 Podobnie jak Enlightenment ma piêkno i mo¿liwo¶ci konfiguracji, o
53 jakich KDM czy GDM mog± tylko pomarzyæ... i to bez narzutu.
54
55 %package theme-default
56 Summary:        Default Entrance theme
57 Summary(pl):    Domy¶lny motyw Entrance
58 Group:          X11/Applications
59 Requires:       %{name} = %{version}-%{release}
60 Provides:       %{name}-theme
61
62 %description theme-default
63 Default Entrance theme.
64
65 %description theme-default -l pl
66 Domy¶lny motyw Entrance.
67
68 %package theme-Nebulous
69 Summary:        Nebulous Entrance theme
70 Summary(pl):    Motyw Entrance Nebulous
71 Group:          X11/Applications
72 Requires:       %{name} = %{version}-%{release}
73 Provides:       %{name}-theme
74
75 %description theme-Nebulous
76 Nebulous Entrance theme.
77
78 %description theme-Nebulous -l pl
79 Motyw Entrance Nebulous.
80
81 %package theme-darkrock
82 Summary:        Darkrock Entrance theme
83 Summary(pl):    Motyw Entrance Darkrock
84 Group:          X11/Applications
85 Requires:       %{name} = %{version}-%{release}
86 Provides:       %{name}-theme
87
88 %description theme-darkrock
89 Darkrock Entrance theme.
90
91 %description theme-darkrock -l pl
92 Motyw Entrance Darkrock.
93
94 %package theme-taillights
95 Summary:        Taillights Entrance theme
96 Summary(pl):    Motyw Entrance Taillights
97 Group:          X11/Applications
98 Requires:       %{name} = %{version}-%{release}
99 Provides:       %{name}-theme
100
101 %description theme-taillights
102 Taillights Entrance theme.
103
104 %description theme-taillights -l pl
105 Motyw Entrance Taillights.
106
107 %prep
108 %setup -q
109 # -n %{name}
110 %patch0 -p1
111 %patch1 -p1
112 mv data/images/sessions/enlightenment{,DR17}.png
113 sed 's/enlightenment.png/enlightenmentDR17.png/' \
114         -i data/images/sessions/Makefile.am
115
116 sed '/PACKAGE_CFG_DIR/s@"${sysconfdir}"@"${localstatedir}/lib/${PACKAGE}"@' \
117         -i configure.in
118 sed -n '/xsession="You should reconfigure --with-xsession"/!p' \
119         -i configure.in
120
121 %build
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --with-xsession=%{_sysconfdir}/X11/%{name}/Xsession
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/X11/%{name},/etc/rc.d/init.d,%{_var}/lib/%{name}}
138 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/entrance
139 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/Xsession
140 install %{SOURCE3} \
141         $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/generate-config
142 install data/config/build_config.sh.in \
143         $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/
144 touch $RPM_BUILD_ROOT%{_var}/lib/%{name}/entrance_config.cfg
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/chkconfig --add entrance
151 if [ -f /var/lock/subsys/entrance ]; then
152         echo "Run \"/etc/rc.d/init.d/entrance restart\" to restart entrance." >&2
153 else
154         echo "Run \"/etc/rc.d/init.d/entrance start\" to start entrance." >&2
155 fi
156
157 %preun
158 if [ "$1" = "0" ]; then
159         if [ -f /var/lock/subsys/entrance ]; then
160                 /etc/rc.d/init.d/entrance stop >&2
161         fi
162         /sbin/chkconfig --del entrance
163 fi
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS COPYING* README
168 %attr(754,root,root) /etc/rc.d/init.d/entrance
169 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/entrance
170 %attr(755,root,root) %{_bindir}/entrance*
171 %attr(755,root,root) %{_sbindir}/entranced
172 %dir %{_datadir}/%{name}
173 %{_datadir}/%{name}/images
174 %dir %{_datadir}/%{name}/themes
175 %{_datadir}/%{name}/users
176 %dir %{_sysconfdir}/X11/%{name}
177 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/Xsession
178 %attr(755,root,root) %{_sysconfdir}/X11/%{name}/generate-config
179 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/build_config.sh.in
180 %dir %{_var}/lib/%{name}
181 %ghost %{_var}/lib/%{name}/entrance_config.cfg
182
183 %files theme-default
184 %defattr(644,root,root,755)
185 %{_datadir}/%{name}/themes/default.edj
186
187 %files theme-Nebulous
188 %defattr(644,root,root,755)
189 %{_datadir}/%{name}/themes/Nebulous.edj
190
191 %files theme-darkrock
192 %defattr(644,root,root,755)
193 %{_datadir}/%{name}/themes/darkrock.edj
194
195 %files theme-taillights
196 %defattr(644,root,root,755)
197 %{_datadir}/%{name}/themes/taillights.edj
This page took 0.104076 seconds and 2 git commands to generate.