]> git.pld-linux.org Git - packages/enscript.git/commitdiff
- automake and autoconf fixes.
authorkloczek <kloczek@pld-linux.org>
Thu, 13 Dec 2001 22:22:24 +0000 (22:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    enscript-ac_fix.patch -> 1.2
    enscript-ac_fixes.patch -> 1.1
    enscript-am_fixes.patch -> 1.1

enscript-ac_fix.patch [deleted file]
enscript-ac_fixes.patch [new file with mode: 0644]
enscript-am_fixes.patch [new file with mode: 0644]

diff --git a/enscript-ac_fix.patch b/enscript-ac_fix.patch
deleted file mode 100644 (file)
index 3b1cbeb..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./configure.in.org Thu Jun 25 08:37:22 1998
-+++ ./configure.in     Wed Dec 12 22:51:10 2001
-@@ -8,7 +8,7 @@
- AC_REVISION($Revision$)
--AM_PROG_INSTALL
-+AC_PROG_INSTALL
- AC_ARG_WITH(cc,
- [  --with-cc(=CC)       use system's native compiler (or compiler CC)],
diff --git a/enscript-ac_fixes.patch b/enscript-ac_fixes.patch
new file mode 100644 (file)
index 0000000..7013de1
--- /dev/null
@@ -0,0 +1,58 @@
+--- ./configure.in.org Thu Jun 25 08:37:22 1998
++++ ./configure.in     Wed Dec 12 22:51:10 2001
+@@ -8,25 +8,9 @@
+ AC_REVISION($Revision$)
+-AM_PROG_INSTALL
++AC_PROG_INSTALL
+-AC_ARG_WITH(cc,
+-[  --with-cc(=CC)       use system's native compiler (or compiler CC)],
+-  if test "X$withval" != "Xno"; then
+-    if test "X$withval" = "Xyes"; then
+-      CC='cc'
+-    else
+-      CC=$withval
+-    fi
+-    CFLAGS="$CFLAGS -I/usr/local/include"
+-    LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-    echo "using compiler CC=$CC"
+-  fi
+-)
+-
+-if test "X$CC" = "X"; then
+-  AC_PROG_CC
+-fi
++AC_PROG_CC
+ AC_ISC_POSIX
+ AM_C_PROTOTYPES
+@@ -69,14 +53,6 @@
+ AC_PROG_YACC
+ AM_PROG_LEX
+-AC_ARG_ENABLE(debug,
+-[  --enable-debug       enable debugging], [
+-  echo enabling debugging
+-  if test -n "$GCC"; then
+-    CFLAGS="$CFLAGS -Wall"
+-  fi
+-])
+-
+ dnl Define the default output media.
+ AC_ARG_WITH(media,
+@@ -140,12 +116,6 @@
+ AC_PATH_PROG(PERL, perl)
+-dnl substitutions
+-
+-AC_SUBST(CFLAGS)
+-AC_SUBST(LDFLAGS)
+-AC_SUBST(LIBOBJS)
+-
+ AC_OUTPUT([Makefile enscript.1 compat/Makefile afm/Makefile afmlib/Makefile src/Makefile lib/Makefile scripts/Makefile intl/Makefile po/Makefile.in states/Makefile states/states.1 states/tests/Makefile tests/Makefile], [sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in >po/Makefile])
+ echo ""
diff --git a/enscript-am_fixes.patch b/enscript-am_fixes.patch
new file mode 100644 (file)
index 0000000..bf898ca
--- /dev/null
@@ -0,0 +1,60 @@
+--- enscript-1.6.1/compat/Makefile.am~ Thu Dec 13 21:16:15 2001
++++ enscript-1.6.1/compat/Makefile.am  Thu Dec 13 21:16:15 2001
+@@ -28,8 +28,6 @@
+ noinst_LIBRARIES = libcompat.a
+ libcompat_a_SOURCES = getopt.c getopt1.c xalloc.c regex.c
+-libcompat_a_LIBADD = @LIBOBJS@ @ALLOCA@
+-libcompat_a_DEPENDENCIES = @LIBOBJS@ @ALLOCA@
+ noinst_HEADERS = dummypwd.h getopt.h regex.h xalloc.h
+--- enscript-1.6.1/lib/Makefile.am~    Thu Dec 13 21:20:28 2001
++++ enscript-1.6.1/lib/Makefile.am     Thu Dec 13 21:20:28 2001
+@@ -37,12 +37,8 @@
+ all-local: enscript.cfg
+ install-data-local: enscript.cfg
+-      $(top_srcdir)/mkinstalldirs $(sysconfdir)
+-      if test -r $(sysconfdir)/enscript.cfg; then \
+-        cp $(sysconfdir)/enscript.cfg $(sysconfdir)/enscript.cfg.old; \
+-      else :; \
+-      fi
+-      $(INSTALL_DATA) enscript.cfg $(sysconfdir)/enscript.cfg
++      $(top_srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
++      $(INSTALL_DATA) enscript.cfg $(DESTDIR)$(sysconfdir)/enscript.cfg
+ uninstall-local:
+       rm -f $(sysconfdir)/enscript.cfg
+--- enscript-1.6.1/states/Makefile.am~ Thu Dec 13 23:09:11 2001
++++ enscript-1.6.1/states/Makefile.am  Thu Dec 13 23:09:11 2001
+@@ -33,14 +33,14 @@
+ bin_PROGRAMS = states
+ states_SOURCES = main.c utils.c prims.c process.c gram.y lex.l
+-LDADD = ../afmlib/libafm.a @INTLLIBS@ ../compat/libcompat.a @LEXLIB@
+-states_DEPENDENCIES = @INTLLIBS@ ../compat/libcompat.a
++LDADD = ../afmlib/libafm.a $(INTLLIBS) ../compat/libcompat.a $(LEXLIB)
++states_DEPENDENCIES = $(INTLLIBS) ../compat/libcompat.a
+ noinst_HEADERS = defs.h gram.h
+ EXTRA_DIST = states.1.in TODO enscript.st over.in enscript.el
+-localedir = $(prefix)/@DATADIRNAME@/locale
++localedir = $(datadir)/locale
+ bin_SCRIPTS = over
+@@ -53,9 +53,5 @@
+ DEFS = @DEFS@ -DLOCALEDIR=\"$(localedir)\" -I. -I$(srcdir) -I..
+ INCLUDES = -I$(srcdir)/../compat -I$(srcdir)/../afmlib -I$(srcdir)/../intl -I../intl
+-install-data-local: enscript.st
+-      $(top_srcdir)/mkinstalldirs $(datadir)/enscript
+-      $(INSTALL_DATA) $(srcdir)/enscript.st $(datadir)/enscript/enscript.st
+-
+-uninstall-local:
+-      rm -f $(datadir)/enscript/enscript.st
++stdir = $(pkgdatadir)
++st_DATA = enscript.st
This page took 0.170622 seconds and 4 git commands to generate.