]> git.pld-linux.org Git - packages/enchant2.git/commitdiff
- updated to 2.2.8 auto/th/enchant2-2.2.8-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 2 Mar 2020 14:44:22 +0000 (15:44 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 2 Mar 2020 14:44:22 +0000 (15:44 +0100)
- build nuspell provider
- added link patch (when linking with libaspell and libhspell, link only particular provider module, not everything; inspired by Fedora)
- drop outdated -fpermissive

enchant2-link.patch [new file with mode: 0644]
enchant2.spec

diff --git a/enchant2-link.patch b/enchant2-link.patch
new file mode 100644 (file)
index 0000000..630510a
--- /dev/null
@@ -0,0 +1,36 @@
+--- enchant-2.2.8/configure.ac.orig    2020-02-27 16:32:32.000000000 +0100
++++ enchant-2.2.8/configure.ac 2020-03-01 21:32:41.372171295 +0100
+@@ -189,7 +189,7 @@
+       [_enchant_header=m4_default([$6], [$1[].h])
+       AC_CHECK_HEADERS([$_enchant_header], [_header_found=yes], [_header_found=no], [])
+       if test "$3" != NOLIB; then
+-         AC_CHECK_LIB([$1], [$3],,, [$5])
++         AC_CHECK_LIB([$1], [$3],[:],, [$5])
+       else
+          ac_cv_lib_[]$1[]_[]$3=yes
+       fi
+@@ -201,7 +201,10 @@
+       else
+          with_[]$1=yes
+          build_providers="$build_providers $1"
+-         LIBS="$LIBS $5"
++         if test "$3" != NOLIB; then
++         $2[]_LIBS="-l$1 $5"
++         fi
++         AC_SUBST($2[]_LIBS)
+       fi])
+    AM_CONDITIONAL(WITH_[]$2, test "x$with_[]$1" = xyes)])
+--- enchant-2.2.8/providers/Makefile.am.orig   2020-02-27 14:05:18.000000000 +0100
++++ enchant-2.2.8/providers/Makefile.am        2020-03-01 21:34:09.391694452 +0100
+@@ -20,6 +20,10 @@
+ if WITH_HUNSPELL
+ provider_LTLIBRARIES += enchant_hunspell.la
+ endif
++enchant_aspell_la_LIBADD = $(ASPELL_LIBS)
++
++enchant_hspell_la_LIBADD = $(HSPELL_LIBS)
++
+ enchant_hunspell_la_CXXFLAGS = $(AM_CXXFLAGS) $(HUNSPELL_CFLAGS)
+ enchant_hunspell_la_LIBADD = $(HUNSPELL_LIBS)
+ enchant_hunspell_la_SOURCES = enchant_hunspell.cpp
index 7e3f7f90bf57f9c75e1fa6a3db4603a58a411e62..8be32634911a62076bc46c3f1edac0024e5e1792 100644 (file)
@@ -5,22 +5,25 @@
 Summary:       libenchant - generic spell checking library
 Summary(pl.UTF-8):     libenchant - ogólna biblioteka sprawdzania pisowni
 Name:          enchant2
-Version:       2.2.7
+Version:       2.2.8
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
 Source0:       https://github.com/AbiWord/enchant/releases/download/v%{version}/enchant-%{version}.tar.gz
-# Source0-md5: 8a6ea1bb143c64e0edf5e49c7e7cb984
+# Source0-md5: c7b9d6a392ecb8758e499f783e8dc883
+Patch0:                %{name}-link.patch
 URL:           https://github.com/AbiWord/enchant
 BuildRequires: aspell-devel >= 2:0.50.0
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: dbus-glib-devel >= 0.62
 BuildRequires: glib2-devel >= 1:2.12.0
 BuildRequires: hspell-devel >= 0.9-3
 BuildRequires: hunspell-devel
-BuildRequires: libtool
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: libtool >= 2:2
 BuildRequires: libvoikko-devel
+BuildRequires: nuspell-devel
 BuildRequires: pkgconfig
 Requires:      glib2 >= 1:2.12.0
 Suggests:      %{name}-backend
@@ -133,6 +136,19 @@ hunspell provider module for Enchant.
 %description hunspell -l pl.UTF-8
 Moduł obsługujący hunspella dla Enchanta.
 
+%package nuspell
+Summary:       nuspell provider module for Enchant
+Summary(pl.UTF-8):     Moduł obsługujący nuspella dla Enchanta
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-backend
+
+%description nuspell
+nuspell provider module for Enchant.
+
+%description nuspell -l pl.UTF-8
+Moduł obsługujący nuspella dla Enchanta.
+
 %package voikko
 Summary:       Voikko provider module for Enchant
 Summary(pl.UTF-8):     Moduł obsługujący backend voikko dla Enchanta
@@ -162,22 +178,21 @@ Moduł obsługujący backend zemberek (turecki) dla Enchanta.
 
 %prep
 %setup -q -n enchant-%{version}
+%patch0 -p1
 
 %build
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
 %{__automake}
-export CFLAGS="%{rpmcflags} -fpermissive"
-export CXXFLAGS="%{rpmcxxflags} -fpermissive"
 %configure \
-       --enable-relocatable \
        %{!?with_static_libs:--disable-static} \
        --with-aspell \
        --with-hspell \
-       --with-zemberek \
        --with-hunspell \
-       --with-hunspell-dir=/usr/share/myspell
+       --with-hunspell-dir=/usr/share/myspell \
+       --with-nuspell \
+       --with-zemberek
 
 %{__make} \
        pkgdatadir=%{_datadir}/enchant-2
@@ -236,6 +251,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/enchant-2/enchant_hunspell.so
 
+%files nuspell
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/enchant-2/enchant_nuspell.so
+
 %files voikko
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/enchant-2/enchant_voikko.so
This page took 0.273585 seconds and 4 git commands to generate.