]> git.pld-linux.org Git - packages/emu10k1-utils.git/blob - emu10k1-utils.spec
- added nokernel patch (fixes build on sparc)
[packages/emu10k1-utils.git] / emu10k1-utils.spec
1 %define epache_version  0.1.4
2 Summary:        Utils controlling emu10k1 processor
3 Summary(pl):    Narzêdzia kontroluj±ce procesor emu10k1
4 Name:           emu10k1-utils
5 Version:        0.9.4
6 Release:        6
7 License:        GPL
8 Group:          Applications/Sound
9 Source0:        http://dl.sourceforge.net/emu10k1/emu-tools-%{version}.tar.gz
10 # Source0-md5:  906fc53ad142bb4d3531c941d7878264
11 Source1:        http://www.geocities.com/hsokolow2001/linux/epache-%{epache_version}.tgz
12 # Source1-md5:  f85a9f71485a4f8667084010e7c18e6f
13 Source2:        m2049.pdf
14 Source3:        hog63.ps
15 Patch0:         %{name}-path.patch
16 Patch1:         %{name}-aumix.patch
17 Patch2:         %{name}-fv10k1.patch
18 Patch3:         %{name}-gcc33.patch
19 Patch4:         %{name}-nokernel.patch
20 URL:            http://sourceforge.net/projects/emu10k1/
21 BuildRequires:  gtk+-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  m4
24 Conflicts:      alsa-driver
25 Conflicts:      kernel < 2.4.11
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The emu10k1 is really a dsp processor. It does not do any effects on
30 it's own, nor does it route sound from input to output. We had to
31 write dsp code to do that ourselves. emu10k1-utils allows us to set
32 routing, load/unload patches (aka effects), control GPRs, map mixer
33 elements.
34
35 This package contains emu-dspmgr, a tool for configuring the cards dsp
36 patch management system and emu-config, a configuration tool for
37 emu10k1 based sound cards. Also, several ".bin" dsp patches will be
38 installed. You can load these patches using emu-dspmgr.
39
40 %description -l pl
41 emu10k1 jest w rzeczywisto¶ci procesorem sygna³ów cyfrowych (dsp). Nie
42 robi ¿adnych efektów sam z siebie, ani nie kieruje d¼wiêku z wej¶cia
43 na wyj¶cie. Odpowiedzialny za to kod dsp musi byæ napisany i
44 za³adowany. emu10k1-utils pozwala ustawiæ routing, (za/wy)³adowywaæ
45 ³atki (efekty), kontrolowaæ ich parametry (np. przez odzwierciedlenie
46 w mikserze).
47
48 Ten pakiet zawiera emu-dspmgr, narzêdzie obs³uguj±ce system
49 zarz±dzania ³atkami dsp karty i emu-config, konfigurator kart
50 d¼wiêkowych opartych na emu10k1. Zainstalowane zostanie równie¿ kilka
51 gotowych, skompilowanych ³atek, które mo¿na za³adowaæ u¿ywaj±c
52 emu-dspmgr.
53
54 %package devel
55 Summary:        emu10k1 programming utils
56 Summary(pl):    Narzêdzia do programowania emu10k1
57 Group:          Applications/Sound
58
59 %description devel
60 Package contains:
61 - as10k1 - Assembler for the emu10k1 DSP Processor
62 - patches sources
63
64 %description devel -l pl
65 Pakiet zawiera:
66 - as10k1 - asembler dla procesora emu10k1
67 - ¼ród³a ³atek z g³ównego pakietu
68
69 %package autoconfig
70 Summary:        emu10k1 autoconfiguration on module load
71 Summary(pl):    Skrypt konfiguruj±cy emu10k1 przy ³adowaniu modu³u
72 Group:          Applications/Sound
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       aumix
75
76 %description autoconfig
77 Script loading patches. Currently it cannot do too much.
78
79 %description autoconfig -l pl
80 Skrypt ³aduj±cy ³atki. W chwili obecnej nie potrafi zbyt du¿o.
81
82 %package epache
83 Summary:        Program for configuring patches for emu10k1 based sound cards
84 Summary(pl):    Program konfiguruj±cy ³atki dla kart opartych na emu10k1
85 Group:          X11/Applications/Sound
86 Requires:       %{name} = %{version}-%{release}
87
88 %description epache
89 - with the help of emu-dspmgr you can easily load a patch to the card
90   on the specified line (the patch must be generated with the as10k1
91   assembler) and clean the card from it.
92 - you can control 'CONTROL GPRS' of loaded patches (such as speed in
93   flanger)
94 - you can save sessions and load them later, session is a list of
95   patches currenlty loaded with values of controls.
96
97 %description epache -l pl
98 - z pomoc± emu-dspmgra mo¿esz ³atwo ³adowaæ ³aty do karty na dan±
99   liniê (³ata musi byæ wygenerowana przez asembler as10k1) oraz
100   wyczy¶ciæ z niej kartê,
101 - mo¿esz kontrolowaæ rejestry kontrolne za³adowanych ³at,
102 - mo¿esz zachowywaæ sesje i ³adowaæ je; sesja jest list± aktualnie
103   za³adowanych ³at z warto¶ciami kontrolnymi.
104
105 %prep
106 %setup -n emu-tools-%{version} -q -a1
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %patch3 -p1
111 %patch4 -p1
112
113 cp %{SOURCE2} %{SOURCE3} .
114
115 %build
116 %{__make} \
117         CC="%{__cc}" \
118         CFLAGS="%{rpmcflags} -W -Wall"
119
120 cd dbgemu
121 %{__cc} %{rpmldflags} %{rpmcflags} -Wall -o dbgemu dbgemu.c
122
123 cd ../fv10k1
124 %{__cxx} %{rpmldflags} %{rpmcflags} -Wall -o calcroom calcroom.C
125 %{__make}
126 cd ..
127
128 %{__make} -C epache-%{epache_version} \
129         CC="%{__cc}" \
130         CFLAGS="%{rpmcflags} -Wall \$(GTK_CFLAGS)"
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install epache-%{epache_version}/epache $RPM_BUILD_ROOT%{_bindir}
140 install dbgemu/dbgemu $RPM_BUILD_ROOT%{_bindir}
141 mv dbgemu/README dbgemu/README.dbgemu
142 install as10k1/effects/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
143 install as10k1/effects/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
144
145 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/*
146 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/README
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   autoconfig
152 umask 027
153 grep "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" /etc/modprobe.conf > /dev/null
154 if [ "$?" -eq "1" ]; then
155         echo "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" >> /etc/modprobe.conf
156 fi
157
158 %postun autoconfig
159 umask 027
160 grep -v "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" /etc/modprobe.conf > /etc/modprobe.conf.new
161 mv -f /etc/modprobe.conf.new /etc/modprobe.conf
162
163 %files
164 %defattr(644,root,root,755)
165 %doc docs/CHANGES docs/README docs/README.FAQ dbgemu/README.dbgemu
166 %attr(754,root,root) %{_bindir}/emu-config
167 %attr(754,root,root) %{_bindir}/emu-dspmgr
168 %attr(754,root,root) %{_bindir}/dbgemu
169 %dir %{_datadir}/emu10k1
170 %{_datadir}/emu10k1/*.bin
171 %{_datadir}/emu10k1/README.gz
172 %{_mandir}/man1/emu-*
173
174 %files devel
175 %defattr(644,root,root,755)
176 %doc docs/dsp.txt docs/manuals.txt docs/multichannel.txt docs/TODO hog63.ps m2049.pdf
177 %attr(755,root,root) %{_bindir}/as10k1
178 %{_datadir}/emu10k1/asm
179 %{_mandir}/man1/as10k1*
180
181 %files autoconfig
182 %defattr(644,root,root,755)
183 %attr(754,root,root) %{_bindir}/emu-script
184 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/emu10k1.conf
185
186 %files epache
187 %defattr(644,root,root,755)
188 %doc epache-%{epache_version}/README
189 %attr(755,root,root) %{_bindir}/epache
This page took 0.046638 seconds and 4 git commands to generate.