]> git.pld-linux.org Git - packages/emu10k1-utils.git/blob - emu10k1-utils.spec
- release 3
[packages/emu10k1-utils.git] / emu10k1-utils.spec
1 %define epache_version  0.1.4
2 Summary:        Utils controlling emu10k1 processor
3 Summary(pl):    Narzêdzia kontroluj±ce procesor emu10k1
4 Name:           emu10k1-utils
5 Version:        0.9.4
6 Release:        3
7 License:        GPL
8 Group:          Applications/Sound
9 Source0:        http://dl.sourceforge.net/emu10k1/emu-tools-%{version}.tar.gz
10 # Source0-md5:  906fc53ad142bb4d3531c941d7878264
11 Source1:        http://www.geocities.com/hsokolow2001/linux/epache-%{epache_version}.tgz
12 # Source1-md5:  f85a9f71485a4f8667084010e7c18e6f
13 Source2:        m2049.pdf
14 Source3:        hog63.ps
15 Patch0:         %{name}-path.patch
16 Patch1:         %{name}-aumix.patch
17 Patch2:         %{name}-fv10k1.patch
18 URL:            http://sourceforge.net/projects/emu10k1/
19 BuildRequires:  gtk+-devel
20 BuildRequires:  m4
21 Conflicts:      alsa-driver
22 Conflicts:      kernel < 2.4.11
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _prefix         /usr
26
27 %description
28 The emu10k1 is really a dsp processor. It does not do any effects on
29 it's own, nor does it route sound from input to output. We had to
30 write dsp code to do that ourselves. emu10k1-utils allows us to set
31 routing, load/unload patches (aka effects), control GPRs, map mixer
32 elements.
33
34 This package contains emu-dspmgr, a tool for configuring the cards dsp
35 patch management system and emu-config, a configuration tool for
36 emu10k1 based sound cards. Also, several ".bin" dsp patches will be
37 installed. You can load these patches using emu-dspmgr.
38
39 %description -l pl
40 emu10k1 jest w rzeczywisto¶ci procesorem sygna³ów cyfrowych (dsp). Nie
41 robi ¿adnych efektów sam z siebie, ani nie kieruje d¼wiêku z wej¶cia
42 na wyj¶cie. Odpowiedzialny za to kod dsp musi byæ napisany i
43 za³adowany. emu10k1-utils pozwala ustawiæ routing, (za/wy)³adowywaæ
44 ³atki (efekty), kontrolowaæ ich parametry (np. przez odzwierciedlenie
45 w mikserze).
46
47 Ten pakiet zawiera emu-dspmgr, narzêdzie obs³uguj±ce system
48 zarz±dzania ³atkami dsp karty i emu-config, konfigurator kart
49 d¼wiêkowych opartych na emu10k1. Zainstalowane zostanie równie¿ kilka
50 gotowych, skompilowanych ³atek, które mo¿na za³adowaæ u¿ywaj±c
51 emu-dspmgr.
52
53 %package devel
54 Summary:        emu10k1 programming utils
55 Summary(pl):    Narzêdzia do programowania emu10k1
56 Group:          Applications/Sound
57
58 %description devel
59 Package contains:
60 - as10k1 - Assembler for the emu10k1 DSP Processor
61 - patches sources
62
63 %description devel -l pl
64 Pakiet zawiera:
65 - as10k1 - asembler dla procesora emu10k1
66 - ¼ród³a ³atek z g³ównego pakietu
67
68 %package autoconfig
69 Summary:        emu10k1 autoconfiguration on module load
70 Summary(pl):    Skrypt konfiguruj±cy emu10k1 przy ³adowaniu modu³u
71 Group:          Applications/Sound
72 Requires:       %{name} = %{version}
73 Requires:       aumix
74
75 %description autoconfig
76 Script loading patches. Currently it cannot do too much.
77
78 %description autoconfig -l pl
79 Skrypt ³aduj±cy ³atki. W chwili obecnej nie potrafi zbyt du¿o.
80
81 %package epache
82 Summary:        Program for configuring patches for emu10k1 based sound cards
83 Summary(pl):    Program konfiguruj±cy ³atki dla kart opartych na emu10k1
84 Group:          X11/Applications/Sound
85 Requires:       %{name}
86
87 %description epache
88 - with the help of emu-dspmgr you can easily load a patch to the card
89   on the specified line (the patch must be generated with the as10k1
90   assembler) and clean the card from it.
91 - you can control 'CONTROL GPRS' of loaded patches (such as speed in
92   flanger)
93 - you can save sessions and load them later, session is a list of
94   patches currenlty loaded with values of controls.
95
96 %description epache -l pl
97 - z pomoc± emu-dspmgra mo¿esz ³atwo ³adowaæ ³aty do karty na dan±
98   liniê (³ata musi byæ wygenerowana przez asembler as10k1) oraz
99   wyczy¶ciæ z niej kartê,
100 - mo¿esz kontrolowaæ rejestry kontrolne za³adowanych ³at,
101 - mo¿esz zachowywaæ sesje i ³adowaæ je; sesja jest list± aktualnie
102   za³adowanych ³at z warto¶ciami kontrolnymi.
103
104 %prep
105 %setup -n emu-tools-%{version} -q -a1
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109
110 cp %{SOURCE2} %{SOURCE3} .
111
112 %build
113 %{__make} CC="%{__cc}"
114 %{__make} -C dbgemu \
115         CC="%{__cc}"
116 #%%{__make} -C fv10k1
117 %{__make} -C epache-%{epache_version} \
118         CC="%{__cc}"
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_prefix}/X11R6/bin,%{_datadir}/emu10k1/asm}
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 install epache-%{epache_version}/epache $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
128 install dbgemu/dbgemu $RPM_BUILD_ROOT%{_bindir}
129 mv dbgemu/README dbgemu/README.dbgemu
130 install as10k1/effects/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
131 install as10k1/effects/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
132
133 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/*
134 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/README
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   autoconfig
140 umask 027
141 grep "post-install emu10k1 /usr/bin/emu-script" /etc/modules.conf > /dev/null
142 if [ "$?" -eq "1" ]; then
143         echo "post-install emu10k1 /usr/bin/emu-script" >> /etc/modules.conf
144 fi
145
146 %postun autoconfig
147 umask 027
148 grep -v "post-install emu10k1 /usr/bin/emu-script" /etc/modules.conf > /etc/modules.conf.new
149 mv -f /etc/modules.conf.new /etc/modules.conf
150
151 %files
152 %defattr(644,root,root,755)
153 %doc docs/CHANGES docs/README docs/README.FAQ dbgemu/README.dbgemu
154 %attr(750,root,root) %{_bindir}/emu-config
155 %attr(750,root,root) %{_bindir}/emu-dspmgr
156 %attr(750,root,root) %{_bindir}/dbgemu
157 %dir %{_datadir}/emu10k1
158 %{_datadir}/emu10k1/*.bin
159 %{_datadir}/emu10k1/README.gz
160 %{_mandir}/man1/emu-*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %doc docs/dsp.txt docs/manuals.txt docs/multichannel.txt docs/TODO
165 %doc hog63.ps m2049.pdf
166 %attr(750,root,root) %{_bindir}/as10k1
167 %dir %{_datadir}/emu10k1/asm
168 %{_datadir}/emu10k1/asm/*
169 %{_mandir}/man1/as10k1*
170
171 %files autoconfig
172 %defattr(644,root,root,755)
173 %attr(750,root,root) %{_bindir}/emu-script
174 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/emu10k1.conf
175
176 %files epache
177 %defattr(644,root,root,755)
178 %doc epache-%{epache_version}/README
179 %attr(755,root,root) %{_prefix}/X11R6/bin/epache
This page took 0.061678 seconds and 4 git commands to generate.