]> git.pld-linux.org Git - packages/emu10k1-utils.git/blob - emu10k1-utils.spec
- adapterized (sorted %verify flags)
[packages/emu10k1-utils.git] / emu10k1-utils.spec
1 %define epache_version  0.1.4
2 Summary:        Utils controlling emu10k1 processor
3 Summary(pl):    Narzêdzia kontroluj±ce procesor emu10k1
4 Name:           emu10k1-utils
5 Version:        0.9.4
6 Release:        6
7 License:        GPL
8 Group:          Applications/Sound
9 Source0:        http://dl.sourceforge.net/emu10k1/emu-tools-%{version}.tar.gz
10 # Source0-md5:  906fc53ad142bb4d3531c941d7878264
11 Source1:        http://www.geocities.com/hsokolow2001/linux/epache-%{epache_version}.tgz
12 # Source1-md5:  f85a9f71485a4f8667084010e7c18e6f
13 Source2:        m2049.pdf
14 Source3:        hog63.ps
15 Patch0:         %{name}-path.patch
16 Patch1:         %{name}-aumix.patch
17 Patch2:         %{name}-fv10k1.patch
18 Patch3:         %{name}-gcc33.patch
19 Patch4:         %{name}-nokernel.patch
20 URL:            http://sourceforge.net/projects/emu10k1/
21 BuildRequires:  gtk+-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  m4
24 BuildRequires:  perl-base
25 Conflicts:      alsa-driver
26 Conflicts:      kernel < 2.4.11
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The emu10k1 is really a dsp processor. It does not do any effects on
31 it's own, nor does it route sound from input to output. We had to
32 write dsp code to do that ourselves. emu10k1-utils allows us to set
33 routing, load/unload patches (aka effects), control GPRs, map mixer
34 elements.
35
36 This package contains emu-dspmgr, a tool for configuring the cards dsp
37 patch management system and emu-config, a configuration tool for
38 emu10k1 based sound cards. Also, several ".bin" dsp patches will be
39 installed. You can load these patches using emu-dspmgr.
40
41 %description -l pl
42 emu10k1 jest w rzeczywisto¶ci procesorem sygna³ów cyfrowych (dsp). Nie
43 robi ¿adnych efektów sam z siebie, ani nie kieruje d¼wiêku z wej¶cia
44 na wyj¶cie. Odpowiedzialny za to kod dsp musi byæ napisany i
45 za³adowany. emu10k1-utils pozwala ustawiæ routing, (za/wy)³adowaæ
46 ³atki (efekty), kontrolowaæ ich parametry (np. przez odzwierciedlenie
47 w mikserze).
48
49 Ten pakiet zawiera emu-dspmgr, narzêdzie obs³uguj±ce system
50 zarz±dzania ³atkami dsp karty i emu-config, konfigurator kart
51 d¼wiêkowych opartych na emu10k1. Zainstalowane zostanie równie¿ kilka
52 gotowych, skompilowanych ³atek, które mo¿na za³adowaæ u¿ywaj±c
53 emu-dspmgr.
54
55 %package devel
56 Summary:        emu10k1 programming utils
57 Summary(pl):    Narzêdzia do programowania emu10k1
58 Group:          Applications/Sound
59
60 %description devel
61 Package contains:
62 - as10k1 - Assembler for the emu10k1 DSP Processor
63 - patches sources
64
65 %description devel -l pl
66 Pakiet zawiera:
67 - as10k1 - asembler dla procesora emu10k1
68 - ¼ród³a ³atek z g³ównego pakietu
69
70 %package autoconfig
71 Summary:        emu10k1 autoconfiguration on module load
72 Summary(pl):    Skrypt konfiguruj±cy emu10k1 przy ³adowaniu modu³u
73 Group:          Applications/Sound
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       aumix
76
77 %description autoconfig
78 Script loading patches. Currently it cannot do too much.
79
80 %description autoconfig -l pl
81 Skrypt ³aduj±cy ³atki. W chwili obecnej nie potrafi zbyt du¿o.
82
83 %package epache
84 Summary:        Program for configuring patches for emu10k1 based sound cards
85 Summary(pl):    Program konfiguruj±cy ³atki dla kart opartych na emu10k1
86 Group:          X11/Applications/Sound
87 Requires:       %{name} = %{version}-%{release}
88
89 %description epache
90 - with the help of emu-dspmgr you can easily load a patch to the card
91   on the specified line (the patch must be generated with the as10k1
92   assembler) and clean the card from it.
93 - you can control 'CONTROL GPRS' of loaded patches (such as speed in
94   flanger)
95 - you can save sessions and load them later, session is a list of
96   patches currenlty loaded with values of controls.
97
98 %description epache -l pl
99 - z pomoc± emu-dspmgra mo¿esz ³atwo ³adowaæ ³aty do karty na dan±
100   liniê (³ata musi byæ wygenerowana przez asembler as10k1) oraz
101   wyczy¶ciæ z niej kartê,
102 - mo¿esz kontrolowaæ rejestry kontrolne za³adowanych ³at,
103 - mo¿esz zachowywaæ sesje i ³adowaæ je; sesja jest list± aktualnie
104   za³adowanych ³at z warto¶ciami kontrolnymi.
105
106 %prep
107 %setup -n emu-tools-%{version} -q -a1
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111 %patch3 -p1
112 %patch4 -p1
113
114 cp %{SOURCE2} %{SOURCE3} .
115
116 %build
117 %{__make} \
118         CC="%{__cc}" \
119         CFLAGS="%{rpmcflags} -W -Wall"
120
121 cd dbgemu
122 %{__cc} %{rpmldflags} %{rpmcflags} -Wall -o dbgemu dbgemu.c
123
124 cd ../fv10k1
125 %{__cxx} %{rpmldflags} %{rpmcflags} -Wall -o calcroom calcroom.C
126 %{__make}
127 cd ..
128
129 %{__make} -C epache-%{epache_version} \
130         CC="%{__cc}" \
131         CFLAGS="%{rpmcflags} -Wall \$(GTK_CFLAGS)"
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 install epache-%{epache_version}/epache $RPM_BUILD_ROOT%{_bindir}
141 install dbgemu/dbgemu $RPM_BUILD_ROOT%{_bindir}
142 mv dbgemu/README dbgemu/README.dbgemu
143 install as10k1/effects/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
144 install as10k1/effects/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
145
146 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/*
147 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/README
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   autoconfig
153 umask 027
154 grep "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" /etc/modprobe.conf > /dev/null
155 if [ "$?" -eq "1" ]; then
156         echo "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" >> /etc/modprobe.conf
157 fi
158
159 %postun autoconfig
160 umask 027
161 grep -v "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" /etc/modprobe.conf > /etc/modprobe.conf.new
162 mv -f /etc/modprobe.conf.new /etc/modprobe.conf
163
164 %files
165 %defattr(644,root,root,755)
166 %doc docs/CHANGES docs/README docs/README.FAQ dbgemu/README.dbgemu
167 %attr(754,root,root) %{_bindir}/emu-config
168 %attr(754,root,root) %{_bindir}/emu-dspmgr
169 %attr(754,root,root) %{_bindir}/dbgemu
170 %dir %{_datadir}/emu10k1
171 %{_datadir}/emu10k1/*.bin
172 %{_datadir}/emu10k1/README.gz
173 %{_mandir}/man1/emu-*
174
175 %files devel
176 %defattr(644,root,root,755)
177 %doc docs/dsp.txt docs/manuals.txt docs/multichannel.txt docs/TODO hog63.ps m2049.pdf
178 %attr(755,root,root) %{_bindir}/as10k1
179 %{_datadir}/emu10k1/asm
180 %{_mandir}/man1/as10k1*
181
182 %files autoconfig
183 %defattr(644,root,root,755)
184 %attr(754,root,root) %{_bindir}/emu-script
185 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/emu10k1.conf
186
187 %files epache
188 %defattr(644,root,root,755)
189 %doc epache-%{epache_version}/README
190 %attr(755,root,root) %{_bindir}/epache
This page took 0.396085 seconds and 4 git commands to generate.