]> git.pld-linux.org Git - packages/emu10k1-utils.git/blob - emu10k1-utils.spec
- massive cleaning
[packages/emu10k1-utils.git] / emu10k1-utils.spec
1 %define epache_version  0.1.4
2 Summary:        Utils controlling emu10k1 processor
3 Summary(pl):    Narzêdzia kontroluj±ce procesor emu10k1
4 Name:           emu10k1-utils
5 Version:        0.9.4
6 Release:        2
7 License:        GPL
8 Group:          Applications/Sound
9 Source0:        http://prdownloads.sourceforge.net/emu10k1/emu-tools-%{version}.tar.gz
10 Source1:        http://www.geocities.com/hsokolow2001/linux/epache-%{epache_version}.tgz
11 Source2:        m2049.pdf
12 Source3:        hog63.ps
13 Patch0:         %{name}-path.patch
14 Patch1:         %{name}-aumix.patch
15 Patch2:         %{name}-fv10k1.patch
16 URL:            http://sourceforge.net/projects/emu10k1/
17 Conflicts:      kernel < 2.4.11
18 Conflicts:      alsa-driver
19 BuildRequires:  m4
20 BuildRequires:  gtk+-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _prefix         /usr
24
25 %description
26 The emu10k1 is really a dsp processor. It does not do any effects on
27 it's own, nor does it route sound from input to output. We had to
28 write dsp code to do that ourselves. emu10k1-utils allows us to set
29 routing, load/unload patches (aka effects), control GPRs, map mixer
30 elements.
31
32 This package contains emu-dspmgr, a tool for configuring the cards dsp
33 patch management system and emu-config, a configuration tool for
34 emu10k1 based sound cards. Also, several ".bin" dsp patches will be
35 installed. You can load these patches using emu-dspmgr.
36
37 %description -l pl
38 emu10k1 jest w rzeczywisto¶ci procesorem sygna³ów cyfrowych (dsp). Nie
39 robi ¿adnych efektów sam z siebie, ani nie kieruje d¼wiêku z wej¶cia
40 na wyj¶cie. Odpowiedzialny za to kod dsp musi byæ napisany i
41 za³adowany. emu10k1-utils pozwala ustawiæ routing, (za/wy)³adowywaæ
42 ³atki (efekty), kontrolowaæ ich parametry (np. przez odzwierciedlenie
43 w mikserze).
44
45 Ten pakiet zawiera emu-dspmgr, narzêdzie obs³uguj±ce system
46 zarz±dzania ³atkami dsp karty i emu-config, konfigurator kart
47 d¼wiêkowych opartych na emu10k1. Zainstalowane zostanie równie¿ kilka
48 gotowych, skompilowanych ³atek, które mo¿na za³adowaæ u¿ywaj±c
49 emu-dspmgr.
50
51 %package devel
52 Summary:        emu10k1 programming utils
53 Summary(pl):    Narzêdzia do programowania emu10k1
54 Group:          Applications/Sound
55
56 %description devel
57 Package contains:
58 - as10k1 - Assembler for the emu10k1 DSP Processor
59 - patches sources
60
61 %description devel -l pl
62 Pakiet zawiera:
63 - as10k1 - asembler dla procesora emu10k1
64 - ¼ród³a ³atek z g³ównego pakietu
65
66 %package autoconfig
67 Summary:        emu10k1 autoconfiguration on module load
68 Summary(pl):    Skrypt konfiguruj±cy emu10k1 przy ³adowaniu modu³u
69 Group:          Applications/Sound
70 Requires:       %{name} = %{version}
71 Requires:       aumix
72
73 %description autoconfig
74 Script loading patches. Currently it cannot do too much.
75
76 %description autoconfig -l pl
77 Skrypt ³aduj±cy ³atki. W chwili obecnej nie potrafi zbyt du¿o.
78
79 %package epache
80 Summary:        Program for configuring patches for emu10k1 based sound cards
81 Summary(pl):    Program konfiguruj±cy ³atki dla kart opartych na emu10k1
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name}
84
85 %description epache
86 - with the help of emu-dspmgr you can easily load a patch to the card
87   on the specified line (the patch must be generated with the as10k1
88   assembler) and clean the card from it.
89 - you can control 'CONTROL GPRS' of loaded patches (such as speed in
90   flanger)
91 - you can save sessions and load them later, session is a list of
92   patches currenlty loaded with values of controls.
93
94 %description epache -l pl
95 - z pomoc± emu-dspmgra mo¿esz ³atwo ³adowaæ ³aty do karty na dan±
96   liniê (³ata musi byæ wygenerowana przez asembler as10k1) oraz
97   wyczy¶ciæ z niej kartê,
98 - mo¿esz kontrolowaæ rejestry kontrolne za³adowanych ³at,
99 - mo¿esz zachowywaæ sesje i ³adowaæ je; sesja jest list± aktualnie
100   za³adowanych ³at z warto¶ciami kontrolnymi.
101
102 %prep
103 %setup -n emu-tools-%{version} -q -a1
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107
108 cp %{SOURCE2} %{SOURCE3} .
109
110 %build
111 %{__make}
112 %{__make} -C dbgemu
113 %{__make} -C fv10k1
114 %{__make} -C epache-%{epache_version}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_prefix}/X11R6/bin,%{_datadir}/emu10k1/asm}
119
120 %{__make} DESTDIR=$RPM_BUILD_ROOT install
121 install epache-%{epache_version}/epache $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/
122 install fv10k1/load.sh fv10k1/unload.sh fv10k1/fv10k1control.pl dbgemu/dbgemu $RPM_BUILD_ROOT%{_bindir}
123 mv fv10k1/README docs/README.fv10k1
124 mv dbgemu/README dbgemu/README.dbgemu
125 install fv10k1/bin/* $RPM_BUILD_ROOT%{_datadir}/emu10k1/
126 install fv10k1/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
127 install fv10k1/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
128 install as10k1/effects/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
129 install as10k1/effects/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
130 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/*
131
132 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/README
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   autoconfig
138 grep "post-install emu10k1 /usr/bin/emu-script" /etc/modules.conf > /dev/null
139 if [ "$?" -eq "1" ]
140 then
141         echo "post-install emu10k1 /usr/bin/emu-script" >> /etc/modules.conf
142 fi
143
144 %postun autoconfig
145 grep -v "post-install emu10k1 /usr/bin/emu-script" /etc/modules.conf > /etc/modules.conf.new
146 mv -f /etc/modules.conf.new /etc/modules.conf
147
148 %files
149 %defattr(644,root,root,755)
150 %attr(750,root,root) %{_bindir}/emu-config
151 %attr(750,root,root) %{_bindir}/emu-dspmgr
152 %attr(750,root,root) %{_bindir}/fv10k1control.pl
153 %attr(750,root,root) %{_bindir}/load.sh
154 %attr(750,root,root) %{_bindir}/unload.sh
155 %attr(750,root,root) %{_bindir}/dbgemu
156 %doc docs/CHANGES docs/README docs/README.FAQ dbgemu/README.dbgemu
157 %{_mandir}/man1/emu-*
158 %dir %{_datadir}/emu10k1
159 %{_datadir}/emu10k1/*.bin
160 %{_datadir}/emu10k1/README.gz
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(750,root,root) %{_bindir}/as10k1
165 %doc docs/dsp.txt docs/manuals.txt docs/multichannel.txt docs/TODO
166 %doc hog63.ps m2049.pdf
167 %{_mandir}/man1/as10k1*
168 %dir %{_datadir}/emu10k1/asm
169 %{_datadir}/emu10k1/asm/*
170
171 %files autoconfig
172 %defattr(644,root,root,755)
173 %attr(750,root,root) %{_bindir}/emu-script
174 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/emu10k1.conf
175
176 %files epache
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_prefix}/X11R6/bin/epache
179 %doc epache-%{epache_version}/README
This page took 1.435981 seconds and 4 git commands to generate.