]> git.pld-linux.org Git - packages/emu10k1-utils.git/blob - emu10k1-utils.spec
- 2.6.x support
[packages/emu10k1-utils.git] / emu10k1-utils.spec
1 %define epache_version  0.1.4
2 Summary:        Utils controlling emu10k1 processor
3 Summary(pl):    Narzêdzia kontroluj±ce procesor emu10k1
4 Name:           emu10k1-utils
5 Version:        0.9.4
6 Release:        5
7 License:        GPL
8 Group:          Applications/Sound
9 Source0:        http://dl.sourceforge.net/emu10k1/emu-tools-%{version}.tar.gz
10 # Source0-md5:  906fc53ad142bb4d3531c941d7878264
11 Source1:        http://www.geocities.com/hsokolow2001/linux/epache-%{epache_version}.tgz
12 # Source1-md5:  f85a9f71485a4f8667084010e7c18e6f
13 Source2:        m2049.pdf
14 Source3:        hog63.ps
15 Patch0:         %{name}-path.patch
16 Patch1:         %{name}-aumix.patch
17 Patch2:         %{name}-fv10k1.patch
18 Patch3:         %{name}-gcc33.patch
19 URL:            http://sourceforge.net/projects/emu10k1/
20 BuildRequires:  gtk+-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  m4
23 Conflicts:      alsa-driver
24 Conflicts:      kernel < 2.4.11
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The emu10k1 is really a dsp processor. It does not do any effects on
29 it's own, nor does it route sound from input to output. We had to
30 write dsp code to do that ourselves. emu10k1-utils allows us to set
31 routing, load/unload patches (aka effects), control GPRs, map mixer
32 elements.
33
34 This package contains emu-dspmgr, a tool for configuring the cards dsp
35 patch management system and emu-config, a configuration tool for
36 emu10k1 based sound cards. Also, several ".bin" dsp patches will be
37 installed. You can load these patches using emu-dspmgr.
38
39 %description -l pl
40 emu10k1 jest w rzeczywisto¶ci procesorem sygna³ów cyfrowych (dsp). Nie
41 robi ¿adnych efektów sam z siebie, ani nie kieruje d¼wiêku z wej¶cia
42 na wyj¶cie. Odpowiedzialny za to kod dsp musi byæ napisany i
43 za³adowany. emu10k1-utils pozwala ustawiæ routing, (za/wy)³adowywaæ
44 ³atki (efekty), kontrolowaæ ich parametry (np. przez odzwierciedlenie
45 w mikserze).
46
47 Ten pakiet zawiera emu-dspmgr, narzêdzie obs³uguj±ce system
48 zarz±dzania ³atkami dsp karty i emu-config, konfigurator kart
49 d¼wiêkowych opartych na emu10k1. Zainstalowane zostanie równie¿ kilka
50 gotowych, skompilowanych ³atek, które mo¿na za³adowaæ u¿ywaj±c
51 emu-dspmgr.
52
53 %package devel
54 Summary:        emu10k1 programming utils
55 Summary(pl):    Narzêdzia do programowania emu10k1
56 Group:          Applications/Sound
57
58 %description devel
59 Package contains:
60 - as10k1 - Assembler for the emu10k1 DSP Processor
61 - patches sources
62
63 %description devel -l pl
64 Pakiet zawiera:
65 - as10k1 - asembler dla procesora emu10k1
66 - ¼ród³a ³atek z g³ównego pakietu
67
68 %package autoconfig
69 Summary:        emu10k1 autoconfiguration on module load
70 Summary(pl):    Skrypt konfiguruj±cy emu10k1 przy ³adowaniu modu³u
71 Group:          Applications/Sound
72 Requires:       %{name} = %{version}
73 Requires:       aumix
74
75 %description autoconfig
76 Script loading patches. Currently it cannot do too much.
77
78 %description autoconfig -l pl
79 Skrypt ³aduj±cy ³atki. W chwili obecnej nie potrafi zbyt du¿o.
80
81 %package epache
82 Summary:        Program for configuring patches for emu10k1 based sound cards
83 Summary(pl):    Program konfiguruj±cy ³atki dla kart opartych na emu10k1
84 Group:          X11/Applications/Sound
85 Requires:       %{name}
86
87 %description epache
88 - with the help of emu-dspmgr you can easily load a patch to the card
89   on the specified line (the patch must be generated with the as10k1
90   assembler) and clean the card from it.
91 - you can control 'CONTROL GPRS' of loaded patches (such as speed in
92   flanger)
93 - you can save sessions and load them later, session is a list of
94   patches currenlty loaded with values of controls.
95
96 %description epache -l pl
97 - z pomoc± emu-dspmgra mo¿esz ³atwo ³adowaæ ³aty do karty na dan±
98   liniê (³ata musi byæ wygenerowana przez asembler as10k1) oraz
99   wyczy¶ciæ z niej kartê,
100 - mo¿esz kontrolowaæ rejestry kontrolne za³adowanych ³at,
101 - mo¿esz zachowywaæ sesje i ³adowaæ je; sesja jest list± aktualnie
102   za³adowanych ³at z warto¶ciami kontrolnymi.
103
104 %prep
105 %setup -n emu-tools-%{version} -q -a1
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109 %patch3 -p1
110
111 cp %{SOURCE2} %{SOURCE3} .
112
113 %build
114 %{__make} \
115         CC="%{__cc}" \
116         CFLAGS="%{rpmcflags} -W -Wall"
117
118 cd dbgemu
119 %{__cc} %{rpmldflags} %{rpmcflags} -Wall -o dbgemu dbgemu.c
120
121 cd ../fv10k1
122 %{__cxx} %{rpmldflags} %{rpmcflags} -Wall -o calcroom calcroom.C
123 %{__make}
124 cd ..
125
126 %{__make} -C epache-%{epache_version} \
127         CC="%{__cc}" \
128         CFLAGS="%{rpmcflags} -Wall \$(GTK_CFLAGS)"
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install epache-%{epache_version}/epache $RPM_BUILD_ROOT%{_bindir}
138 install dbgemu/dbgemu $RPM_BUILD_ROOT%{_bindir}
139 mv dbgemu/README dbgemu/README.dbgemu
140 install as10k1/effects/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
141 install as10k1/effects/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm
142
143 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/*
144 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/README
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   autoconfig
150 umask 027
151 grep "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" /etc/modprobe.conf > /dev/null
152 if [ "$?" -eq "1" ]; then
153         echo "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" >> /etc/modprobe.conf
154 fi
155
156 %postun autoconfig
157 umask 027
158 grep -v "install emu10k1 /sbin/modprobe --ignore-install emu10k1 && { /usr/bin/emu-script; }" /etc/modprobe.conf > /etc/modprobe.conf.new
159 mv -f /etc/modprobe.conf.new /etc/modprobe.conf
160
161 %files
162 %defattr(644,root,root,755)
163 %doc docs/CHANGES docs/README docs/README.FAQ dbgemu/README.dbgemu
164 %attr(754,root,root) %{_bindir}/emu-config
165 %attr(754,root,root) %{_bindir}/emu-dspmgr
166 %attr(754,root,root) %{_bindir}/dbgemu
167 %dir %{_datadir}/emu10k1
168 %{_datadir}/emu10k1/*.bin
169 %{_datadir}/emu10k1/README.gz
170 %{_mandir}/man1/emu-*
171
172 %files devel
173 %defattr(644,root,root,755)
174 %doc docs/dsp.txt docs/manuals.txt docs/multichannel.txt docs/TODO hog63.ps m2049.pdf
175 %attr(755,root,root) %{_bindir}/as10k1
176 %{_datadir}/emu10k1/asm
177 %{_mandir}/man1/as10k1*
178
179 %files autoconfig
180 %defattr(644,root,root,755)
181 %attr(754,root,root) %{_bindir}/emu-script
182 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/emu10k1.conf
183
184 %files epache
185 %defattr(644,root,root,755)
186 %doc epache-%{epache_version}/README
187 %attr(755,root,root) %{_bindir}/epache
This page took 0.097687 seconds and 3 git commands to generate.