]> git.pld-linux.org Git - packages/emu10k1-utils.git/blob - emu10k1-utils.spec
- devel doesn't need main package
[packages/emu10k1-utils.git] / emu10k1-utils.spec
1 %define snap    20020101
2 Summary:        Utils controlling emu10k1 processor
3 Summary(pl):    Narzêdzia kontroluj±ce procesor emu10k1
4 Name:           emu10k1-utils
5 Version:        0.9.3
6 Release:        0.%{snap}.1
7 License:        GPL
8 Group:          Applications/Sound
9 Group(de):      Applikationen/Laut
10 Group(es):      Aplicaciones/Sonido
11 Group(pl):      Aplikacje/D¼wiêk
12 Group(pt_BR):   Aplicações/Som
13 Source0:        %{name}-%{snap}.tar.bz2
14 Patch0:         %{name}-path.patch
15 Patch1:         %{name}-aumix.patch
16 Patch2:         %{name}-fv10k1.patch
17 URL:            http://opensource.creative.com/
18 # czy w j±drach 2.2 jest obs³uga emu10k1? jak nie, to dodaæ requires: kernel >=2.4
19 BuildRequires:  m4
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _prefix         /usr
23
24 %description
25 The emu10k1 is really a dsp processor. It does not do any effects on
26 it's own, nor does it route sound from input to output. We had to
27 write dsp code to do that ourselves. emu10k1-utils allows us to set
28 routing, load/unload patches (aka effects), control GPRs, map mixer
29 elements.
30
31 This package contains emu-dspmgr, a tool for configuring the cards dsp
32 patch management system and emu-config, a configuration tool for
33 emu10k1 based sound cards. Also, several ".bin" dsp patches will be
34 installed. You can load these patches using emu-dspmgr.
35
36 %description -l pl
37 emu10k1 jest w rzeczywisto¶ci procesorem sygna³ów cyfrowych (dsp). Nie
38 robi ¿adnych efektów sam z siebie, ani nie kieruje d¼wiêku z wej¶cia
39 na wyj¶cie. Odpowiedzialny za to kod dsp musi byæ napisany i
40 za³adowany. emu10k1-utils pozwala ustawiæ routing, (za/wy)³adowywaæ
41 ³atki (efekty), kontrolowaæ ich parametry (np. przez odzwierciedlenie
42 w mikserze).
43
44 Ten pakiet zawiera emu-dspmgr, narzêdzie obs³uguj±ce system
45 zarz±dzania ³atkami dsp karty i emu-config, konfigurator kart
46 d¼wiêkowych opartych na emu10k1. Zainstalowane zostanie równie¿ kilka
47 gotowych, skompilowanych ³atek, które mo¿na za³adowaæ u¿ywaj±c
48 emu-dspmgr.
49
50 %package devel
51 Summary:        emu10k1 programming utils.
52 Summary(pl):    Narzêdzia do programowania emu10k1
53 Group:          Applications/Sound
54 Group(de):      Applikationen/Laut
55 Group(es):      Aplicaciones/Sonido
56 Group(pl):      Aplikacje/D¼wiêk
57 Group(pt_BR):   Aplicações/Som
58
59 %description devel
60 Package contains:
61 - as10k1 - Assembler for the emu10k1 DSP Processor
62 - patches sources
63
64 %description -l pl devel
65 Pakiet zawiera:
66 - as10k1 - asembler dla procesora emu10k1
67 - ¼ród³a ³atek z g³ównego pakietu
68
69 %package autoconfig
70 Summary:        emu10k1 autoconfiguration on module load.
71 Summary(pl):    Skrypt konfiguruj±cy emu10k1 przy ³adowaniu modu³u.
72 Group:          Applications/Sound
73 Group(de):      Applikationen/Laut
74 Group(es):      Aplicaciones/Sonido
75 Group(pl):      Aplikacje/D¼wiêk
76 Group(pt_BR):   Aplicações/Som
77 Requires:       %{name} = %{version}
78 Requires:       aumix
79
80 %description autoconfig
81 Script loading patches. Currently it cannot do too much.
82
83 %description -l pl autoconfig
84 Skrypt ³aduj±cy ³atki. W chwili obecnej nie potrafi zbyt du¿o.
85
86 %prep
87 %setup -n emu10k1-utils -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 %build
93 %{__make}
94 #%{__make} -C compiler
95 #%{__make} -C dbgemu
96 %{__make} -C fv10k1
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} DESTDIR=$RPM_BUILD_ROOT install
102 cp fv10k1/load.sh fv10k1/unload.sh fv10k1/fv10k1control.pl $RPM_BUILD_ROOT%{_bindir}
103 mv fv10k1/README docs/README.fv10k1
104 cp fv10k1/bin/* $RPM_BUILD_ROOT%{_datadir}/emu10k1/
105 mkdir $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
106 cp fv10k1/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
107 cp fv10k1/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
108 cp as10k1/effects/*.asm $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
109 cp -f as10k1/effects/*.inc $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/
110 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/asm/*
111
112 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/emu10k1/README
113 gzip -9nf docs/*
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   autoconfig
119 grep "post-install emu10k1 /usr/bin/emu-script" /etc/modules.conf > /dev/null
120 if [ "$?" -eq "1" ]
121 then
122         echo "post-install emu10k1 /usr/bin/emu-script" >> /etc/modules.conf
123 fi
124
125 %postun autoconfig
126 grep -v "post-install emu10k1 /usr/bin/emu-script" /etc/modules.conf > /etc/modules.conf.new
127 mv -f /etc/modules.conf /etc/modules.conf.old
128 mv /etc/modules.conf.new /etc/modules.conf
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(750,root,root) %{_bindir}/emu-config
133 %attr(750,root,root) %{_bindir}/emu-dspmgr
134 %attr(750,root,root) %{_bindir}/fv10k1control.pl
135 %attr(750,root,root) %{_bindir}/load.sh
136 %attr(750,root,root) %{_bindir}/unload.sh
137 %doc docs/README-TOOLS.gz docs/README.fv10k1.gz
138 %{_mandir}/man1/emu-*
139 %dir %{_datadir}/emu10k1
140 %{_datadir}/emu10k1/*.bin
141 %{_datadir}/emu10k1/README.gz
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(750,root,root) %{_bindir}/as10k1
146 %doc docs/dsp.txt.gz docs/manuals.txt.gz docs/registers.txt.gz docs/tram.txt.gz
147 %{_mandir}/man1/as10k1*
148 %dir %{_datadir}/emu10k1/asm
149 %{_datadir}/emu10k1/asm/*
150
151 %files autoconfig
152 %defattr(644,root,root,755)
153 %attr(750,root,root) %{_bindir}/emu-script
154 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/emu10k1.conf
This page took 0.225775 seconds and 3 git commands to generate.