]> git.pld-linux.org Git - packages/empy.git/blob - empy.spec
- rel. 3 (rebuild with python 2.5)
[packages/empy.git] / empy.spec
1 Summary:        System for embedding Python expressions and statements in template text
2 Summary(pl):    System wbudowywania wyra¿eñ jêzyka Python w pliki tekstowe
3 Name:           empy
4 Version:        3.3
5 Release:        3
6 License:        LGPL
7 Group:          Applications/Text
8 Source0:        http://www.alcyone.com/software/empy/%{name}-%{version}.tar.gz
9 # Source0-md5:  e7b518a6fc4fd28fef87726cdb003118
10 URL:            http://www.alcyone.com/software/empy/
11 %pyrequires_eq  python-modules
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 System for embedding Python expressions and statements in template
17 text.
18
19 %description -l pl
20 System wbudowywania wyra¿eñ jêzyka Python w pliki tekstowe.
21
22 %prep
23 %setup -q
24
25 %build
26 python setup.py build
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
31
32 python setup.py install \
33         --optimize=2 \
34         --root=$RPM_BUILD_ROOT
35
36 cat > $RPM_BUILD_ROOT%{_bindir}/em.py <<"EOF"
37 #!/usr/bin/python
38 import em
39 em.invoke(sys.argv[1:])
40 EOF
41
42 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.py
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README *.em doc
50 %attr(755,root,root) %{_bindir}/*
51 %{py_sitescriptdir}/*.py[co]
This page took 0.048628 seconds and 3 git commands to generate.