]> git.pld-linux.org Git - packages/emotion.git/blobdiff - emotion.spec
- note efl.spec for later versions
[packages/emotion.git] / emotion.spec
index 1e640a50d8552b70fea0e9810a30ae6c170fbb73..631507ad4b71f06a2f0384d9b0ec43e99729a548 100644 (file)
-Summary:       Enlightenment Fundation Libraries - Emotion
-Summary(pl):   Podstawowe biblioteki Enlightenmenta - Emotion
+# NOTE: for versions >= 1.8 see efl.spec, emotion-decoders-generic.spec
+#
+# Conditional build:
+%bcond_without gstreamer       # don't build gstreamer decoder
+%bcond_without vlc             # don't build vlc generic decoder
+%bcond_without xine            # don't build xine decoder
+%bcond_without static_libs     # don't build static library
+#
+%define                ecore_ver       1.7.9
+%define                edje_ver        1.7.9
+%define                eet_ver         1.7.9
+%define                eeze_ver        1.7.9
+%define                eina_ver        1.7.9
+%define                eio_ver         1.7.9
+%define                evas_ver        1.7.9
+
+Summary:       Emotion - EFL media playback library
+Summary(pl.UTF-8):     Emotion - biblioteka EFL do odtwarzania multimediów
 Name:          emotion
-Version:       0.0.1.003
-%define        _snap   20050701
-Release:       0.%{_snap}.0.1
-License:       BSD
-Group:         X11/Libraries
-#Source0:      http://dl.sourceforge.net/enlightenment/%{name}-%{version}.tar.gz
-Source0:       http://sparky.homelinux.org/snaps/enli/e17/libs/%{name}-%{_snap}.tar.gz
-# Source0-md5: b93da3ce3da37483ad4721facb050744
-URL:           http://enlightenment.org/
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: edje-devel
+Version:       1.7.9
+Release:       1
+License:       BSD-like
+Group:         Libraries
+Source0:       http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
+# Source0-md5: 85792e42b44e3af5df56c26c802c29b0
+Patch0:                %{name}-am.patch
+URL:           http://trac.enlightenment.org/e/wiki/Emotion
+BuildRequires: autoconf >= 2.60
+BuildRequires: automake >= 1.6
+BuildRequires: ecore-devel >= %{ecore_ver}
+BuildRequires: ecore-evas-devel >= %{ecore_ver}
+BuildRequires: ecore-fb-devel >= %{ecore_ver}
+BuildRequires: ecore-x-devel >= %{ecore_ver}
+BuildRequires: edje >= %{edje_ver}
+BuildRequires: edje-devel >= %{edje_ver}
+BuildRequires: eet-devel >= %{eet_ver}
+BuildRequires: eeze-devel >= %{eeze_ver}
+BuildRequires: eio-devel >= %{eio_ver}
+BuildRequires: eina-devel >= %{eina_ver}
+BuildRequires: evas-devel >= %{evas_ver}
+%if %{with gstreamer}
+BuildRequires: gstreamer0.10-devel >= 0.10.2
+BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10.34
+%endif
 BuildRequires: libtool
-BuildRequires: xine-lib-devel
+BuildRequires: pkgconfig >= 1:0.22
+%{?with_vlc:BuildRequires:     vlc-devel >= 0.9}
+%{?with_xine:BuildRequires:    xine-lib-devel >= 2:1.1.1}
+Requires:      ecore >= %{ecore_ver}
+Requires:      ecore-evas >= %{ecore_ver}
+Requires:      ecore-fb >= %{ecore_ver}
+Requires:      ecore-x >= %{ecore_ver}
+Requires:      edje-libs >= %{edje_ver}
+Requires:      eet >= %{eet_ver}
+Requires:      eeze >= %{eeze_ver}
+Requires:      eina >= %{eina_ver}
+Requires:      eio >= %{eio_ver}
+Requires:      evas >= %{evas_ver}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Emotion is a Media Library.
+Emotion is a library to easily integrate media playback into EFL
+applications, it will take care of using Ecore's main loop and video
+display is done using Evas.
 
-%description -l pl
-Emotion to biblioteka multimedialna.
+%description -l pl.UTF-8
+Emotion to biblioteka pozwalająca na łatwą integrację odtwarzania
+multimediów w aplikacjach EFL. Współpracuje z główną pętlą Ecore, a do
+wyświetlania wykorzystuje bibliotekę Evas.
 
 %package devel
 Summary:       Emotion header files
-Summary(pl):   Pliki nag³ówkowe Emotion
+Summary(pl.UTF-8):     Pliki nagłówkowe Emotion
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      xine-lib-devel
+Requires:      ecore-devel >= %{ecore_ver}
+Requires:      eio-devel >= %{eio_ver}
+Requires:      eet-devel >= %{eet_ver}
+Requires:      eeze-devel >= %{eeze_ver}
+Requires:      eina-devel >= %{eina_ver}
+Requires:      evas-devel >= %{evas_ver}
 
 %description devel
 Header files for Emotion.
 
-%description devel -l pl
-Pliki nag³ówkowe Emotion.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe Emotion.
 
 %package static
 Summary:       Static Emotion library
-Summary(pl):   Statyczna biblioteka Emotion
+Summary(pl.UTF-8):     Statyczna biblioteka Emotion
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static Emotion library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna biblioteka Emotion.
 
+%package decoder-gstreamer
+Summary:       Emotion decoder using gstreamer
+Summary(pl.UTF-8):     Dekoder Emotion używający gstreamera
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      gstreamer0.10 >= 0.10.2
+Requires:      gstreamer0.10-plugins-base >= 0.10.34
+
+%description decoder-gstreamer
+Emotion decoder using gstreamer.
+
+%description decoder-gstreamer -l pl.UTF-8
+Dekoder Emotion używający gstreamera.
+
+%package decoder-xine
+Summary:       Emotion decoder using xine
+Summary(pl.UTF-8):     Dekoder Emotion używający xine
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      xine-lib >= 2:1.1.1
+
+%description decoder-xine
+Emotion decoder using xine.
+
+%description decoder-xine -l pl.UTF-8
+Dekoder Emotion używający xine.
+
+%package decoder-vlc
+Summary:       Emotion decoder using vlc
+Summary(pl.UTF-8):     Dekoder Emotion używający vlc
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      vlc >= 0.9
+
+%description decoder-vlc
+Emotion decoder using vlc and Emotion generic plugin.
+
+%description decoder-vlc -l pl.UTF-8
+Dekoder Emotion używający vlc i wtyczkę generic biblioteki Emotion.
+
 %prep
-%setup -q -n %{name}
+%setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -57,7 +148,12 @@ Statyczna biblioteka Emotion.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       --disable-silent-rules \
+       %{!?with_static_libs:--disable-static} \
+       %{!?with_vlc:--disable-generic-vlc} \
+       %{!?with_gstreamer:--disable-gstreamer} \
+       %{!?with_xine:--disable-xine}
 %{__make}
 
 %install
@@ -66,8 +162,13 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/xine/plugins/*/*.{la,a} \
-       $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la \
+       $RPM_BUILD_ROOT%{_libdir}/edje/modules/emotion/linux-gnu-*/*.la
+
+%if %{without vlc}
+# dir not installed if vlc module not installed
+install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/utils
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -77,23 +178,45 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING COPYING-PLAIN README TODO
-%attr(755,root,root) %{_bindir}/emotion_*
+%doc AUTHORS COPYING ChangeLog README TODO
+%attr(755,root,root) %{_bindir}/emotion_test
 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libemotion.so.1
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_xine.so
-%{_libdir}/%{name}/emotion_decoder_xine.la
-%attr(755,root,root) %{_libdir}/xine/plugins/*/xineplug_vo_out_emotion.so
+%attr(755,root,root) %{_libdir}/%{name}/em_generic.so
+%dir %{_libdir}/%{name}/utils
+%dir %{_libdir}/edje/modules/emotion
+%dir %{_libdir}/edje/modules/emotion/linux-gnu-*
+%attr(755,root,root) %{_libdir}/edje/modules/emotion/linux-gnu-*/module.so
 %{_datadir}/%{name}
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/emotion-config
 %attr(755,root,root) %{_libdir}/libemotion.so
 %{_libdir}/libemotion.la
-%{_includedir}/Emotion*
+%{_includedir}/emotion-1
 %{_pkgconfigdir}/emotion.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libemotion.a
+%endif
+
+%if %{with gstreamer}
+%files decoder-gstreamer
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/gstreamer.so
+%endif
+
+%if %{with xine}
+%files decoder-xine
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/xine.so
+%endif
+
+%if %{with vlc}
+%files decoder-vlc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/utils/em_generic_vlc
+%endif
This page took 0.094977 seconds and 4 git commands to generate.