]> git.pld-linux.org Git - packages/emotion.git/blobdiff - emotion.spec
- more flexible to update
[packages/emotion.git] / emotion.spec
index ad0f4499912538f8c4ab46d7700b1d65c438dd38..0aa787ac50867801084d253ed103924f879f0370 100644 (file)
 %bcond_without static_libs     # don't build static library
 #
 %if !%{with gstreamer} && !%{with xine}
-error at last one backend must be enabled
+%error at last one backend must be enabled
 %endif
 #
+%define                ecore_ver       0.9.9
+%define                edje_ver        0.5.0
+%define                evas_ver        0.9.9
+
 Summary:       Enlightenment Fundation Libraries - Emotion
-Summary(pl):   Podstawowe biblioteki Enlightenmenta - Emotion
+Summary(pl.UTF-8):     Podstawowe biblioteki Enlightenmenta - Emotion
 Name:          emotion
-Version:       0.0.1.004
-%define        _snap   20060625
-Release:       2.%{_snap}.1
+Version:       0.0.1.005
+Release:       1
 License:       BSD
 Group:         X11/Libraries
-#Source0:      http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
-Source0:       http://sparky.homelinux.org/snaps/enli/e17/libs/%{name}-%{_snap}.tar.bz2
-# Source0-md5: aa4f66fba709b4b08c2ed49eda196657
-URL:           http://enlightenment.org/Libraries/Emotion/
+Source0:       http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
+# Source0-md5: e1550ff7a8f68b76b76a4d857073b3ee
+URL:           http://enlightenment.org/p.php?p=about/libs/emotion
 BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: edje
-BuildRequires: edje-devel
+BuildRequires: automake >= 1.4
+# ecore-evas ecore-job
+BuildRequires: ecore-devel >= %{ecore_ver}
+BuildRequires: edje >= %{edje_ver}
+BuildRequires: edje-devel >= %{edje_ver}
+BuildRequires: evas-devel >= %{evas_ver}
 %if %{with gstreamer}
-BuildRequires: gstreamer-cdio
 BuildRequires: gstreamer-devel >= 0.10.2
-BuildRequires: gstreamer-ffmpeg
 BuildRequires: gstreamer-plugins-base-devel >= 0.10.1
+# gstreamer-cdio,gstreamer-ffmpeg for runtime, configure just warns if missing
 %endif
 BuildRequires: libtool
 BuildRequires: pkgconfig
 %{?with_xine:BuildRequires:    xine-lib-devel >= 2:1.1.1}
+Requires:      ecore-evas >= %{ecore_ver}
+Requires:      ecore-job >= %{ecore_ver}
+Requires:      edje-libs >= %{edje_ver}
+Requires:      evas >= %{evas_ver}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Emotion is a Media Library.
 
-%description -l pl
+%description -l pl.UTF-8
 Emotion to biblioteka multimedialna.
 
 %package devel
 Summary:       Emotion header files
-Summary(pl):   Pliki nag³ówkowe Emotion
+Summary(pl.UTF-8):     Pliki nagłówkowe Emotion
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+# ecore-evas ecore-job
+Requires:      ecore-devel >= %{ecore_ver}
+Requires:      edje-devel >= %{edje_ver}
+Requires:      evas-devel >= %{evas_ver}
 
 %description devel
 Header files for Emotion.
 
-%description devel -l pl
-Pliki nag³ówkowe Emotion.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe Emotion.
 
 %package static
 Summary:       Static Emotion library
-Summary(pl):   Statyczna biblioteka Emotion
+Summary(pl.UTF-8):     Statyczna biblioteka Emotion
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static Emotion library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna biblioteka Emotion.
 
 %package decoder-gstreamer
 Summary:       Emotion decoder using gstreamer
-Summary(pl):   Dekoder Emotion u¿ywaj±cy gstreamera
+Summary(pl.UTF-8):     Dekoder Emotion używający gstreamera
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      gstreamer >= 0.10.2
+Requires:      gstreamer-plugins-base >= 0.10.1
+Suggests:      gstreamer-cdio
+Suggests:      gstreamer-ffmpeg
 
 %description decoder-gstreamer
 Emotion decoder using gstreamer.
 
-%description decoder-gstreamer -l pl
-Dekoder Emotion u¿ywaj±cy gstreamera.
+%description decoder-gstreamer -l pl.UTF-8
+Dekoder Emotion używający gstreamera.
 
 %package decoder-xine
 Summary:       Emotion decoder using xine
-Summary(pl):   Dekoder Emotion u¿ywaj±cy xine
+Summary(pl.UTF-8):     Dekoder Emotion używający xine
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      xine-lib >= 2:1.1.1
 
 %description decoder-xine
 Emotion decoder using xine.
 
-%description decoder-xine -l pl
-Dekoder Emotion u¿ywaj±cy xine.
+%description decoder-xine -l pl.UTF-8
+Dekoder Emotion używający xine.
 
 %prep
-%setup -q -n %{name}
+%setup -q
 
 %build
 %{__libtoolize}
@@ -110,6 +127,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -124,26 +143,12 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}
 %{_datadir}/%{name}
 
-%if %{with gstreamer}
-%files decoder-gstreamer
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_gstreamer.so
-%endif
-
-%if %{with xine}
-%files decoder-xine
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_xine.so
-%endif
-
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/emotion-config
 %attr(755,root,root) %{_libdir}/libemotion.so
 %{_libdir}/libemotion.la
-%{_libdir}/%{name}/emotion_decoder_gstreamer.la
-#%{_libdir}/%{name}/emotion_decoder_xine.la
-%{_includedir}/Emotion*
+%{_includedir}/Emotion.h
 %{_pkgconfigdir}/emotion.pc
 
 %if %{with static_libs}
@@ -151,3 +156,15 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libemotion.a
 %endif
+
+%if %{with gstreamer}
+%files decoder-gstreamer
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_gstreamer.so
+%endif
+
+%if %{with xine}
+%files decoder-xine
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/emotion_decoder_xine.so
+%endif
This page took 0.120942 seconds and 4 git commands to generate.