]> git.pld-linux.org Git - packages/emoticons.git/blob - emoticons.spec
- move binary sources to distfiles
[packages/emoticons.git] / emoticons.spec
1 Summary:        EmotIcons
2 Summary(pl.UTF-8):      EmotIkonki
3 Name:           emoticons
4 Version:        0.1
5 Release:        0.1
6 License:        GPL (?)
7 Group:          Applications/Communications
8 Source0:        %{name}-gg-031212.tgz
9 # Source0-md5:  eb824103b01d2fb4bd376b0540ba176d
10 URL:            http://www.gadu.gnu.pl/
11 BuildRequires:  ImageMagick-coder-png
12 BuildRequires:  iconv
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 EmoteIcons.
17
18 %description -l pl.UTF-8
19 EmotIkonki.
20
21 %package kopete-gg
22 Summary:        Gadu-Gadu emoticons for kopete
23 Summary(pl.UTF-8):      Emotikonki Gadu-Gadu dla kopete
24 Group:          X11/Applications/Networking
25 Requires:       kdenetwork-kopete
26
27 %description kopete-gg
28 Gadu-Gadu emoticons for kopete.
29
30 %description kopete-gg -l pl.UTF-8
31 Emotikonki Gadu-Gadu dla kopete.
32
33 %prep
34 %setup -qc
35
36 %build
37 %{__cc} %{rpmldflags} %{rpmcflags} -o conv conv.c
38
39 rm -rf out; mkdir out
40 # oryginal emots/2/emots.txt have some errors :(
41 cat emots/2/emots.txt | \
42     sed 's/<soczek>,/<soczek>"/' | \
43     sed 's:("<marzyciel>","oczy.gif"):"<marzyciel>","oczy.gif":' \
44     > emots/2/emotsnew.txt
45 rm -f emots/2/emots.txt
46
47 FILES=`find emots -type f -iname "*.txt"`
48 cat $FILES > emots.txt
49
50 echo -e -n "<?xml version=\"1.0\"?>\n<messaging-emoticon-map>\n\n" > emoticons.xml.tmp
51 ./conv emots.txt >> emoticons.xml.tmp
52 echo -e -n "</messaging-emoticon-map>\n" >> emoticons.xml.tmp
53
54 cat emoticons.xml.tmp | iconv -f cp1250 -t utf-8 > out/emoticons.xml
55 FILES=`find emots -type f -iname "*.gif"`
56 for FILE in $FILES
57 do
58     F=`basename $FILE | tr '[:upper:]' '[:lower:]'`
59     cp $FILE out/$F
60 done
61 convert out/wesoly_na.gif out/smile.png
62 rm -f out/*_na.*
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_datadir}/apps/kopete/pics/emoticons/Gadu-Gadu
67
68 cp out/* $RPM_BUILD_ROOT%{_datadir}/apps/kopete/pics/emoticons/Gadu-Gadu
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files kopete-gg
74 %defattr(644,root,root,755)
75 %{_datadir}/apps/kopete/pics/emoticons/Gadu-Gadu
This page took 0.062525 seconds and 3 git commands to generate.