]> git.pld-linux.org Git - packages/emoticons.git/blame - emoticons.spec
- initial release
[packages/emoticons.git] / emoticons.spec
CommitLineData
e927064c 1#
2Summary: EmotIcons
3Name: emoticons
4Version: 0.1
5Release: 0.1
6License: GPL ?
7Group: Applications/Communications
8Source0: %{name}-gg-031212.tgz
9URL: http://www.gadu.gnu.pl/
10BuildRequires: ImageMagick-coder-png
11BuildRequires: iconv
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15EmoteIcons
16
17%package -n emoticons-kopete-gg
18Summary: Gadu-Gadu emoticons for kopete
19Group: X11/Applications/Networking
20Requires: kdenetwork-kopete
21
22%description -n emoticons-kopete-gg
23Gadu-Gadu emoticons for kopete
24
25%prep
26%setup -Tcqn %{name} -a0
27
28%build
29gcc -o conv conv.c
30
31rm -rf out; mkdir out
32# oryginal emots/2/emots.txt have some errors :(
33cat emots/2/emots.txt | \
34 sed 's/<soczek>,/<soczek>"/' | \
35 sed 's:("<marzyciel>","oczy.gif"):"<marzyciel>","oczy.gif":' \
36 > emots/2/emotsnew.txt
37rm -f emots/2/emots.txt
38
39FILES=`find emots -type f -iname "*.txt"`
40cat $FILES > emots.txt
41
42echo -e -n "<?xml version=\"1.0\"?>\n<messaging-emoticon-map>\n\n" > emoticons.xml.tmp
43./conv emots.txt >> emoticons.xml.tmp
44echo -e -n "</messaging-emoticon-map>\n" >> emoticons.xml.tmp
45
46cat emoticons.xml.tmp | iconv -f cp1250 -t utf-8 > out/emoticons.xml
47FILES=`find emots -type f -iname "*.gif"`
48for FILE in $FILES
49do
50 F=`basename $FILE | tr '[:upper:]' '[:lower:]'`
51 cp $FILE out/$F
52done
53convert out/wesoly_na.gif out/smile.png
54rm -f out/*_na.*
55
56%install
57rm -rf $RPM_BUILD_ROOT
58
59install -d $RPM_BUILD_ROOT%{_datadir}/apps/kopete/pics/emoticons/Gadu-Gadu/
60cp out/* $RPM_BUILD_ROOT%{_datadir}/apps/kopete/pics/emoticons/Gadu-Gadu/
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files -n emoticons-kopete-gg
66%defattr(644,root,root,755)
67%{_datadir}/apps/kopete/pics/emoticons/Gadu-Gadu/*
This page took 0.089342 seconds and 4 git commands to generate.