]> git.pld-linux.org Git - packages/emesene.git/commitdiff
- locate .pyc plugins
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 21 Mar 2010 11:19:54 +0000 (11:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    emesene.spec -> 1.7
    plugins-pyc.patch -> 1.1

emesene.spec
plugins-pyc.patch [new file with mode: 0644]

index ca782641c8cc5b9da8fa62aa3276f4f750d53c02..cb9c284c16079acac25494c6b883082bf97000f9 100644 (file)
@@ -1,7 +1,7 @@
 Summary:       Instant messaging client for Windows Live Messenger (tm) network
 Name:          emesene
 Version:       1.6
-Release:       0.15
+Release:       0.16
 License:       GPL v2+
 Group:         Applications/Networking
 URL:           http://www.emesene.org/
@@ -9,6 +9,7 @@ Source0:        http://downloads.sourceforge.net/project/emesene/%{name}-%{version}/eme
 # Source0-md5: ea4d3f4097265daac6823d8288979d02
 Patch0:                %{name}-desktop.patch
 Patch1:                setup-install.patch
+Patch2:                plugins-pyc.patch
 BuildRequires: gettext
 BuildRequires: python-devel
 BuildRequires: rpmbuild(macros) >= 1.219
@@ -40,6 +41,7 @@ picture.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 cat <<'EOF' > emesene.sh
 #!/bin/sh
diff --git a/plugins-pyc.patch b/plugins-pyc.patch
new file mode 100644 (file)
index 0000000..67e64e1
--- /dev/null
@@ -0,0 +1,13 @@
+--- emesene-1.6/PluginManager.py~      2009-12-24 14:55:03.000000000 +0200
++++ emesene-1.6/PluginManager.py       2010-03-21 13:11:23.769597184 +0200
+@@ -92,8 +92,8 @@
+         path = path + paths.DIR_SEP + package
+         modules = [ x.split( '.' )[ 0 ] for x in os.listdir( path ) \
+-                    if x.endswith( '.py' ) and not x.startswith( '_' ) \
+-                    and x != 'Plugin.py' ]
++                    if (x.endswith( '.py' ) or x.endswith ('.pyc')) and not x.startswith( '_' ) \
++                    and x != 'Plugin.py' and x != 'Plugin.pyc' ]
+         plugins = {}
+         plugins = plugins.fromkeys( modules )
+         
This page took 0.089167 seconds and 4 git commands to generate.