]> git.pld-linux.org Git - packages/emerald.git/commitdiff
- added emerald-gtk+2_2_20.patch (fix build with gtk+2 2.20)
authorJarosław Kruk <jareq@pld-linux.org>
Wed, 8 Sep 2010 16:28:22 +0000 (16:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- rel 2

Changed files:
    emerald-gtk+2_2_20.patch -> 1.1
    emerald.spec -> 1.41

emerald-gtk+2_2_20.patch [new file with mode: 0644]
emerald.spec

diff --git a/emerald-gtk+2_2_20.patch b/emerald-gtk+2_2_20.patch
new file mode 100644 (file)
index 0000000..a21d528
--- /dev/null
@@ -0,0 +1,33 @@
+--- emerald-0.8.4/src/main.c.old       2010-03-29 19:49:30.420710030 -0700
++++ emerald-0.8.4/src/main.c   2010-03-29 19:52:33.654024944 -0700
+@@ -3757,7 +3757,7 @@
+ static void hide_tooltip(void)
+ {
+-    if (GTK_WIDGET_VISIBLE(tip_window))
++    if (gtk_widget_get_visible(tip_window))
+       g_get_current_time(&tooltip_last_popdown);
+     gtk_widget_hide(tip_window);
+
+diff -urN emerald-0.8.4/libengine/themer.c emerald-0.8.4.new/libengine/themer.c
+--- emerald-0.8.4/libengine/themer.c   2009-10-13 20:56:23.000000000 -0400
++++ emerald-0.8.4.new/libengine/themer.c       2010-03-10 01:20:03.046827674 -0500
+@@ -461,7 +461,7 @@
+ }
+ gdouble get_float(SettingItem * item)
+ {
+-    if(!strcmp(GTK_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
++    if(!strcmp(G_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
+          return gtk_spin_button_get_value((GtkSpinButton *)item->widget);
+     }
+     else {
+@@ -647,7 +647,7 @@
+ }
+ void set_float(SettingItem * item, gdouble f)
+ {
+-    if(!strcmp(GTK_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
++    if(!strcmp(G_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
+          gtk_spin_button_set_value((GtkSpinButton *)item->widget, f);
+     } 
+     else {
index 6863f758b1a56a5dd42c2576823983cb560c3806..0600754dbbd9e9f899ea619607ea4fa8df15525d 100644 (file)
@@ -2,13 +2,14 @@ Summary:      An alternative themeable window decorator
 Summary(pl.UTF-8):     Alternatywny dekorator okien z obsługą motywów
 Name:          emerald
 Version:       0.8.4
-Release:       1
+Release:       2
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
 # Source0-md5: e92fbe8252ea393206d98ed6ae9af4ec
 Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-gtk+2_2_20.patch
 URL:           http://www.compiz.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1:1.9
@@ -71,6 +72,7 @@ Statyczna biblioteka Emerald Engines.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__glib_gettextize}
This page took 0.075372 seconds and 4 git commands to generate.