]> git.pld-linux.org Git - packages/embryo.git/blob - embryo.spec
c52c23972312100a32a60b4732b691fa0692ce8d
[packages/embryo.git] / embryo.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightenment Fundation Libraries - Embryo
6 Summary(pl.UTF-8):      Podstawowe biblioteki Enlightenmenta - Embryo
7 Name:           embryo
8 Version:        1.0.0
9 Release:        2
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
13 # Source0-md5:  12f6c7d1d39c223d412351594a24dc64
14 URL:            http://enlightenment.org/p.php?p=about/libs/embryo
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake >= 1.6
17 BuildRequires:  libtool
18 BuildRequires:  pkgconfig >= 1:0.22
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %undefine       __cxx
22
23 %description
24 Embryo is a tiny library designed as a virtual machine to interpret a
25 limited set of small compiled programs.
26
27 %description -l pl.UTF-8
28 Embryo to mała biblioteka zaprojektowana jako maszyna wirtualna do
29 interpretowania ograniczonego zbioru małych skompilowanych programów.
30
31 %package devel
32 Summary:        Embryo header files
33 Summary(pl.UTF-8):      Pliki nagłówkowe Embryo
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for Embryo.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe Embryo.
42
43 %package static
44 Summary:        Static Embryo library
45 Summary(pl.UTF-8):      Statyczna biblioteka Embryo
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static Embryo library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka Embryo.
54
55 %prep
56 %setup -q
57
58 %build
59 %{__libtoolize}
60 %{__aclocal} -I m4
61 %{__autoconf}
62 %{__autoheader}
63 %{__automake}
64 %configure \
65         --disable-silent-rules \
66         %{!?with_static_libs:--disable-static}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS COPYING ChangeLog README
84 %attr(755,root,root) %{_bindir}/embryo_cc
85 %attr(755,root,root) %{_libdir}/libembryo.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libembryo.so.1
87 # for embryo_cc
88 %{_datadir}/%{name}
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libembryo.so
93 %{_libdir}/libembryo.la
94 %{_includedir}/embryo-1
95 %{_pkgconfigdir}/embryo.pc
96
97 %if %{with static_libs}
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/libembryo.a
101 %endif
This page took 0.074441 seconds and 3 git commands to generate.