]> git.pld-linux.org Git - packages/emacsen-gnus-pkg.git/blob - emacsen-gnus-pkg.spec
- xemacs support cleaned up, disable build
[packages/emacsen-gnus-pkg.git] / emacsen-gnus-pkg.spec
1 #
2 # Conditional build:
3 %bcond_with     xemacs  # Build without XEmacs support
4 %bcond_with     emacs   # Build with GNU Emacs support
5 %bcond_with     pdf_doc # Don't build PDF documentation
6 #
7 %define         _the_name gnus
8 Summary:        An Emacs/XEmacs newsreader and mail client
9 Summary(pl.UTF-8):      Czytnik grup dyskusyjnych i klient poczty dla Emacsa/XEmacsa
10 Name:           emacsen-gnus-pkg
11 Version:        5.10.10
12 Release:        6.see-web-page-why-not-this-package
13 License:        GPL
14 Group:          Applications/Networking
15 Source0:        http://www.gnus.org/dist/%{_the_name}-%{version}.tar.gz
16 # Source0-md5:  dd4ea349448a005ff5d068ba57ad9bca
17 Patch0:         %{name}-destdir.patch
18 URL:            http://www.gnus.org/
19 %if %{with pdf_doc}
20 BuildRequires:  texinfo-texi2dvi
21 BuildRequires:  tetex-latex
22 BuildRequires:  tetex-makeindex
23 BuildRequires:  tetex-dvips
24 BuildRequires:  tetex-format-pdftex
25 %endif
26 %if %{with emacs}
27 BuildRequires:  emacs
28 %endif
29 %if %{with xemacs}
30 BuildRequires:  xemacs
31 BuildRequires:  xemacs-dired-pkg
32 BuildRequires:  xemacs-eterm-pkg
33 BuildRequires:  xemacs-fsf-compat-pkg
34 BuildRequires:  xemacs-mail-lib-pkg
35 BuildRequires:  xemacs-mailcrypt-pkg
36 BuildRequires:  xemacs-mh-e-pkg
37 BuildRequires:  xemacs-os-utils-pkg
38 BuildRequires:  xemacs-sh-script-pkg
39 BuildRequires:  xemacs-texinfo-pkg
40 BuildRequires:  xemacs-w3-pkg
41 %endif
42 Requires:       gnus-elisp-code = %{version}-%{release}
43 Requires:       starttls
44 Conflicts:      xemacs-gnus-pkg
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 You can read news (and mail) from within GNU Emacs or XEmacs by using
50 Gnus. The news can be gotten by any nefarious means you can think of
51 -- NNTP, local spool or your mbox file.
52
53 This package contains files common to both GNU Emacs and XEmacs.
54
55 %description -l pl.UTF-8
56 Dzięki pakietowi Gnus możesz czytać newsy i pocztę z użyciem GNU
57 Emacsa lub XEmacsa. Gnus może pobierać listy z najróżniejszych źródeł,
58 w tym z serwera NNTP, lokalnego spoola jak i plików mbox.
59
60 Ten pakiet zawiera pliki Gnusa wspólne dla GNU Emacsa i XEmacsa.
61
62 %package emacs
63 Summary:        Gnus elisp files for GNU Emacs
64 Summary(pl.UTF-8):      Kod elisp Gnusa dla GNU Emacsa
65 Group:          Applications/Networking
66 Requires:       %{name} = %{version}-%{release}
67 %requires_eq    emacs
68 Provides:       gnus-elisp-code = %{version}-%{release}
69
70 %description emacs
71 This package contains compiled elisp files needed to run Gnus on GNU Emacs
72
73 %description emacs -l pl.UTF-8
74 Pakiet zawiera skompilowane pliki elisp z kodem Gnusa dla GNU Emacsa.
75
76 %package emacs-el
77 Summary:        Gnus elisp source files for GNU Emacs
78 Summary(pl.UTF-8):      Kod źródłowy elisp Gnusa dla GNU Emacsa
79 Group:          Applications/Networking
80 Requires:       %{name}-emacs = %{version}-%{release}
81
82 %description emacs-el
83 This package contains source elisp files needed to run Gnus on GNU Emacs
84
85 %description emacs-el -l pl.UTF-8
86 Pakiet zawiera źródłowe pliki elisp z kodem Gnusa dla GNU Emacsa.
87
88 %package xemacs
89 Summary:        Gnus elisp files for XEmacs
90 Summary(pl.UTF-8):      Kod elisp Gnusa dla XEmacsa
91 Group:          Applications/Networking
92 Requires:       %{name} = %{version}-%{release}
93 %requires_eq    xemacs
94 Requires:       xemacs-mail-lib-pkg
95 Requires:       xemacs-eterm-pkg
96 Requires:       xemacs-sh-script-pkg
97 Requires:       xemacs-os-utils-pkg
98 Requires:       xemacs-dired-pkg
99 Requires:       xemacs-mh-e-pkg
100 Requires:       xemacs-mailcrypt-pkg
101 Requires:       xemacs-fsf-compat-pkg
102 Provides:       gnus-elisp-code = %{version}-%{release}
103
104 %description xemacs
105 This package contains compiled elisp files needed to run Gnus on XEmacs
106
107 %description xemacs -l pl.UTF-8
108 Pakiet zawiera skompilowane pliki elisp z kodem Gnusa dla XEmacsa.
109
110 %package xemacs-el
111 Summary:        Gnus elisp source files for XEmacs
112 Summary(pl.UTF-8):      Kod źródłowy elisp Gnusa dla XEmacsa
113 Group:          Applications/Networking
114 Requires:       %{name}-xemacs = %{version}-%{release}
115
116 %description xemacs-el
117 This package contains source elisp files needed to run Gnus on XEmacs
118
119 %description xemacs-el -l pl.UTF-8
120 Pakiet zawiera pliki źródłowe elisp z kodem Gnusa dla XEmacsa.
121
122 %package pdf-doc
123 Summary:        PDF documentation for Gnus
124 Summary(pl.UTF-8):      Dokumentacja Gnusa w formacie PDF
125 Group:          Documentation
126
127 %description pdf-doc
128 Documentation for Gnus in PDF format
129
130 %description pdf-doc -l pl.UTF-8
131 Dokumentacja Gnusa w formacie PDF
132
133 %prep
134 %setup -q -n %{_the_name}-%{version}
135 %patch0 -p1
136
137 %build
138 mkdir DUMMY
139
140 %if %{with xemacs}
141 %configure \
142         --with-xemacs \
143         --with-lispdir=%{_datadir}/xemacs-packages/lisp/%{_the_name} \
144         --with-etcdir=%{_datadir}/%{_the_name}
145 %{__make}
146
147 %if %{without emacs} && %{with pdf_doc}
148 %{__make} -j1 -C texi pdf
149 %endif
150
151 %{__make} install \
152         DESTDIR=$(pwd)/DUMMY
153 %{__make} distclean
154 %endif
155
156 %if %{with emacs}
157 %configure \
158         --with-emacs \
159         --with-lispdir=%{_emacs_lispdir}/%{_the_name} \
160         --with-etcdir=%{_datadir}/%{_the_name}
161 %{__make}
162
163 %if %{with pdf_doc}
164 %{__make} -j1 -C texi pdf
165 %endif
166
167 %{__make} install \
168         DESTDIR=$(pwd)/DUMMY
169 %endif
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173 cp -R ./DUMMY $RPM_BUILD_ROOT
174 install -d $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/etc
175 ln -s ../../gnus $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/etc
176
177 for ff in $RPM_BUILD_ROOT%{_infodir}/* ; do
178         mv -f $ff $ff.info
179 done
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc ChangeLog GNUS-NEWS README todo contrib
187 %{_datadir}/%{_the_name}
188 %{_infodir}/*.info*
189
190 %if %{with emacs}
191 %files emacs
192 %defattr(644,root,root,755)
193 %dir %{_emacs_lispdir}/%{_the_name}
194 %{_emacs_lispdir}/%{_the_name}/*.elc
195
196 %files emacs-el
197 %defattr(644,root,root,755)
198 %{_emacs_lispdir}/%{_the_name}/*.el
199 %endif
200
201 %if %{with xemacs}
202 %files xemacs
203 %defattr(644,root,root,755)
204 %dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
205 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
206 %{_datadir}/xemacs-packages/etc/%{_the_name}
207
208 %files xemacs-el
209 %defattr(644,root,root,755)
210 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
211 %endif
212
213 %if %{with pdf_doc}
214 %files pdf-doc
215 %defattr(644,root,root,755)
216 %doc texi/*.pdf
217 %endif
This page took 0.094752 seconds and 3 git commands to generate.