]> git.pld-linux.org Git - packages/emacsen-gnus-pkg.git/blob - emacsen-gnus-pkg.spec
- no need to bcond preambles
[packages/emacsen-gnus-pkg.git] / emacsen-gnus-pkg.spec
1 %bcond_without  xemacs  # Build without XEmacs support
2 %bcond_without  emacs   # Build without GNU Emacs support
3 %bcond_without  pdf_doc # Don't build PDF documentation
4 %define         _the_name gnus
5 Summary:        An Emacs/XEmacs newsreader and mail client
6 Summary(pl.UTF-8):      Czytnik grup dyskusyjnych i klient poczty dla Emacsa/XEmacsa
7 Name:           emacsen-gnus-pkg
8 Version:        5.10.6
9 Release:        5
10 License:        GPL
11 Group:          Applications/Networking
12 Source0:        http://www.gnus.org/dist/%{_the_name}-%{version}.tar.gz
13 # Source0-md5:  8b510e5d2530f92af371eb64f828b257
14 Patch0:         %{name}-destdir.patch
15 URL:            http://www.gnus.org/
16 %if %{with pdf_doc}
17 BuildRequires:  texinfo-texi2dvi
18 BuildRequires:  tetex-latex
19 BuildRequires:  tetex-makeindex
20 BuildRequires:  tetex-dvips
21 BuildRequires:  tetex-format-pdftex
22 %endif
23 %if %{with emacs}
24 BuildRequires:  emacs
25 %endif
26 %if %{with xemacs}
27 BuildRequires:  xemacs
28 BuildRequires:  xemacs-mail-lib-pkg
29 BuildRequires:  xemacs-eterm-pkg
30 BuildRequires:  xemacs-sh-script-pkg
31 BuildRequires:  xemacs-os-utils-pkg
32 BuildRequires:  xemacs-dired-pkg
33 BuildRequires:  xemacs-mh-e-pkg
34 BuildRequires:  xemacs-mailcrypt-pkg
35 BuildRequires:  xemacs-fsf-compat-pkg
36 BuildRequires:  xemacs-texinfo-pkg
37 %endif
38 Requires:       gnus-elisp-code = %{version}-%{release}
39 Requires:       starttls
40 Conflicts:      xemacs-gnus-pkg
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 You can read news (and mail) from within GNU Emacs or XEmacs by using
46 Gnus. The news can be gotten by any nefarious means you can think of
47 -- NNTP, local spool or your mbox file.
48
49 This package contains files common to both GNU Emacs and XEmacs.
50
51 %description -l pl.UTF-8
52 Dzięki pakietowi Gnus możesz czytać newsy i pocztę z użyciem GNU
53 Emacsa lub XEmacsa. Gnus może pobierać listy z najróżniejszych źródeł,
54 w tym z serwera NNTP, lokalnego spoola jak i plików mbox.
55
56 Ten pakiet zawiera pliki Gnusa wspólne dla GNU Emacsa i XEmacsa.
57
58 %package emacs
59 Summary:        Gnus elisp files for GNU Emacs
60 Summary(pl.UTF-8):      Kod elisp Gnusa dla GNU Emacsa
61 Group:          Applications/Networking
62 Requires:       %{name} = %{version}-%{release}
63 Provides:       gnus-elisp-code = %{version}-%{release}
64 %requires_eq emacs
65
66 %description emacs
67 This package contains compiled elisp files needed to run Gnus on GNU Emacs
68
69 %description emacs -l pl.UTF-8
70 Pakiet zawiera skompilowane pliki elisp z kodem Gnusa dla GNU Emacsa.
71
72 %package emacs-el
73 Summary:        Gnus elisp source files for GNU Emacs
74 Summary(pl.UTF-8):      Kod źródłowy elisp Gnusa dla GNU Emacsa
75 Group:          Applications/Networking
76 Requires:       %{name}-emacs = %{version}-%{release}
77
78 %description emacs-el
79 This package contains source elisp files needed to run Gnus on GNU Emacs
80
81 %description emacs-el -l pl.UTF-8
82 Pakiet zawiera źródłowe pliki elisp z kodem Gnusa dla GNU Emacsa.
83
84 %package xemacs
85 Summary:        Gnus elisp files for XEmacs
86 Summary(pl.UTF-8):      Kod elisp Gnusa dla XEmacsa
87 Group:          Applications/Networking
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       xemacs-mail-lib-pkg
90 Requires:       xemacs-eterm-pkg
91 Requires:       xemacs-sh-script-pkg
92 Requires:       xemacs-os-utils-pkg
93 Requires:       xemacs-dired-pkg
94 Requires:       xemacs-mh-e-pkg
95 Requires:       xemacs-mailcrypt-pkg
96 Requires:       xemacs-fsf-compat-pkg
97 Provides:       gnus-elisp-code = %{version}-%{release}
98 %requires_eq emacs
99
100 %description xemacs
101 This package contains compiled elisp files needed to run Gnus on XEmacs
102
103 %description xemacs -l pl.UTF-8
104 Pakiet zawiera skompilowane pliki elisp z kodem Gnusa dla XEmacsa.
105
106 %package xemacs-el
107 Summary:        Gnus elisp source files for XEmacs
108 Summary(pl.UTF-8):      Kod źródłowy elisp Gnusa dla XEmacsa
109 Group:          Applications/Networking
110 Requires:       %{name}-xemacs = %{version}-%{release}
111
112 %description xemacs-el
113 This package contains source elisp files needed to run Gnus on XEmacs
114
115 %description xemacs-el -l pl.UTF-8
116 Pakiet zawiera pliki źródłowe elisp z kodem Gnusa dla XEmacsa.
117
118 %package pdf-doc
119 Summary:        PDF documentation for Gnus
120 Summary(pl.UTF-8):      Dokumentacja Gnusa w formacie PDF
121 Group:          Documentation
122
123 %description pdf-doc
124 Documentation for Gnus in PDF format
125
126 %description pdf-doc -l pl.UTF-8
127 Dokumentacja Gnusa w formacie PDF
128
129 %prep
130 %setup -q -n %{_the_name}-%{version}
131 %patch0 -p1
132
133 %build
134 mkdir DUMMY
135
136 %if %{with xemacs}
137 %configure \
138         --with-xemacs \
139         --with-lispdir=%{_datadir}/xemacs-packages/lisp/%{_the_name} \
140         --with-etcdir=%{_datadir}/%{_the_name}
141 %{__make}
142
143 %if %{without emacs} && %{with pdf_doc}
144 %{__make} -C texi pdf
145 %endif
146
147 %{__make} DESTDIR=$(pwd)/DUMMY install
148 %{__make} distclean
149 %endif
150
151 %if %{with emacs}
152 %configure \
153         --with-emacs \
154         --with-lispdir=%{_emacs_lispdir}/%{_the_name} \
155         --with-etcdir=%{_datadir}/%{_the_name}
156 %{__make}
157
158 %if %{with pdf_doc}
159 %{__make} -C texi pdf
160 %endif
161
162 %{__make} DESTDIR=$(pwd)/DUMMY install
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 cp -R ./DUMMY $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/etc
169 ln -s ../../gnus $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/etc
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %files
175 %defattr(644,root,root,755)
176 %doc ChangeLog GNUS-NEWS README todo contrib
177 %{_datadir}/%{_the_name}
178 %{_infodir}/*
179
180 %if %{with emacs}
181 %files emacs
182 %defattr(644,root,root,755)
183 %dir %{_emacs_lispdir}/%{_the_name}
184 %{_emacs_lispdir}/%{_the_name}/*.elc
185
186 %files emacs-el
187 %defattr(644,root,root,755)
188 %{_emacs_lispdir}/%{_the_name}/*.el
189 %endif
190
191 %if %{with xemacs}
192 %files xemacs
193 %defattr(644,root,root,755)
194 %dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
195 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
196 %{_datadir}/xemacs-packages/etc/%{_the_name}
197
198 %files xemacs-el
199 %defattr(644,root,root,755)
200 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
201 %endif
202
203 %if %{with pdf_doc}
204 %files pdf-doc
205 %defattr(644,root,root,755)
206 %doc texi/*.pdf
207 %endif
This page took 0.042282 seconds and 3 git commands to generate.