]> git.pld-linux.org Git - packages/emacsen-gnus-pkg.git/blob - emacsen-gnus-pkg.spec
New spec file.
[packages/emacsen-gnus-pkg.git] / emacsen-gnus-pkg.spec
1 %bcond_without  xemacs  # Build without XEmacs support
2 %bcond_without  emacs   # Build without GNU Emacs support
3 %bcond_without  pdf_doc # Don't build PDF documentation
4 %define         _the_name gnus
5 Summary:        An Emacs/XEmacs newsreader and mail client
6 Summary(pl):    Czytnik grup dyskusyjnych i klient poczty dla Emacsa/XEmacsa
7 Name:           emacsen-gnus-pkg
8 Version:        5.10.6
9 Release:        1
10 License:        GPL
11 Group:          Applications/Networking
12 Source0:        http://www.gnus.org/dist/%{_the_name}-%{version}.tar.gz
13 # Source0-md5:  8b510e5d2530f92af371eb64f828b257
14 Patch0:         %{name}-destdir.patch
15 URL:            http://www.gnus.org/
16
17 Conflicts:      xemacs-gnus-pkg
18 Requires:       gnus-elisp-code = %{version}-%{release}
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %if %{with pdf_doc}
23 BuildRequires:  texinfo-texi2dvi
24 BuildRequires:  tetex-latex
25 BuildRequires:  tetex-makeindex
26 BuildRequires:  tetex-dvips
27 BuildRequires:  tetex-format-pdftex
28 %endif
29
30 %if %{with emacs}
31 BuildRequires:  emacs
32 %endif
33
34 %if %{with xemacs}
35 BuildRequires:  xemacs
36 BuildRequires:  xemacs-mail-lib-pkg
37 BuildRequires:  xemacs-eterm-pkg
38 BuildRequires:  xemacs-sh-script-pkg
39 BuildRequires:  xemacs-os-utils-pkg
40 BuildRequires:  xemacs-dired-pkg
41 BuildRequires:  xemacs-mh-e-pkg
42 BuildRequires:  xemacs-mailcrypt-pkg
43 BuildRequires:  xemacs-fsf-compat-pkg
44 BuildRequires:  xemacs-texinfo-pkg
45 %endif
46
47 %description
48 You can read news (and mail) from within GNU Emacs or XEmacs by using
49 Gnus. The news can be gotten by any nefarious means you can think of
50 -- NNTP, local spool or your mbox file.
51
52 This package contains files common to both GNU Emacs and XEmacs.
53
54 %description -l pl
55 Dziêki pakietowi Gnus mo¿esz czytaæ newsy i pocztê z u¿yciem
56 GNU Emacsa lub XEmacsa.  Gnus mo¿e pobieraæ listy z najró¿niejszych
57 ¼róde³, w tym z serwera NNTP, lokalnego spoola jak i plików mbox.
58
59 Ten pakiet zawiera pliki Gnusa wspólne dla GNU Emacsa i XEmacsa.
60
61 %define version_of() %{expand:%%(rpm -q %1 --queryformat '%%%%{version}-%%%%{release}')}
62
63 %if %{with emacs}
64 %package emacs
65 Summary:        Gnus elisp files for GNU Emacs
66 Summary(pl):    Kod elisp Gnusa dla GNU Emacsa
67 Group:          Applications/Networking
68 Provides:       gnus-elisp-code = %{version}-%{release}
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       emacs = %{version_of emacs}
71
72 %description emacs
73 This package contains compiled elisp files needed to run Gnus on GNU Emacs
74
75 %description emacs -l pl
76 Pakiet zawiera skompilowane pliki elisp z kodem Gnusa dla GNU Emacsa.
77
78 %package emacs-el
79 Summary:        Gnus elisp source files for GNU Emacs
80 Summary(pl):    Kod ¼ród³owy elisp Gnusa dla GNU Emacsa
81 Group:          Applications/Networking
82 Requires:       %{name}-emacs = %{version}-%{release}
83
84 %description emacs-el
85 This package contains source elisp files needed to run Gnus on GNU Emacs
86
87 %description emacs-el -l pl
88 Pakiet zawiera ¼ród³owe pliki elisp z kodem Gnusa dla GNU Emacsa.
89 %endif
90
91
92 %if %{with xemacs}
93 %package xemacs
94 Summary:        Gnus elisp files for XEmacs
95 Summary(pl):    Kod elisp Gnusa dla XEmacsa
96 Group:          Applications/Networking
97 Provides:       gnus-elisp-code = %{version}-%{release}
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       xemacs = %{version_of xemacs}
100 Requires:       xemacs-mail-lib-pkg
101 Requires:       xemacs-eterm-pkg
102 Requires:       xemacs-sh-script-pkg
103 Requires:       xemacs-os-utils-pkg
104 Requires:       xemacs-dired-pkg
105 Requires:       xemacs-mh-e-pkg
106 Requires:       xemacs-mailcrypt-pkg
107 Requires:       xemacs-fsf-compat-pkg
108
109 %description xemacs
110 This package contains compiled elisp files needed to run Gnus on XEmacs
111
112 %description xemacs -l pl
113 Pakiet zawiera skompilowane pliki elisp z kodem Gnusa dla XEmacsa.
114
115 %package xemacs-el
116 Summary:        Gnus elisp source files for XEmacs
117 Summary(pl):    Kod ¼ród³owy elisp Gnusa dla XEmacsa
118 Group:          Applications/Networking
119 Requires:       %{name}-xemacs = %{version}-%{release}
120
121 %description xemacs-el
122 This package contains source elisp files needed to run Gnus on XEmacs
123
124 %description xemacs-el -l pl
125 Pakiet zawiera pliki ¼ród³owe elisp z kodem Gnusa dla XEmacsa.
126 %endif
127
128
129 %if %{with pdf_doc}
130 %package pdf-doc
131 Summary:        PDF documentation for Gnus
132 Summary(pl):    Dokumentacja Gnusa w formacie PDF
133 Group:          Documentation
134
135 %description pdf-doc
136 Documentation for Gnus in PDF format
137
138 %description pdf-doc -l pl
139 Dokumentacja Gnusa w formacie PDF
140 %endif
141
142
143 %prep
144 %setup -q -n %{_the_name}-%{version}
145 %patch0 -p1
146
147
148 %build
149 mkdir DUMMY
150
151 %if %{with xemacs}
152
153 %configure \
154     --with-xemacs \
155     --with-lispdir=%{_datadir}/xemacs-packages/lisp/%{_the_name} \
156     --with-etcdir=%{_datadir}/%{_the_name}
157 %{__make}
158
159 %if %{without emacs} && %{with pdf_doc}
160 %{__make} -C texi pdf
161 %endif
162
163 %{__make} DESTDIR=`pwd`/DUMMY install
164 %{__make} distclean
165
166 %endif
167
168 %if %{with emacs}
169
170 %configure \
171     --with-emacs \
172     --with-lispdir=%{_emacs_lispdir}/%{_the_name} \
173     --with-etcdir=%{_datadir}/%{_the_name}
174 %{__make}
175
176 %if %{with pdf_doc}
177 %{__make} -C texi pdf
178 %endif
179
180 %{__make} DESTDIR=`pwd`/DUMMY install
181
182 %endif
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186 cp -R ./DUMMY $RPM_BUILD_ROOT
187 install -d $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/etc
188 ln -s ../../gnus $RPM_BUILD_ROOT%{_datadir}/xemacs-packages/etc/
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %files
194 %defattr(644,root,root,755)
195 %doc ChangeLog GNUS-NEWS README todo contrib/
196 %{_datadir}/%{_the_name}
197 %{_infodir}/*
198
199 %if %{with emacs}
200 %files emacs
201 %defattr(644,root,root,755)
202 %dir %{_emacs_lispdir}/%{_the_name}
203 %{_emacs_lispdir}/%{_the_name}/*.elc
204
205 %files emacs-el
206 %defattr(644,root,root,755)
207 %{_emacs_lispdir}/%{_the_name}/*.el
208 %endif
209
210 %if %{with xemacs}
211 %files xemacs
212 %defattr(644,root,root,755)
213 %dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
214 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
215 %{_datadir}/xemacs-packages/etc/%{_the_name}
216
217 %files xemacs-el
218 %defattr(644,root,root,755)
219 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
220 %endif
221
222 %if %{with pdf_doc}
223 %files pdf-doc
224 %defattr(644,root,root,755)
225 %doc texi/*.pdf
226 %endif
This page took 0.081136 seconds and 3 git commands to generate.