]> git.pld-linux.org Git - packages/emacsen-ecb-pkg.git/blob - emacsen-ecb-pkg.spec
- use standard requires_eq macro, cleanups
[packages/emacsen-ecb-pkg.git] / emacsen-ecb-pkg.spec
1 # TODO
2 # - build for xemacs
3 #
4 # Conditional build:
5 %bcond_with     xemacs  # Build without XEmacs support
6 %bcond_without  emacs   # Build without GNU Emacs support
7 #
8 %define         _the_name ecb
9 Summary:        Emacs Code Browser IDE
10 Summary(pl.UTF-8):      Środowisko programistyczne dla Emacsa
11 Name:           emacsen-%{_the_name}-pkg
12 Version:        2.26
13 Release:        0.1
14 License:        GPL
15 Group:          Applications/Editors/Emacs
16 Source0:        http://dl.sourceforge.net/ecb/%{_the_name}-%{version}.tar.gz
17 # Source0-md5:  89bea4c856b96a943e83f14ef650e753
18 URL:            http://ecb.sourceforge.net/
19 BuildRequires:  emacsen-cedet-pkg
20 %if %{with emacs}
21 BuildRequires:  emacs
22 %endif
23 %if %{with xemacs}
24 BuildRequires:  xemacs
25 %endif
26 Requires:       cedet-elisp-code = %{version}-%{release}
27 Conflicts:      xemacs-cedet-pkg
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 ECB is a global minor-mode which offers a couple of ECB-windows for
33 browsing your sources comfortable with the mouse and the keyboard.
34
35 This package contains files common to both GNU Emacs and XEmacs.
36
37 %description -l pl.UTF-8
38 ECB jest globalnym minor mode wyświetlającym kilka własnych okienek
39 ułatwiających przeglądanie kodu myszą i klawiaturą.
40
41 Ten pakiet zawiera pliki wspólne dla GNU Emacsa i XEmacsa.
42
43 %package emacs
44 Summary:        ECB compiled elisp files for GNU Emacs
45 Summary(pl.UTF-8):      Skompilowany kod elisp ECB dla GNU Emacsa
46 Group:          Applications/Editors/Emacs
47 Requires:       %{name} = %{version}-%{release}
48 Provides:       cedet-elisp-code = %{version}-%{release}
49 %requires_eq emacs
50
51 %description emacs
52 This package contains compiled elisp files needed to run ECB on GNU Emacs
53
54 %description emacs -l pl.UTF-8
55 Pakiet zawiera skompilowane pliki elisp z kodem ECB dla GNU Emacsa.
56
57 %package emacs-el
58 Summary:        ECB elisp files for GNU Emacs
59 Summary(pl.UTF-8):      Kod elisp ECB dla GNU Emacsa
60 Group:          Applications/Editors/Emacs
61 Requires:       %{name}-emacs = %{version}-%{release}
62
63 %description emacs-el
64 This package contains ECB source elisp files for GNU Emacs
65
66 %description emacs-el -l pl.UTF-8
67 Pakiet zawiera źródłowe pliki elisp z kodem ECB dla GNU Emacsa.
68
69 %package xemacs
70 Summary:        ECB elisp files for XEmacs
71 Summary(pl.UTF-8):      Kod elisp ECB dla XEmacsa
72 Group:          Applications/Editors/Emacs
73 Requires:       %{name} = %{version}-%{release}
74 Provides:       cedet-elisp-code = %{version}-%{release}
75 %requires_eq xemacs
76
77 %description xemacs
78 This package contains compiled elisp files needed to run ECB on XEmacs
79
80 %description xemacs -l pl.UTF-8
81 Pakiet zawiera skompilowane pliki elisp z kodem ECB dla XEmacsa.
82
83 %package xemacs-el
84 Summary:        ECB elisp source files for XEmacs
85 Summary(pl.UTF-8):      Kod źródłowy elisp ECB dla XEmacsa
86 Group:          Applications/Editors/Emacs
87 Requires:       %{name}-xemacs = %{version}-%{release}
88
89 %description xemacs-el
90 This package contains source ECB elisp files for XEmacs
91
92 %description xemacs-el -l pl.UTF-8
93 Pakiet zawiera pliki źródłowe elisp z kodem ECB dla XEmacsa.
94
95 %prep
96 %setup -q -n %{_the_name}-%{version}
97
98 %build
99 %if %{with xemacs}
100 mkdir _xemacs
101 %endif
102
103 %if %{with emacs}
104 mkdir _emacs
105 cp -a [!_]* _emacs
106 %{__make} -C _emacs \
107         EMACS=emacs \
108         CEDET=%{_datadir}/emacs/cedet
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT%{_infodir}
114
115 %if %{with xemacs}
116 %endif
117
118 %if %{with emacs}
119 install -d $RPM_BUILD_ROOT%{_emacs_lispdir}
120 install _emacs/*.{el,elc} $RPM_BUILD_ROOT%{_emacs_lispdir}
121 rm _emacs/ecb-images/klaus.sh
122 cp -a _emacs/ecb-images $RPM_BUILD_ROOT%{_emacs_lispdir}
123 %endif
124
125 install info-help/* $RPM_BUILD_ROOT%{_infodir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc NEWS README RELEASE_NOTES html-help
133 %{_infodir}/*.info*
134
135 %if %{with emacs}
136 %files emacs
137 %defattr(644,root,root,755)
138 %{_emacs_lispdir}/*.elc
139 %{_emacs_lispdir}/ecb-images
140 %{_emacs_lispdir}/ecb-autoloads.el
141
142 %files emacs-el
143 %defattr(644,root,root,755)
144 # All except ecb-autoloads.el
145 %{_emacs_lispdir}/[!e]*.el
146 %{_emacs_lispdir}/ecb-[!a]*.el
147 %{_emacs_lispdir}/ecb-autogen.el
148 %endif
149
150 %if %{with xemacs}
151 %files xemacs
152 %defattr(644,root,root,755)
153 %dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
154 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
155 %{_datadir}/xemacs-packages/etc/%{_the_name}
156
157 %files xemacs-el
158 %defattr(644,root,root,755)
159 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
160 %endif
This page took 1.471692 seconds and 3 git commands to generate.