]> git.pld-linux.org Git - packages/emacsen-ecb-pkg.git/blob - emacsen-ecb-pkg.spec
cb1099c8679ee21cf4ddb4caff8b94f1ae660f1e
[packages/emacsen-ecb-pkg.git] / emacsen-ecb-pkg.spec
1 # TODO: build for xemacs
2 #
3 # Conditional build:
4 %bcond_with     xemacs  # Build without XEmacs support
5 %bcond_without  emacs   # Build without GNU Emacs support
6 #
7 %define         _the_name ecb
8 Summary:        Emacs Code Browser IDE
9 Summary(pl):    ¦rodowisko programistyczne dla Emacsa
10 Name:           emacsen-%{_the_name}-pkg
11 Version:        2.26
12 Release:        0.1
13 License:        GPL
14 Group:          Applications/Editors/Emacs
15 Source0:        http://dl.sourceforge.net/ecb/%{_the_name}-%{version}.tar.gz
16 # Source0-md5:  89bea4c856b96a943e83f14ef650e753
17 URL:            http://ecb.sf.net/
18 BuildRequires:  emacsen-cedet-pkg
19 %if %{with emacs}
20 BuildRequires:  emacs
21 %endif
22 %if %{with xemacs}
23 BuildRequires:  xemacs
24 %endif
25 Requires:       cedet-elisp-code = %{version}-%{release}
26 Conflicts:      xemacs-cedet-pkg
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ECB is a global minor-mode which offers a couple of ECB-windows for
32 browsing your sources comfortable with the mouse and the keyboard.
33
34 This package contains files common to both GNU Emacs and XEmacs.
35
36 %description -l pl
37 ECB jest globalnym minor mode wy¶wietlaj±cym kilka w³asnych okienek
38 u³atwiaj±cych przegl±danie kodu mysz± i klawiatur±.
39
40 Ten pakiet zawiera pliki wspólne dla GNU Emacsa i XEmacsa.
41
42 %define version_of() %{expand:%%(rpm -q %1 --queryformat '%%%%{version}-%%%%{release}')}
43
44 %package emacs
45 Summary:        ECB compiled elisp files for GNU Emacs
46 Summary(pl):    Skompilowany kod elisp ECB dla GNU Emacsa
47 Group:          Applications/Editors/Emacs
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       emacs = %{version_of emacs}
50 Provides:       cedet-elisp-code = %{version}-%{release}
51
52 %description emacs
53 This package contains compiled elisp files needed to run ECB on GNU Emacs
54
55 %description emacs -l pl
56 Pakiet zawiera skompilowane pliki elisp z kodem ECB dla GNU Emacsa.
57
58 %package emacs-el
59 Summary:        ECB elisp files for GNU Emacs
60 Summary(pl):    Kod elisp ECB dla GNU Emacsa
61 Group:          Applications/Editors/Emacs
62 Requires:       %{name}-emacs = %{version}-%{release}
63
64 %description emacs-el
65 This package contains ECB source elisp files for GNU Emacs
66
67 %description emacs-el -l pl
68 Pakiet zawiera ¼ród³owe pliki elisp z kodem ECB dla GNU Emacsa.
69
70 %package xemacs
71 Summary:        ECB elisp files for XEmacs
72 Summary(pl):    Kod elisp ECB dla XEmacsa
73 Group:          Applications/Editors/Emacs
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       xemacs = %{version_of xemacs}
76 Provides:       cedet-elisp-code = %{version}-%{release}
77
78 %description xemacs
79 This package contains compiled elisp files needed to run ECB on XEmacs
80
81 %description xemacs -l pl
82 Pakiet zawiera skompilowane pliki elisp z kodem ECB dla XEmacsa.
83
84 %package xemacs-el
85 Summary:        ECB elisp source files for XEmacs
86 Summary(pl):    Kod ¼ród³owy elisp ECB dla XEmacsa
87 Group:          Applications/Editors/Emacs
88 Requires:       %{name}-xemacs = %{version}-%{release}
89
90 %description xemacs-el
91 This package contains source ECB elisp files for  XEmacs
92
93 %description xemacs-el -l pl
94 Pakiet zawiera pliki ¼ród³owe elisp z kodem ECB dla XEmacsa.
95
96 %prep
97 %setup -q -n %{_the_name}-%{version}
98
99 %build
100 %if %{with xemacs}
101 mkdir _xemacs
102 %endif
103
104 %if %{with emacs}
105 mkdir _emacs
106 cp -a [!_]* _emacs
107 %{__make} -C _emacs \
108         EMACS=emacs \
109         CEDET=%{_datadir}/emacs/cedet
110 %endif
111
112 %install
113 install -d $RPM_BUILD_ROOT%{_infodir}
114
115 %if %{with xemacs}
116 %endif
117
118 %if %{with emacs}
119 install -d $RPM_BUILD_ROOT%{_emacs_lispdir}
120 install _emacs/*.{el,elc} $RPM_BUILD_ROOT%{_emacs_lispdir}
121 rm _emacs/ecb-images/klaus.sh
122 cp -a _emacs/ecb-images $RPM_BUILD_ROOT%{_emacs_lispdir}
123 %endif
124
125 install info-help/* $RPM_BUILD_ROOT%{_infodir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc NEWS README RELEASE_NOTES html-help
133 %{_infodir}/*.info*
134
135 %if %{with emacs}
136 %files emacs
137 %defattr(644,root,root,755)
138 %{_emacs_lispdir}/*.elc
139 %{_emacs_lispdir}/ecb-images
140 %{_emacs_lispdir}/ecb-autoloads.el
141
142 %files emacs-el
143 %defattr(644,root,root,755)
144 # All except ecb-autoloads.el
145 %{_emacs_lispdir}/[!e]*.el
146 %{_emacs_lispdir}/ecb-[!a]*.el
147 %{_emacs_lispdir}/ecb-autogen.el
148 %endif
149
150 %if %{with xemacs}
151 %files xemacs
152 %defattr(644,root,root,755)
153 %dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
154 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
155 %{_datadir}/xemacs-packages/etc/%{_the_name}
156
157 %files xemacs-el
158 %defattr(644,root,root,755)
159 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
160 %endif
This page took 0.153427 seconds and 3 git commands to generate.