]> git.pld-linux.org Git - packages/em8300.git/blob - em8300.spec
- added depmod options so modules can be installed for kernel other than running
[packages/em8300.git] / em8300.spec
1 # TODO: separate modules to subpackages, standardize them
2 Summary:        dxr3 and h+ driver
3 Summary(pl):    sterowniki dla dxr3 i h+
4 Name:           em8300
5 Version:        0.12.0
6 Release:        1
7 License:        GPL
8 Group:          Libraries
9 Source0:        http://dxr3.sourceforge.net/download/%{name}-%{version}.tar.gz
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconf
12 URL:            http://dxr3.sourceforge.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  gtk+-devel >= 1.2.0
17 Requires(post,postun):  /sbin/ldconfig
18 Requires(post,postun):  /sbin/depmod
19 Requires(post,preun):   /sbin/chkconfig
20 Provides:       dxr3
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _xbindir                %{_prefix}/X11R6/bin
24
25 %description
26 em8300 is a Linux driver for Creative DXR3 and Sigma Designs
27 Hollywood+ cards. Both cards are hardware MPEG1, MPEG2, AC3 decoders.
28 Additionaly Xine and MPlayer with help of this driver allow you to
29 play all the video formats that they recognise through the tv-out of
30 these cards.
31
32 %description -l pl
33 em8300 pozwala na uruchomienie pod Linuksem kart Creative DXR3 i Sigma
34 Designs Hollywood+. Obie karty, o prawie identycznej konstrukcji s±
35 sprzêtowymi dekoderami MPEG1, MPEG2 i AC3. Programy Xine i MPlayer
36 pozwalaj± przy u¿yciu tego sterownika na odtwarzanie przez wyj¶cie
37 telewizyjne tych kart nie tylko w/w formatów, ale tak¿e wszystkich
38 formatów video, które te programy rozpoznaj±.
39
40 %package devel
41 Summary:        Files required to develop programs using em8300
42 Summary(pl):    Pliki potrzebne do tworzenia programów korzystaj±cych z em8300
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}
45
46 %description devel
47 Header files and additional scripts useful for developers of em8300
48 apps.
49
50 %description devel -l pl
51 Pliki nag³ówkowe i skrypty przydatne dla autorów aplikacji
52 korzystaj±cych z em8300.
53
54 %package static
55 Summary:        Static libraries for em8300
56 Summary(pl):    Statyczne biblioteki dla em8300
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}
59
60 %description static
61 Static libraries for em8300.
62
63 %description static -l pl
64 Statyczne biblioteki dla em8300.
65
66 %package gtk
67 Summary:        Utility programs for em8300 using gtk+
68 Summary(pl):    Programy u¿ytkowe em8300 u¿ywaj±ce bibliteki gtk+
69 Group:          X11/Applications
70 Requires:       %{name} = %{version}
71
72 %description gtk
73 Utility programs for em8300 using gtk+ toolkit.
74
75 %description gtk -l pl
76 Programy u¿ytkowe em8300 u¿ywaj±ce biblioteki gtk+.
77
78 %prep
79 %setup -q
80
81 %build
82 rm -f missing
83 sh bootstrap
84 %{__automake}
85 %configure
86 %{__make}
87 cd modules
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT
93
94 %{__make} install DESTDIR=$RPM_BUILD_ROOT
95 cd modules
96 %{__make} install-newkern prefix=$RPM_BUILD_ROOT
97 find $RPM_BUILD_ROOT/lib/modules -name "*.o" -print | sed s,$RPM_BUILD_ROOT,, >../mods.lst
98 mv INSTALL INSTALL.modules
99
100 install -D em8300.uc $RPM_BUILD_ROOT/%{_datadir}/misc/em8300.uc
101
102 cd $RPM_BUILD_ROOT
103 install -d ./%{_xbindir}
104 mv ./%{_bindir}/* ./%{_xbindir}
105
106 cd $RPM_BUILD_ROOT%{_datadir}
107 install -m 755 em8300/microcode_upload.pl ../bin/em8300_microcode_upload
108 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
109 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT $RPM_BUILD_DIR/%{name}-%{version}
113
114 %postun
115 /sbin/ldconfig
116 /sbin/depmod -a -F /boot/System.map-%{_kernel_ver} %{_kernel_ver}
117
118 %post
119 /sbin/ldconfig
120 /sbin/depmod -a -F /boot/System.map-%{_kernel_ver} %{_kernel_ver}
121 /sbin/chkconfig --add %{name}
122 if [ -f /var/lock/subsys/%{name} ]; then
123         /etc/rc.d/init.d/%{name} restart 1>&2
124 else
125         echo "Run \"/etc/rc.d/init.d/%{name} start\" to load %{name} modules."
126 fi
127
128 %preun
129 if [ "$1" = "0" ]; then
130         if [ -f /var/lock/subsys/%{name} ]; then
131                 /etc/rc.d/init.d/%{name} stop 1>&2
132         fi
133         /sbin/chkconfig --del %{name}
134 fi
135
136 %files -f mods.lst
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog COPYING README 
139 %doc modules/{README*,INSTALL*,devices.sh,devfs_symlinks}
140 %attr(755,root,root) %{_bindir}/*
141 %attr(755,root,root) %{_datadir}/misc/*
142 %attr(755,root,root) %{_libdir}/lib*.so.*
143 %attr(755,root,root) /etc/rc.d/init.d/%{name}
144 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/%{name}
145
146 %files devel
147 %defattr(644,root,root,755)
148 %{_includedir}/libdxr3
149 %{_includedir}/linux/*
150 %attr(755,root,root) %{_libdir}/lib*.so
151 %{_libdir}/lib*.la
152 %attr(755,root,root) %dir %{_datadir}/em8300
153 %attr(755,root,root) %{_datadir}/em8300/*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/*.a
158
159 %files gtk
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_xbindir}/*
This page took 0.055828 seconds and 3 git commands to generate.