]> git.pld-linux.org Git - packages/em8300.git/blob - em8300.spec
- massive attack: adding Source-md5
[packages/em8300.git] / em8300.spec
1 # TODO: separate modules to subpackages, standardize them
2 Summary:        dxr3 and h+ driver
3 Summary(pl):    sterowniki dla dxr3 i h+
4 Name:           em8300
5 Version:        0.12.0
6 Release:        1
7 License:        GPL
8 Group:          Libraries
9 Source0:        http://dxr3.sourceforge.net/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  720a5dfba76789321ba6d7e0f8e1ecbe
11 Source1:        %{name}.init
12 Source2:        %{name}.sysconf
13 URL:            http://dxr3.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  gtk+-devel >= 1.2.0
18 Requires(post,postun):  /sbin/ldconfig
19 Requires(post,postun):  /sbin/depmod
20 Requires(post,preun):   /sbin/chkconfig
21 Provides:       dxr3
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _xbindir                %{_prefix}/X11R6/bin
25
26 %description
27 em8300 is a Linux driver for Creative DXR3 and Sigma Designs
28 Hollywood+ cards. Both cards are hardware MPEG1, MPEG2, AC3 decoders.
29 Additionaly Xine and MPlayer with help of this driver allow you to
30 play all the video formats that they recognise through the tv-out of
31 these cards.
32
33 %description -l pl
34 em8300 pozwala na uruchomienie pod Linuksem kart Creative DXR3 i Sigma
35 Designs Hollywood+. Obie karty, o prawie identycznej konstrukcji s±
36 sprzêtowymi dekoderami MPEG1, MPEG2 i AC3. Programy Xine i MPlayer
37 pozwalaj± przy u¿yciu tego sterownika na odtwarzanie przez wyj¶cie
38 telewizyjne tych kart nie tylko w/w formatów, ale tak¿e wszystkich
39 formatów video, które te programy rozpoznaj±.
40
41 %package devel
42 Summary:        Files required to develop programs using em8300
43 Summary(pl):    Pliki potrzebne do tworzenia programów korzystaj±cych z em8300
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}
46
47 %description devel
48 Header files and additional scripts useful for developers of em8300
49 apps.
50
51 %description devel -l pl
52 Pliki nag³ówkowe i skrypty przydatne dla autorów aplikacji
53 korzystaj±cych z em8300.
54
55 %package static
56 Summary:        Static libraries for em8300
57 Summary(pl):    Statyczne biblioteki dla em8300
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}
60
61 %description static
62 Static libraries for em8300.
63
64 %description static -l pl
65 Statyczne biblioteki dla em8300.
66
67 %package gtk
68 Summary:        Utility programs for em8300 using gtk+
69 Summary(pl):    Programy u¿ytkowe em8300 u¿ywaj±ce bibliteki gtk+
70 Group:          X11/Applications
71 Requires:       %{name} = %{version}
72
73 %description gtk
74 Utility programs for em8300 using gtk+ toolkit.
75
76 %description gtk -l pl
77 Programy u¿ytkowe em8300 u¿ywaj±ce biblioteki gtk+.
78
79 %prep
80 %setup -q
81
82 %build
83 rm -f missing
84 sh bootstrap
85 %{__automake}
86 %configure
87 %{__make}
88 cd modules
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT
94
95 %{__make} install DESTDIR=$RPM_BUILD_ROOT
96 cd modules
97 %{__make} install-newkern prefix=$RPM_BUILD_ROOT
98 find $RPM_BUILD_ROOT/lib/modules -name "*.o" -print | sed s,$RPM_BUILD_ROOT,, >../mods.lst
99 mv INSTALL INSTALL.modules
100
101 install -D em8300.uc $RPM_BUILD_ROOT/%{_datadir}/misc/em8300.uc
102
103 cd $RPM_BUILD_ROOT
104 install -d ./%{_xbindir}
105 mv ./%{_bindir}/* ./%{_xbindir}
106
107 cd $RPM_BUILD_ROOT%{_datadir}
108 install -m 755 em8300/microcode_upload.pl ../bin/em8300_microcode_upload
109 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
110 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT $RPM_BUILD_DIR/%{name}-%{version}
114
115 %postun
116 /sbin/ldconfig
117 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
118
119 %post
120 /sbin/ldconfig
121 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
122 /sbin/chkconfig --add %{name}
123 if [ -f /var/lock/subsys/%{name} ]; then
124         /etc/rc.d/init.d/%{name} restart 1>&2
125 else
126         echo "Run \"/etc/rc.d/init.d/%{name} start\" to load %{name} modules."
127 fi
128
129 %preun
130 if [ "$1" = "0" ]; then
131         if [ -f /var/lock/subsys/%{name} ]; then
132                 /etc/rc.d/init.d/%{name} stop 1>&2
133         fi
134         /sbin/chkconfig --del %{name}
135 fi
136
137 %files -f mods.lst
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog COPYING README 
140 %doc modules/{README*,INSTALL*,devices.sh,devfs_symlinks}
141 %attr(755,root,root) %{_bindir}/*
142 %attr(755,root,root) %{_datadir}/misc/*
143 %attr(755,root,root) %{_libdir}/lib*.so.*
144 %attr(755,root,root) /etc/rc.d/init.d/%{name}
145 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/%{name}
146
147 %files devel
148 %defattr(644,root,root,755)
149 %{_includedir}/libdxr3
150 %{_includedir}/linux/*
151 %attr(755,root,root) %{_libdir}/lib*.so
152 %{_libdir}/lib*.la
153 %attr(755,root,root) %dir %{_datadir}/em8300
154 %attr(755,root,root) %{_datadir}/em8300/*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/*.a
159
160 %files gtk
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_xbindir}/*
This page took 0.077406 seconds and 3 git commands to generate.