]> git.pld-linux.org Git - packages/em8300.git/blob - em8300.spec
- fix improper usage of %%{_sysconfdir}
[packages/em8300.git] / em8300.spec
1 Summary:        dxr3 and h+ driver
2 Summary(pl):    sterowniki dla dxr3 i h+
3 Name:           em8300
4 Version:        0.12.0
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://dxr3.sourceforge.net/download/%{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconf
11 URL:            http://dxr3.sourceforge.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  gtk+-devel >= 1.2.0
16 Requires(post,postun):  /sbin/ldconfig
17 Requires(post,postun):  /sbin/depmod
18 Requires(post,preun):   /sbin/chkconfig
19 Provides:       dxr3
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _xbindir                %{_prefix}/X11R6/bin
23
24 %description
25 em8300 is a Linux driver for Creative DXR3 and Sigma Designs
26 Hollywood+ cards. Both cards are hardware MPEG1, MPEG2, AC3 decoders.
27 Additionaly Xine and MPlayer with help of this driver allow you to
28 play all the video formats that they recognise through the tv-out of
29 these cards.
30
31 %description -l pl
32 em8300 pozwala na uruchomienie pod Linuksem kart Creative DXR3 i Sigma
33 Designs Hollywood+. Obie karty, o prawie identycznej konstrukcji s±
34 sprzêtowymi dekoderami MPEG1, MPEG2 i AC3. Programy Xine i MPlayer
35 pozwalaj± przy u¿yciu tego sterownika na odtwarzanie przez wyj¶cie
36 telewizyjne tych kart nie tylko w/w formatów, ale tak¿e wszystkich
37 formatów video, które te programy rozpoznaj±.
38
39 %package devel
40 Summary:        Files required to develop programs using em8300
41 Summary(pl):    Pliki potrzebne do tworzenia programów korzystaj±cych z em8300
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}
44
45 %description devel
46 Header files and additional scripts useful for developers of em8300
47 apps.
48
49 %description devel -l pl
50 Pliki nag³ówkowe i skrypty przydatne dla autorów aplikacji
51 korzystaj±cych z em8300.
52
53 %package static
54 Summary:        Static libraries for em8300
55 Summary(pl):    Statyczne biblioteki dla em8300
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}
58
59 %description static
60 Static libraries for em8300.
61
62 %description static -l pl
63 Statyczne biblioteki dla em8300.
64
65 %package gtk
66 Summary:        Utility programs for em8300 using gtk+
67 Summary(pl):    Programy u¿ytkowe em8300 u¿ywaj±ce bibliteki gtk+
68 Group:          X11/Applications
69 Requires:       %{name} = %{version}
70
71 %description gtk
72 Utility programs for em8300 using gtk+ toolkit.
73
74 %description gtk -l pl
75 Programy u¿ytkowe em8300 u¿ywaj±ce biblioteki gtk+.
76
77 %prep
78 %setup -q
79
80 %build
81 rm -f missing
82 sh bootstrap
83 %{__automake}
84 %configure
85 %{__make}
86 cd modules
87 make
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT
92
93 %{__make} install DESTDIR=$RPM_BUILD_ROOT
94 cd modules
95 %{__make} install-newkern prefix=$RPM_BUILD_ROOT
96 find $RPM_BUILD_ROOT/lib/modules -name "*.o" -print | sed s,$RPM_BUILD_ROOT,, >../mods.lst
97 mv INSTALL INSTALL.modules
98
99 install -D em8300.uc $RPM_BUILD_ROOT/%{_datadir}/misc/em8300.uc
100
101 cd $RPM_BUILD_ROOT
102 install -d ./%{_xbindir}
103 mv ./%{_bindir}/* ./%{_xbindir}
104
105 cd $RPM_BUILD_ROOT%{_datadir}
106 install -m 755 em8300/microcode_upload.pl ../bin/em8300_microcode_upload
107 install -D %{SOURCE1} $RPM_BUILD_ROOT//etc/rc.d/init.d/%{name}
108 install -D %{SOURCE2} $RPM_BUILD_ROOT//etc/sysconfig/%{name}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT $RPM_BUILD_DIR/%{name}-%{version}
112
113 %postun
114 /sbin/ldconfig
115 /sbin/depmod -a
116
117 %post
118 /sbin/ldconfig
119 /sbin/depmod -a
120 /sbin/chkconfig --add %{name}
121 if [ -f /var/lock/subsys/%{name} ]; then
122         /etc/rc.d/init.d/%{name} restart 1>&2
123 else
124         echo "Run \"/etc/rc.d/init.d/%{name} start\" to load %{name} modules."
125 fi
126
127 %preun
128 if [ "$1" = "0" ]; then
129         if [ -f /var/lock/subsys/%{name} ]; then
130                 /etc/rc.d/init.d/%{name} stop 1>&2
131         fi
132         /sbin/chkconfig --del %{name}
133 fi
134
135 %files -f mods.lst
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog COPYING README 
138 %doc modules/{README*,INSTALL*,devices.sh,devfs_symlinks}
139 %attr(755,root,root) %{_bindir}/*
140 %attr(755,root,root) %{_datadir}/misc/*
141 %attr(755,root,root) %{_libdir}/lib*.so.*
142 %attr(755,root,root) /etc/rc.d/init.d/%{name}
143 %attr(755,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/%{name}
144
145 %files devel
146 %defattr(644,root,root,755)
147 %{_includedir}/libdxr3
148 %{_includedir}/linux/*
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %{_libdir}/lib*.la
151 %attr(755,root,root) %dir %{_datadir}/em8300
152 %attr(755,root,root) %{_datadir}/em8300/*
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/*.a
157
158 %files gtk
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_xbindir}/*
This page took 0.48939 seconds and 3 git commands to generate.