]> git.pld-linux.org Git - packages/elinks.git/commitdiff
- merged options cleanup from elinks-0.12 branch auto/th/elinks-0.13-4.20120604.1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 21 Jun 2013 16:47:15 +0000 (18:47 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 21 Jun 2013 16:47:15 +0000 (18:47 +0200)
elinks.spec

index 14ed232f609358b4ee9277d6f31b698873f67f58..e5a0f5c7ae9495e0b8dc49a4fcd56683c2787bd7 100644 (file)
@@ -1,28 +1,32 @@
 # TODO: consider lua51
 
 # Conditional build:
-%bcond_with    gnutls          # Enable GNUTLS SSL support (disables openssl)
-%bcond_with    lzma            # Enable lzma support
-%bcond_with    python          # Enable Python scripting support
-%bcond_with    ruby            # Enable (experimental) Ruby scripting support
-%bcond_with    smb             # Enable smb protocol support (smb requires libsmbclient)
-#The latest libsmbclient is GPLv3, while ELinks is GPL v2 only.
-%bcond_with    verbose         # verbose build (V=1)
-%bcond_with    x               # Use the X Window System
-%bcond_without 256             # Disable 256 colors support
-%bcond_without bittorrent      # Disable BitTorrent support
-%bcond_without cgi             # Disable Local CGI support
-%bcond_without fsp             # Disable FSP support
-%bcond_without guile           # Disable Guile scripting
-%bcond_without idn             # Disable Internation Domain Names support
-%bcond_without ipv6            # Disable IPv6 support
-%bcond_without js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
-%bcond_without led             # Disable LEDs
-%bcond_without lua             # Disable Lua scripting
-%bcond_without openssl         # Disable OpenSSL support
-%bcond_without perl            # Disable Perl scripting
-%bcond_without truecolor       # Disable true color
+# - protocols
+%bcond_without bittorrent      # BitTorrent protocol support
+%bcond_without fsp             # FSP support
+%bcond_without idn             # Internation Domain Names support
+%bcond_without ipv6            # IPv6 support
+%bcond_with    smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
+%bcond_with    gnutls          # GNUTLS-based SSL support (instead of openssl)
+%bcond_without openssl         # OpenSSL-based SSL support
+# - content
+%bcond_without cgi             # Local CGI support
+%bcond_without js              # experimental (yet quite usable) JavaScript support (using SpiderMonkey)
+%bcond_with    lzma            # LZMA support (old API, incompatible with xz-libs)
+# - scripting
+%bcond_with    guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
+%bcond_without lua             # Lua scripting
+%bcond_without perl            # Perl scripting
+%bcond_with    python          # Python scripting support
+%bcond_with    ruby            # (experimental) Ruby scripting support
+# - display and UI
+%bcond_without 256             # 256 colors support
+%bcond_without led             # LEDs
+%bcond_without truecolor       # true color
 %bcond_with    olderisbetter   # variuos pre-0.10.0 behaviour rules (typeahead and esc-esc)
+%bcond_with    x               # Use the X Window System
+# - misc
+%bcond_without verbose         # verbose build (V=1)
 
 %if %{with gnutls}
 %undefine      with_openssl
@@ -57,7 +61,6 @@ BuildRequires:        automake
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
 %{?with_fsp:BuildRequires:     fsplib-devel}
-#BuildRequires:        gc-devel
 BuildRequires: gettext-devel
 %{?with_gnutls:BuildRequires:  gnutls-devel >= 1.2.5}
 BuildRequires: gpm-devel
@@ -106,7 +109,7 @@ tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
 keepalive.
 
 %prep
-%setup -q -n %{name}-%{version}-20120604
+%setup -q -n %{name}-%{version}-%{snap}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -121,38 +124,37 @@ keepalive.
 %{__autoconf}
 %{__autoheader}
 %configure \
-       --with-gc=no \
-       %{?with_smb:--enable-smb} \
-       --disable-no-root \
-       %{!?debug:--enable-fastmem} \
-       %{?debug:--enable-debug} \
-       %{!?with_ipv6:--disable-ipv6} \
        %{?with_bittorrent:--enable-bittorrent} \
        %{?with_cgi:--enable-cgi} \
-       --enable-finger \
-       --enable-gopher \
-       --enable-nntp \
        --enable-88-colors \
        %{?with_256:--enable-256-colors} \
        %{?with_truecolor:--enable-true-color} \
        --enable-exmode \
+       %{?debug:--enable-debug} \
+       %{!?debug:--enable-fastmem} \
+       --enable-finger \
        %{?with_fsp:--enable-fsp} \
+       --enable-gopher \
+       --enable-html-highlight \
+       %{!?with_ipv6:--disable-ipv6} \
        %{?with_leds:--enable-leds} \
        --enable-marks \
-       --enable-html-highlight \
-       %{!?with_idn:--without-idn} \
+       --enable-nntp \
+       --disable-no-root \
+       %{?with_smb:--enable-smb} \
+       --without-gc \
+       %{?with_gnutls:--with-gnutls} \
        %{?with_guile:--with-guile} \
-       %{?with_perl:--with-perl} \
+       %{!?with_idn:--without-idn} \
        %{!?with_lua:--without-lua} \
+       %{?with_lzma:--with-lzma} \
+       %{!?with_openssl:--without-openssl} \
+       %{?with_perl:--with-perl} \
        %{?with_python:--with-python} \
        %{?with_ruby:--with-ruby} \
        %{!?with_js:--without-spidermonkey} \
-       %{?with_gnutls:--with-gnutls} \
-       %{!?with_openssl:--without-openssl} \
-       --with%{!?with_x:out}-x \
-       %{!?with_lzma:--without-lzma}
-# xterm -e is default, one might want to change it to
-# something else
+       --with-x%{!?with_x:=no}
+# xterm -e is default, one might want to change it to something else:
 #      --with-xterm="xterm -e"
 
 %{__make} %{?with_verbose:V=1}
@@ -166,7 +168,7 @@ install -d $RPM_BUILD_ROOT%{_desktopdir} \
 %{__make} install %{?with_verbose:V=1} \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
 
 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
This page took 0.26207 seconds and 4 git commands to generate.