]> git.pld-linux.org Git - packages/elinks.git/blobdiff - elinks.spec
- up to 0.11.4rc1 (this is marked as the latest stable
[packages/elinks.git] / elinks.spec
index 8b421ddfce30f9701e10dbd12d1ed559bfef7aa4..be68fa556d8f08409a9be4ef9951ad9bdcd2910d 100644 (file)
@@ -1,48 +1,53 @@
+# TODO: consider lua51
 #
 # Conditional build:
-%bcond_with    x       # Use the X Windows System
-%bcond_with    gnutls  # Enable GNUTLS SSL support (disables openssl)
-%bcond_with    ruby    # Enable (experimental) Ruby scripting support
-%bcond_without 256     # Disable 256 colors support
-%bcond_without bittorent # Disable BitTorrent support
-%bcond_without cgi     # Disable Local CGI support
-%bcond_without guile   # Disable Guile scripting
-%bcond_without idn     # Disable Internation Domain Names support
-%bcond_without ipv6    # Disable IPv6 support
-%bcond_without js      # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
-%bcond_without led     # Disable LEDs
-%bcond_without lua     # Disable Lua scripting
-%bcond_without openssl # Disable OpenSSL support
-%bcond_without perl    # Disable Perl scripting
+%bcond_with    x               # Use the X Windows System
+%bcond_with    gnutls          # Enable GNUTLS SSL support (disables openssl)
+%bcond_with    ruby            # Enable (experimental) Ruby scripting support
+%bcond_without 256             # Disable 256 colors support
+%bcond_without bittorrent      # Disable BitTorrent support
+%bcond_without cgi             # Disable Local CGI support
+%bcond_without fsp             # Disable FSP support
+%bcond_without guile           # Disable Guile scripting
+%bcond_without idn             # Disable Internation Domain Names support
+%bcond_without ipv6            # Disable IPv6 support
+%bcond_without js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
+%bcond_without led             # Disable LEDs
+%bcond_without lua             # Disable Lua scripting
+%bcond_without openssl         # Disable OpenSSL support
+%bcond_without perl            # Disable Perl scripting
 # 
 %if %{with gnutls}
 %undefine      with_openssl
 %endif
 #
+%define                pre     rc1
 Summary:       Experimantal Links (text WWW browser)
-Summary(es):   El links es un browser para modo texto, similar a lynx
-Summary(pl):   Eksperymentalny Links (tekstowa przegl±darka WWW)
-Summary(pt_BR):        O links é um browser para modo texto, similar ao lynx
+Summary(es.UTF-8):     El links es un browser para modo texto, similar a lynx
+Summary(pl.UTF-8):     Eksperymentalny Links (tekstowa przeglądarka WWW)
+Summary(pt_BR.UTF-8):  O links é um browser para modo texto, similar ao lynx
 Name:          elinks
-Version:       0.11.0
-Release:       1
+Version:       0.11.4
+Release:       0.%{pre}
 Epoch:         1
 License:       GPL
 Group:         Applications/Networking
-#Source0Download:      http://www.elinks.cz/download.html
-Source0:       http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 9154f493f544af31ae31ec1dd203d315
+Source0:       http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
+# Source0-md5: 7fc7c36844be9c528c2ef28dbd4c5e6f
 Source1:       %{name}.desktop
 Source2:       links.png
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-lua40.patch
-Patch2:                %{name}-pl.po-update.patch
-Patch3:                %{name}-srcdir.patch
+Patch2:                %{name}-bug517.patch
+Patch3:                %{name}-date-format.patch
+Patch4:                %{name}-chunked.patch
+Patch5:                %{name}-mailcap_DISPLAY.patch
 URL:           http://www.elinks.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
+%{?with_fsp:BuildRequires:     fsplib-devel}
 BuildRequires: gettext-devel
 BuildRequires: gpm-devel
 %{?with_guile:BuildRequires: guile-devel}
@@ -55,7 +60,6 @@ BuildRequires:        ncurses-devel >= 5.1
 %{?with_perl:BuildRequires:    perl-devel}
 %{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: zlib-devel
-BuildRequires: tetex
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -69,34 +73,36 @@ purpose is to make alternative to links, until Mikulas will have some
 time to maintain it, and to test and tune various patches for Mikulas
 to be able to include them in the official links releases.
 
-%description -l es
+%description -l es.UTF-8
 Links es un browser WWW modo texto, similar al Lynx. El links muestra
 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
 keepalive.
 
-%description -l pl
-Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
-elinks jednak jest dedykowana g³ównie do testowania.
+%description -l pl.UTF-8
+Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
+elinks jednak jest dedykowana głównie do testowania.
 
-%description -l pt_BR
-Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
-tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
+%description -l pt_BR.UTF-8
+Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
+tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
 keepalive.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}%{pre}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %configure \
-       --disable-no-root \
        HAVE_SMBCLIENT=yes \
+       --disable-no-root \
        %{!?debug:--enable-fastmem} \
        %{?debug:--enable-debug} \
        %{!?with_ipv6:--disable-ipv6} \
@@ -107,6 +113,7 @@ keepalive.
        --enable-nntp \
        %{?with_256:--enable-256-colors} \
        --enable-exmode \
+       %{?with_fsp:--enable-fsp} \
        %{?with_leds:--enable-leds} \
        --enable-marks \
        --enable-html-highlight \
@@ -125,10 +132,6 @@ keepalive.
 
 %{__make} V=1
 
-cd doc
-texi2html elinks-lua.texi
-cd ..
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_desktopdir} \
@@ -153,9 +156,9 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
 %doc contrib/conv/{*awk,*.pl,*.sh}
-%doc doc/{*.txt,html}
+%doc doc/html/*.html
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man*/*
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_pixmapsdir}/*
 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.265724 seconds and 4 git commands to generate.