]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
be68fa556d8f08409a9be4ef9951ad9bdcd2910d
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2 #
3 # Conditional build:
4 %bcond_with     x               # Use the X Windows System
5 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
6 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
7 %bcond_without  256             # Disable 256 colors support
8 %bcond_without  bittorrent      # Disable BitTorrent support
9 %bcond_without  cgi             # Disable Local CGI support
10 %bcond_without  fsp             # Disable FSP support
11 %bcond_without  guile           # Disable Guile scripting
12 %bcond_without  idn             # Disable Internation Domain Names support
13 %bcond_without  ipv6            # Disable IPv6 support
14 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15 %bcond_without  led             # Disable LEDs
16 %bcond_without  lua             # Disable Lua scripting
17 %bcond_without  openssl         # Disable OpenSSL support
18 %bcond_without  perl            # Disable Perl scripting
19
20 %if %{with gnutls}
21 %undefine       with_openssl
22 %endif
23 #
24 %define         pre     rc1
25 Summary:        Experimantal Links (text WWW browser)
26 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
27 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
28 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
29 Name:           elinks
30 Version:        0.11.4
31 Release:        0.%{pre}
32 Epoch:          1
33 License:        GPL
34 Group:          Applications/Networking
35 Source0:        http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
36 # Source0-md5:  7fc7c36844be9c528c2ef28dbd4c5e6f
37 Source1:        %{name}.desktop
38 Source2:        links.png
39 Patch0:         %{name}-home_etc.patch
40 Patch1:         %{name}-lua40.patch
41 Patch2:         %{name}-bug517.patch
42 Patch3:         %{name}-date-format.patch
43 Patch4:         %{name}-chunked.patch
44 Patch5:         %{name}-mailcap_DISPLAY.patch
45 URL:            http://www.elinks.cz/
46 BuildRequires:  autoconf
47 BuildRequires:  automake
48 BuildRequires:  bzip2-devel
49 BuildRequires:  expat-devel
50 %{?with_fsp:BuildRequires:      fsplib-devel}
51 BuildRequires:  gettext-devel
52 BuildRequires:  gpm-devel
53 %{?with_guile:BuildRequires: guile-devel}
54 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
55 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
56 %{?with_idn:BuildRequires:      libidn-devel}
57 %{?with_lua:BuildRequires:      lua50-devel}
58 BuildRequires:  ncurses-devel >= 5.1
59 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
60 %{?with_perl:BuildRequires:     perl-devel}
61 %{?with_ruby:BuildRequires:     ruby-devel}
62 BuildRequires:  zlib-devel
63 Provides:       webclient
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _sysconfdir     /etc/elinks
67 %define         specflags_ia32  -fomit-frame-pointer 
68
69 %description
70 This is the elinks tree - intended to provide feature-rich version of
71 links, however not rock-stable and dedicated mainly for testing. Its
72 purpose is to make alternative to links, until Mikulas will have some
73 time to maintain it, and to test and tune various patches for Mikulas
74 to be able to include them in the official links releases.
75
76 %description -l es.UTF-8
77 Links es un browser WWW modo texto, similar al Lynx. El links muestra
78 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
79 keepalive.
80
81 %description -l pl.UTF-8
82 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
83 elinks jednak jest dedykowana głównie do testowania.
84
85 %description -l pt_BR.UTF-8
86 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
87 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
88 keepalive.
89
90 %prep
91 %setup -q -n %{name}-%{version}%{pre}
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96 %patch4 -p1
97 %patch5 -p1
98
99 %build
100 %{__aclocal}
101 %{__autoconf}
102 %{__autoheader}
103 %configure \
104         HAVE_SMBCLIENT=yes \
105         --disable-no-root \
106         %{!?debug:--enable-fastmem} \
107         %{?debug:--enable-debug} \
108         %{!?with_ipv6:--disable-ipv6} \
109         %{?with_bittorrent:--enable-bittorrent} \
110         %{?with_cgi:--enable-cgi} \
111         --enable-finger \
112         --enable-gopher \
113         --enable-nntp \
114         %{?with_256:--enable-256-colors} \
115         --enable-exmode \
116         %{?with_fsp:--enable-fsp} \
117         %{?with_leds:--enable-leds} \
118         --enable-marks \
119         --enable-html-highlight \
120         %{!?with_idn:--without-idn} \
121         %{?with_guile:--with-guile} \
122         %{?with_perl:--with-perl} \
123         %{!?with_lua:--without-lua} \
124         %{?with_ruby:--with-ruby} \
125         %{!?with_js:--without-spidermonkey} \
126         %{?with_gnutls:--with-gnutls} \
127         %{!?with_openssl:--without-openssl} \
128         --with%{!?with_x:out}-x
129 # xterm -e is default, one might want to change it to
130 # something else
131 #       --with-xterm="xterm -e"
132
133 %{__make} V=1
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT%{_desktopdir} \
138         $RPM_BUILD_ROOT%{_datadir}/%{name} \
139         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
140
141 %{__make} install V=1 \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
145 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
146
147 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
148
149 %find_lang %{name}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
157 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
158 %doc contrib/conv/{*awk,*.pl,*.sh}
159 %doc doc/html/*.html
160 %attr(755,root,root) %{_bindir}/*
161 %{_mandir}/man*/*
162 %{_desktopdir}/*.desktop
163 %{_pixmapsdir}/*
164 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.041131 seconds and 3 git commands to generate.