]> git.pld-linux.org Git - packages/elinks.git/blobdiff - elinks.spec
- up to 0.11.4rc1 (this is marked as the latest stable
[packages/elinks.git] / elinks.spec
index 762a7e88ebfae6507c283487f988d66369ec7965..be68fa556d8f08409a9be4ef9951ad9bdcd2910d 100644 (file)
@@ -1,48 +1,70 @@
+# TODO: consider lua51
+#
 # Conditional build:
-%bcond_with    x       # Use the X Windows System
-%bcond_without cgi     # Disable Local CGI support
-%bcond_without ipv6    # Disable IPv6 Support
-%bcond_without led     # Disable LEDs
-%bcond_without 256     # Disable 256 colors support
-%bcond_without lua     # Disable Lua scripting
+%bcond_with    x               # Use the X Windows System
+%bcond_with    gnutls          # Enable GNUTLS SSL support (disables openssl)
+%bcond_with    ruby            # Enable (experimental) Ruby scripting support
+%bcond_without 256             # Disable 256 colors support
+%bcond_without bittorrent      # Disable BitTorrent support
+%bcond_without cgi             # Disable Local CGI support
+%bcond_without fsp             # Disable FSP support
+%bcond_without guile           # Disable Guile scripting
+%bcond_without idn             # Disable Internation Domain Names support
+%bcond_without ipv6            # Disable IPv6 support
+%bcond_without js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
+%bcond_without led             # Disable LEDs
+%bcond_without lua             # Disable Lua scripting
+%bcond_without openssl         # Disable OpenSSL support
+%bcond_without perl            # Disable Perl scripting
+# 
+%if %{with gnutls}
+%undefine      with_openssl
+%endif
 #
+%define                pre     rc1
 Summary:       Experimantal Links (text WWW browser)
-Summary(es):   El links es un browser para modo texto, similar a lynx
-Summary(pl):   Eksperymentalny Links (tekstowa przegl±darka WWW)
-Summary(pt_BR):        O links é um browser para modo texto, similar ao lynx
+Summary(es.UTF-8):     El links es un browser para modo texto, similar a lynx
+Summary(pl.UTF-8):     Eksperymentalny Links (tekstowa przeglądarka WWW)
+Summary(pt_BR.UTF-8):  O links é um browser para modo texto, similar ao lynx
 Name:          elinks
-Version:       0.9.2
-%define _ver   rc7
-Release:       0.%{_ver}
+Version:       0.11.4
+Release:       0.%{pre}
 Epoch:         1
 License:       GPL
 Group:         Applications/Networking
-#Source0Download:      http://elinks.or.cz/download.html
-Source0:       http://elinks.or.cz/download/%{name}-%{version}%{_ver}.tar.bz2
-# Source0-md5: 7ae3168f7ce847bb49155777de432fbd
+Source0:       http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
+# Source0-md5: 7fc7c36844be9c528c2ef28dbd4c5e6f
 Source1:       %{name}.desktop
 Source2:       links.png
-#Patch0:               %{name}-pl.po.patch
-Patch1:                %{name}-home_etc.patch
-Patch2:                %{name}-lua40.patch
-Patch3:                %{name}-locale_names.patch
-URL:           http://elinks.or.cz/
+Patch0:                %{name}-home_etc.patch
+Patch1:                %{name}-lua40.patch
+Patch2:                %{name}-bug517.patch
+Patch3:                %{name}-date-format.patch
+Patch4:                %{name}-chunked.patch
+Patch5:                %{name}-mailcap_DISPLAY.patch
+URL:           http://www.elinks.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
+%{?with_fsp:BuildRequires:     fsplib-devel}
 BuildRequires: gettext-devel
 BuildRequires: gpm-devel
-%{?with_lua:BuildRequires:     lua40-devel >= 4.0.1-9}
-BuildRequires: ncurses-devel => 5.1
-BuildRequires: openssl-devel >= 0.9.7d
-BuildRequires: tetex
+%{?with_guile:BuildRequires: guile-devel}
+%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
+%{?with_js:BuildRequires:      js-devel >= 1.5-0.rc6a.1}
+%{?with_idn:BuildRequires:     libidn-devel}
+%{?with_lua:BuildRequires:     lua50-devel}
+BuildRequires: ncurses-devel >= 5.1
+%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
+%{?with_perl:BuildRequires:    perl-devel}
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: zlib-devel
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/elinks
-%define                specflags_ia32   -fomit-frame-pointer 
+%define                specflags_ia32  -fomit-frame-pointer 
 
 %description
 This is the elinks tree - intended to provide feature-rich version of
@@ -51,48 +73,64 @@ purpose is to make alternative to links, until Mikulas will have some
 time to maintain it, and to test and tune various patches for Mikulas
 to be able to include them in the official links releases.
 
-%description -l es
+%description -l es.UTF-8
 Links es un browser WWW modo texto, similar al Lynx. El links muestra
 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
 keepalive.
 
-%description -l pl
-Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki www - links.
-elinks jednak jest dedykowana g³ównie do testowania.
+%description -l pl.UTF-8
+Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
+elinks jednak jest dedykowana głównie do testowania.
 
-%description -l pt_BR
-Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
-tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
+%description -l pt_BR.UTF-8
+Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
+tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
 keepalive.
 
 %prep
-%setup -q -n %{name}-%{version}%{_ver}
-#%patch0 -p1
+%setup -q -n %{name}-%{version}%{pre}
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-
-mv -f po/{no,nb}.po
+%patch4 -p1
+%patch5 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
-%{__automake}
 %configure \
-%{!?debug:     --enable-fastmem} \
-%{?debug:      --enable-debug} \
+       HAVE_SMBCLIENT=yes \
+       --disable-no-root \
+       %{!?debug:--enable-fastmem} \
+       %{?debug:--enable-debug} \
        %{!?with_ipv6:--disable-ipv6} \
+       %{?with_bittorrent:--enable-bittorrent} \
+       %{?with_cgi:--enable-cgi} \
+       --enable-finger \
+       --enable-gopher \
+       --enable-nntp \
+       %{?with_256:--enable-256-colors} \
+       --enable-exmode \
+       %{?with_fsp:--enable-fsp} \
+       %{?with_leds:--enable-leds} \
+       --enable-marks \
+       --enable-html-highlight \
+       %{!?with_idn:--without-idn} \
+       %{?with_guile:--with-guile} \
+       %{?with_perl:--with-perl} \
        %{!?with_lua:--without-lua} \
+       %{?with_ruby:--with-ruby} \
+       %{!?with_js:--without-spidermonkey} \
+       %{?with_gnutls:--with-gnutls} \
+       %{!?with_openssl:--without-openssl} \
        --with%{!?with_x:out}-x
-%{?with_led:echo    '#define CONFIG_LEDS' >> feature.h}
-%{?with_256:echo    '#define CONFIG_256_COLORS' >> feature.h}
-%{?with_cgi:echo -e "#ifdef HAVE_SETENV\n\t#define CONFIG_CGI\n#endif" >> feature.h}
-%{__make}
+# xterm -e is default, one might want to change it to
+# something else
+#      --with-xterm="xterm -e"
 
-cd doc
-texi2html elinks-lua.texi
-cd ..
+%{__make} V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -100,7 +138,7 @@ install -d $RPM_BUILD_ROOT%{_desktopdir} \
        $RPM_BUILD_ROOT%{_datadir}/%{name} \
        $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
 
-%{__make} install \
+%{__make} install V=1 \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
@@ -118,9 +156,9 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
 %doc contrib/conv/{*awk,*.pl,*.sh}
-%doc doc/{*.txt,*.html}
+%doc doc/html/*.html
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man*/*
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_pixmapsdir}/*
-%{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
+%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.097988 seconds and 4 git commands to generate.