]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- require cooperative lua40
[packages/elinks.git] / elinks.spec
1 # Conditional build:
2 %bcond_with     x       # Use the X Windows System
3 %bcond_without  cgi     # Disable Local CGI support
4 %bcond_without  ipv6    # Disable IPv6 Support
5 %bcond_without  led     # Disable LEDs
6 %bcond_without  256     # Disable 256 colors support
7 %bcond_without  lua # Disable Lua scripting
8 #
9 Summary:        Experimantal Links (text WWW browser)
10 Summary(es):    El links es un browser para modo texto, similar a lynx
11 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
12 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
13 Name:           elinks
14 Version:        0.9.1
15 Release:        4
16 Epoch:          1
17 License:        GPL
18 Group:          Applications/Networking
19 #Source0Download:       http://elinks.or.cz/download.html
20 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
21 # Source0-md5:  78b536a9e9607ed522229b70172706a8
22 Source1:        %{name}.desktop
23 Source2:        links.png
24 Patch0:         %{name}-pl.po.patch
25 Patch1:         %{name}-home_etc.patch
26 Patch2:         %{name}-lua40.patch
27 URL:            http://elinks.or.cz/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  bzip2-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  gettext-devel
33 BuildRequires:  gpm-devel
34 BuildRequires:  lua40-devel >= 4.0.1-9
35 BuildRequires:  ncurses-devel => 5.1
36 BuildRequires:  openssl-devel >= 0.9.7d
37 BuildRequires:  zlib-devel
38 BuildRequires:  /usr/bin/texi2html
39 Provides:       webclient
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _sysconfdir     /etc/elinks
43 %define         specflags_ia32  "-fomit-frame-pointer"
44
45 %description
46 This is the elinks tree - intended to provide feature-rich version of
47 links, however not rock-stable and dedicated mainly for testing. Its
48 purpose is to make alternative to links, until Mikulas will have some
49 time to maintain it, and to test and tune various patches for Mikulas
50 to be able to include them in the official links releases.
51
52 %description -l es
53 Links es un browser WWW modo texto, similar al Lynx. El links muestra
54 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
55 keepalive.
56
57 %description -l pl
58 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki www - links.
59 elinks jednak jest dedykowana g³ównie do testowania.
60
61 %description -l pt_BR
62 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
63 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
64 keepalive.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71
72 %build
73 %{__aclocal}
74 %{__autoconf}
75 %{__autoheader}
76 %{__automake}
77 %configure \
78 %{!?debug:      --enable-fastmem} \
79 %{?debug:       --enable-debug} \
80         %{!?with_ipv6:--disable-ipv6} \
81         %{!?with_lua:--without-lua} \
82         --with%{!?with_x:out}-x
83 %{?with_led:echo    '#define CONFIG_LEDS' >> feature.h}
84 %{?with_256:echo    '#define CONFIG_256_COLORS' >> feature.h}
85 %{?with_cgi:echo -e "#ifdef HAVE_SETENV\n\t#define CONFIG_CGI\n#endif" >> feature.h}
86 %{__make}
87
88 cd doc
89 texi2html elinks-lua.texi
90 cd ..
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_desktopdir} \
95         $RPM_BUILD_ROOT%{_datadir}/%{name} \
96         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
103
104 install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}
105
106 %find_lang %{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files -f %{name}.lang
112 %defattr(644,root,root,755)
113 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
114 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
115 %doc contrib/conv/{*awk,*.pl,*.sh}
116 %doc doc/{*.txt,*.html}
117 %attr(755,root,root) %{_bindir}/*
118 %{_mandir}/man*/*
119 %{_desktopdir}/*
120 %{_pixmapsdir}/*
121 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.199837 seconds and 4 git commands to generate.