]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- rel 3
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 %bcond_with     x               # Use the X Windows System
4 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
5 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
6 %bcond_without  256             # Disable 256 colors support
7 %bcond_without  bittorrent      # Disable BitTorrent support
8 %bcond_without  cgi             # Disable Local CGI support
9 %bcond_without  fsp             # Disable FSP support
10 %bcond_without  guile           # Disable Guile scripting
11 %bcond_without  idn             # Disable Internation Domain Names support
12 %bcond_without  ipv6            # Disable IPv6 support
13 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
14 %bcond_without  led             # Disable LEDs
15 %bcond_without  lua             # Disable Lua scripting
16 %bcond_without  openssl         # Disable OpenSSL support
17 %bcond_without  perl            # Disable Perl scripting
18
19 %if %{with gnutls}
20 %undefine       with_openssl
21 %endif
22 #
23 Summary:        Experimantal Links (text WWW browser)
24 Summary(es):    El links es un browser para modo texto, similar a lynx
25 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
26 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
27 Name:           elinks
28 Version:        0.11.2
29 Release:        3
30 Epoch:          1
31 License:        GPL
32 Group:          Applications/Networking
33 #Source0Download:       http://www.elinks.cz/download.html
34 Source0:        http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
35 # Source0-md5:  5a8f83afb527cf443f58b372136a81fc
36 Source1:        %{name}.desktop
37 Source2:        links.png
38 Patch0:         %{name}-home_etc.patch
39 Patch1:         %{name}-lua40.patch
40 Patch2:         %{name}-pl.po-update.patch
41 Patch3:         %{name}-bug899.patch
42 URL:            http://www.elinks.cz/
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  bzip2-devel
46 BuildRequires:  expat-devel
47 %{?with_fsp:BuildRequires:      fsplib-devel}
48 BuildRequires:  gettext-devel
49 BuildRequires:  gpm-devel
50 %{?with_guile:BuildRequires: guile-devel}
51 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
52 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
53 %{?with_idn:BuildRequires:      libidn-devel}
54 %{?with_lua:BuildRequires:      lua50-devel}
55 BuildRequires:  ncurses-devel >= 5.1
56 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
57 %{?with_perl:BuildRequires:     perl-devel}
58 %{?with_ruby:BuildRequires:     ruby-devel}
59 BuildRequires:  zlib-devel
60 Provides:       webclient
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _sysconfdir     /etc/elinks
64 %define         specflags_ia32  -fomit-frame-pointer 
65
66 %description
67 This is the elinks tree - intended to provide feature-rich version of
68 links, however not rock-stable and dedicated mainly for testing. Its
69 purpose is to make alternative to links, until Mikulas will have some
70 time to maintain it, and to test and tune various patches for Mikulas
71 to be able to include them in the official links releases.
72
73 %description -l es
74 Links es un browser WWW modo texto, similar al Lynx. El links muestra
75 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
76 keepalive.
77
78 %description -l pl
79 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
80 elinks jednak jest dedykowana g³ównie do testowania.
81
82 %description -l pt_BR
83 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
84 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
85 keepalive.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 %patch3 -p1
93
94 %build
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %configure \
99         --disable-no-root \
100         HAVE_SMBCLIENT=yes \
101         %{!?debug:--enable-fastmem} \
102         %{?debug:--enable-debug} \
103         %{!?with_ipv6:--disable-ipv6} \
104         %{?with_bittorrent:--enable-bittorrent} \
105         %{?with_cgi:--enable-cgi} \
106         --enable-finger \
107         --enable-gopher \
108         --enable-nntp \
109         %{?with_256:--enable-256-colors} \
110         --enable-exmode \
111         %{?with_fsp:--enable-fsp} \
112         %{?with_leds:--enable-leds} \
113         --enable-marks \
114         --enable-html-highlight \
115         %{!?with_idn:--without-idn} \
116         %{?with_guile:--with-guile} \
117         %{?with_perl:--with-perl} \
118         %{!?with_lua:--without-lua} \
119         %{?with_ruby:--with-ruby} \
120         %{!?with_js:--without-spidermonkey} \
121         %{?with_gnutls:--with-gnutls} \
122         %{!?with_openssl:--without-openssl} \
123         --with%{!?with_x:out}-x
124 # xterm -e is default, one might want to change it to
125 # something else
126 #       --with-xterm="xterm -e"
127
128 %{__make} V=1
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_desktopdir} \
133         $RPM_BUILD_ROOT%{_datadir}/%{name} \
134         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
135
136 %{__make} install V=1 \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
140 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
141
142 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
143
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
152 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
153 %doc contrib/conv/{*awk,*.pl,*.sh}
154 %doc doc/html/*.html
155 %attr(755,root,root) %{_bindir}/*
156 %{_mandir}/man*/*
157 %{_desktopdir}/*.desktop
158 %{_pixmapsdir}/*
159 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.063794 seconds and 3 git commands to generate.