]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- initialize unit_len_ctx
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 # - protocols
4 %bcond_without  bittorrent      # BitTorrent protocol support
5 %bcond_without  fsp             # FSP support
6 %bcond_without  idn             # Internation Domain Names support
7 %bcond_without  ipv6            # IPv6 support
8 %bcond_with     smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
9 %bcond_with     gnutls          # GNUTLS-based SSL support (instead of openssl)
10 %bcond_without  openssl         # OpenSSL-based SSL support
11 # - content
12 %bcond_without  cgi             # Local CGI support
13 %bcond_with     brotli          # Brotli compression support
14 %bcond_without  js              # experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15 %bcond_with     lzma            # LZMA support (old API, incompatible with xz-libs)
16 # - scripting
17 %bcond_with     guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
18 %bcond_without  lua             # Lua scripting
19 %bcond_without  perl            # Perl scripting
20 %bcond_with     python          # Python scripting support
21 %bcond_with     ruby            # (experimental) Ruby scripting support
22 # - display and UI
23 %bcond_without  256             # 256 colors support
24 %bcond_without  led             # LEDs
25 %bcond_without  truecolor       # true color
26 %bcond_with     olderisbetter   # variuos pre-0.10.0 behaviour rules (typeahead and esc-esc)
27 %bcond_with     x               # Use the X Window System
28 # - misc
29 %bcond_without  verbose         # verbose build (V=1)
30
31 %if %{with gnutls}
32 %undefine       with_openssl
33 %endif
34
35 Summary:        Experimantal Links (text WWW browser)
36 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
37 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
38 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
39 Name:           elinks
40 Version:        0.13
41 %define snap    20151228
42 %define rel     6
43 Release:        4.%{snap}.%{rel}
44 Epoch:          1
45 License:        GPL v2
46 Group:          Applications/Networking
47 # github gives different archive on each download
48 # http://www.elinks.cz/download/%{name}-current-%{version}.tar.bz2
49 Source0:        http://elinks.cz/download/elinks-current-%{version}.tar.bz2
50 # Source0-md5:  c8e0588124c127f5d025cb1cafe5d9d3
51 Source1:        %{name}.desktop
52 Source2:        links.png
53 Patch0:         %{name}-home_etc.patch
54 Patch1:         %{name}-lua40.patch
55 Patch2:         %{name}-date-format.patch
56 Patch3:         %{name}-old_incremental.patch
57 Patch4:         %{name}-0.10.0-0.9.3-typeahead-beginning.patch
58 Patch5:         %{name}-double-esc.patch
59 URL:            http://www.elinks.cz/
60 BuildRequires:  autoconf >= 2.61
61 BuildRequires:  automake
62 BuildRequires:  bzip2-devel
63 BuildRequires:  expat-devel
64 %{?with_fsp:BuildRequires:      fsplib-devel}
65 BuildRequires:  gettext-tools
66 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
67 BuildRequires:  gpm-devel
68 %{?with_guile:BuildRequires: guile-devel}
69 #BuildRequires: heimdal-devel
70 %{?with_js:BuildRequires:       js187-devel}
71 %{?with_brotli:BuildRequires:   libbrotli-devel < 0.3}
72 %{?with_idn:BuildRequires:      libidn-devel}
73 %{?with_smb:BuildRequires:      libsmbclient-devel}
74 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
75 %{?with_lzma:BuildRequires:     lzma-devel}
76 BuildRequires:  ncurses-devel >= 5.1
77 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
78 %{?with_perl:BuildRequires:     perl-devel}
79 BuildRequires:  pkgconfig
80 %{?with_python:BuildRequires:   python-devel}
81 %{?with_ruby:BuildRequires:     ruby-devel}
82 BuildRequires:  tre-devel
83 BuildRequires:  which
84 BuildRequires:  zlib-devel
85 Suggests:       mailcap
86 Provides:       webclient
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         _sysconfdir     /etc/elinks
90 %define         specflags_ia32  -fomit-frame-pointer
91
92 %description
93 This is the elinks tree - intended to provide feature-rich version of
94 links, however not rock-stable and dedicated mainly for testing. Its
95 purpose is to make alternative to links, until Mikulas will have some
96 time to maintain it, and to test and tune various patches for Mikulas
97 to be able to include them in the official links releases.
98
99 %description -l es.UTF-8
100 Links es un browser WWW modo texto, similar al Lynx. El links muestra
101 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
102 keepalive.
103
104 %description -l pl.UTF-8
105 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
106 elinks jednak jest dedykowana głównie do testowania.
107
108 %description -l pt_BR.UTF-8
109 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
110 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
111 keepalive.
112
113 %prep
114 %setup -q -n %{name}-%{version}-%{snap}
115 %patch0 -p1
116 %patch1 -p1
117 %patch2 -p1
118 %if %{with olderisbetter}
119 %patch3 -p1
120 %patch4 -p1
121 %patch5 -p1
122 %endif
123
124 %build
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %configure \
129         %{?with_bittorrent:--enable-bittorrent} \
130         %{?with_cgi:--enable-cgi} \
131         --enable-88-colors \
132         %{?with_256:--enable-256-colors} \
133         %{?with_truecolor:--enable-true-color} \
134         --enable-exmode \
135         %{?debug:--enable-debug} \
136         %{!?debug:--enable-fastmem} \
137         --enable-finger \
138         %{?with_fsp:--enable-fsp} \
139         --enable-gopher \
140         --enable-html-highlight \
141         %{!?with_ipv6:--disable-ipv6} \
142         %{?with_leds:--enable-leds} \
143         --enable-marks \
144         --enable-nntp \
145         --disable-no-root \
146         %{?with_smb:--enable-smb} \
147         %{!?with_brotli:--without-brotli} \
148         --without-gc \
149         %{?with_gnutls:--with-gnutls} \
150         %{?with_guile:--with-guile} \
151         %{!?with_idn:--without-idn} \
152         %{!?with_lua:--without-lua} \
153         %{!?with_lzma:--without-lzma} \
154         %{!?with_openssl:--without-openssl} \
155         %{?with_perl:--with-perl} \
156         %{?with_python:--with-python} \
157         %{?with_ruby:--with-ruby} \
158         %{!?with_js:--without-spidermonkey} \
159         --with-x%{!?with_x:=no}
160 # xterm -e is default, one might want to change it to something else:
161 #       --with-xterm="xterm -e"
162
163 %{__make} %{?with_verbose:V=1}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT%{_desktopdir} \
168         $RPM_BUILD_ROOT%{_datadir}/%{name} \
169         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
170
171 %{__make} install %{?with_verbose:V=1} \
172         DESTDIR=$RPM_BUILD_ROOT
173
174 %{__rm} $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
175
176 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
177 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
178
179 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
180
181 %find_lang %{name}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %files -f %{name}.lang
187 %defattr(644,root,root,755)
188 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO doc/html/*.html
189 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh}
190 %attr(755,root,root) %{_bindir}/elinks
191 %{_mandir}/man1/elinks.1*
192 %{_mandir}/man5/elinks.conf.5*
193 %{_mandir}/man5/elinkskeys.5*
194 %{_desktopdir}/elinks.desktop
195 %{_pixmapsdir}/elinks.png
196 %if %{with lua}
197 %dir %{_sysconfdir}
198 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
199 %endif
This page took 0.088221 seconds and 3 git commands to generate.