]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
allow building just without libcss
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 # - protocols
4 %bcond_without  bittorrent      # BitTorrent protocol support
5 %bcond_without  curl            # FTPes, SFTP, HTTP/2, etc.
6 %bcond_without  fsp             # FSP support
7 %bcond_without  idn             # Internation Domain Names support
8 %bcond_without  ipv6            # IPv6 support
9 %bcond_with     smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
10 %bcond_with     gnutls          # GNUTLS-based SSL support (instead of openssl)
11 %bcond_without  openssl         # OpenSSL-based SSL support
12 # - content
13 %bcond_without  cgi             # Local CGI support
14 %bcond_without  brotli          # Brotli compression support
15 %bcond_without  js              # experimental (yet quite usable) JavaScript support (using quickjs)
16 %bcond_without  libcss          # libcss support
17 %bcond_with     lzma            # LZMA support (old API, incompatible with xz-libs)
18 %bcond_without  zstd    # zstd compression support
19 # - scripting
20 %bcond_with     guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
21 %bcond_without  lua             # Lua scripting
22 %bcond_with     perl            # Perl scripting
23 %bcond_with     python          # Python scripting support
24 %bcond_with     ruby            # (experimental) Ruby scripting support
25 # - display and UI
26 %bcond_without  256             # 256 colors support
27 %bcond_without  led             # LEDs
28 %bcond_without  truecolor       # true color
29 %bcond_with     x               # Use the X Window System
30 # - misc
31 %bcond_without  verbose         # verbose build (V=1)
32 %bcond_without  libevent        # build without libevent
33
34 %if %{with gnutls}
35 %undefine       with_openssl
36 %endif
37
38 %if %{without libcss}
39 %undefine       with_js
40 %endif
41
42 Summary:        Experimantal Links (text WWW browser)
43 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
44 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
45 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
46 Name:           elinks
47 Version:        0.17.0
48 Release:        1
49 Epoch:          1
50 License:        GPL v2
51 Group:          Applications/Networking
52 Source0:        https://github.com/rkd77/elinks/releases/download/v%{version}/%{name}-%{version}.tar.xz
53 # Source0-md5:  6bb43cd9037ad83cded1df85d95dbd73
54 Source1:        %{name}.desktop
55 Source2:        links.png
56 URL:            http://www.elinks.cz/
57 BuildRequires:  bzip2-devel
58 %{?with_curl:BuildRequires:     curl-devel}
59 BuildRequires:  expat-devel
60 %{?with_fsp:BuildRequires:      fsplib-devel}
61 BuildRequires:  gettext-tools
62 BuildRequires:  git-core
63 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
64 BuildRequires:  gpm-devel
65 %{?with_guile:BuildRequires: guile-devel}
66 %{?with_libcss:BuildRequires:   libCSS-devel >= 0.9.1}
67 BuildRequires:  libstdc++-devel
68 BuildRequires:  rpmbuild(macros) >= 1.736
69 %{?with_js:BuildRequires:       sqlite3-devel}
70 %{?with_brotli:BuildRequires:   libbrotli-devel}
71 %{?with_js:BuildRequires:       libdom-devel >= 0.4.1}
72 %{?with_libevent:BuildRequires: libevent-devel}
73 %{?with_idn:BuildRequires:      libidn2-devel}
74 %{?with_smb:BuildRequires:      libsmbclient-devel}
75 %{?with_lua:BuildRequires:      lua53-devel}
76 %{?with_lzma:BuildRequires:     lzma-devel}
77 BuildRequires:  meson
78 BuildRequires:  ncurses-devel >= 5.1
79 BuildRequires:  ninja >= 1.5
80 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
81 %{?with_perl:BuildRequires:     perl-devel}
82 BuildRequires:  pkgconfig
83 %{?with_python:BuildRequires:   python3-devel}
84 %{?with_js:BuildRequires:       quickjs-devel >= 20210327-4}
85 %{?with_ruby:BuildRequires:     ruby-devel}
86 BuildRequires:  sed
87 BuildRequires:  tar >= 1:1.22
88 BuildRequires:  tre-devel
89 BuildRequires:  which
90 BuildRequires:  xmlto
91 BuildRequires:  xz
92 BuildRequires:  zlib-devel
93 %{?with_zstd:BuildRequires:     zstd-devel}
94 %{?with_gnutls:Requires:        gnutls-libs >= 1.2.5}
95 %{?with_libcss:Requires:        libCSS >= 0.9.1}
96 %{?with_js:Requires:    libdom >= 0.4.1}
97 Requires:       ncurses >= 5.1
98 %{?with_openssl:Requires:       openssl >= 0.9.7d}
99 %{?with_js:Requires:    quickjs >= 20210327-4}
100 Suggests:       mailcap
101 Provides:       webclient
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _sysconfdir     /etc/elinks
105 %define         specflags_ia32  -fomit-frame-pointer
106
107 %description
108 This is the elinks tree - intended to provide feature-rich version of
109 links, however not rock-stable and dedicated mainly for testing. Its
110 purpose is to make alternative to links, until Mikulas will have some
111 time to maintain it, and to test and tune various patches for Mikulas
112 to be able to include them in the official links releases.
113
114 %description -l es.UTF-8
115 Links es un browser WWW modo texto, similar al Lynx. El links muestra
116 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
117 keepalive.
118
119 %description -l pl.UTF-8
120 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
121 elinks jednak jest dedykowana głównie do testowania.
122
123 %description -l pt_BR.UTF-8
124 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
125 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
126 keepalive.
127
128 %prep
129 %setup -q
130
131 %build
132 %meson build \
133         -Dapidoc=false \
134         -Dhtmldoc=true \
135         -Dpdfdoc=false \
136         -Ddocdir=%{_docdir}/%{name}-%{version} \
137         %{?with_bittorrent:-Dbittorrent=true} \
138         %{?with_cgi:-Dcgi=true} \
139         -D88-colors=true \
140         %{?with_256:-D256-colors=true} \
141         %{?with_truecolor:-Dtrue-color=true} \
142         -Dexmode=true \
143         %{?debug:-Ddebug=true} \
144         %{!?debug:-Dfastmem=true} \
145         -Dfinger=true \
146         -Dfsp=%{__true_false fsp} \
147         -Dgemini=true \
148         -Dgettext=true \
149         -Dgopher=true \
150         -Dhtml-highlight=true \
151         %{!?with_ipv6:-Dipv6=false} \
152         %{?with_leds:-Dleds=true} \
153         -Dmarks=true \
154         -Dnntp=true \
155         -Dno-root=false \
156         %{?with_smb:-Dsmb=true} \
157         %{?with_brotli:-Dbrotli=true} \
158         %{?with_zstd:-Dzstd=true} \
159         %{?with_gnutls:-Dgnutls=true} \
160         %{?with_guile:-Dguile=true} \
161         %{!?with_idn:-Didn=false} \
162         %{?with_lua:-Dluapkg=lua5.3} \
163         %{?with_lzma:-Dlzma=true} \
164         %{?with_openssl:-Dopenssl=true} \
165         %{?with_perl:-Dperl=true} \
166         %{?with_python:-Dpython=true} \
167         %{?with_ruby:-Druby=true} \
168         %{?with_js:-Dquickjs=true} \
169         %{?with_x:-Dx=true} \
170         %{?with_libevent:-Dlibevent=true} \
171         %{!?with_curl:-Dlibcurl=false} \
172         %{!?with_libcss:-Dlibcss=false}
173
174 %ninja_build -C build
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178 %ninja_install -C build
179
180 install -d $RPM_BUILD_ROOT%{_desktopdir} \
181         $RPM_BUILD_ROOT%{_datadir}/%{name} \
182         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
183
184 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
185 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
186
187 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
188 sed -i -e 's|bin/lua|bin/lua5.3|g' $RPM_BUILD_ROOT%{_sysconfdir}/*lua
189
190 install AUTHORS BUGS ChangeLog NEWS README.md SITES TODO $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
191 install contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
192
193 %find_lang %{name}
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %files -f %{name}.lang
199 %defattr(644,root,root,755)
200 %{_docdir}/%{name}-%{version}
201 %attr(755,root,root) %{_bindir}/elinks
202 %{_mandir}/man1/elinks.1*
203 %{_mandir}/man5/elinks.conf.5*
204 %{_mandir}/man5/elinkskeys.5*
205 %{_desktopdir}/elinks.desktop
206 %{_pixmapsdir}/elinks.png
207 %if %{with lua}
208 %dir %{_sysconfdir}
209 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
210 %endif
This page took 0.63711 seconds and 3 git commands to generate.