]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- the archives createad automatically for a branch on github are different
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2
3 # Conditional build:
4 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
5 %bcond_with     lzma            # Enable lzma support
6 %bcond_with     python          # Enable Python scripting support
7 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
8 %bcond_with     smb             # Enable smb protocol support (smb requires libsmbclient)
9 #The latest libsmbclient is GPLv3, while ELinks is GPL v2 only.
10 %bcond_with     verbose         # verbose build (V=1)
11 %bcond_with     x               # Use the X Window System
12 %bcond_without  256             # Disable 256 colors support
13 %bcond_without  bittorrent      # Disable BitTorrent support
14 %bcond_without  cgi             # Disable Local CGI support
15 %bcond_without  fsp             # Disable FSP support
16 %bcond_without  guile           # Disable Guile scripting
17 %bcond_without  idn             # Disable Internation Domain Names support
18 %bcond_without  ipv6            # Disable IPv6 support
19 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
20 %bcond_without  led             # Disable LEDs
21 %bcond_without  lua             # Disable Lua scripting
22 %bcond_without  openssl         # Disable OpenSSL support
23 %bcond_without  perl            # Disable Perl scripting
24 %bcond_with     olderisbetter   # variuos pre-0.10.0 behaviour rules (typeahead and esc-esc)
25
26 %if %{with gnutls}
27 %undefine       with_openssl
28 %endif
29
30 Summary:        Experimantal Links (text WWW browser)
31 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
32 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
33 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
34 Name:           elinks
35 Version:        0.13
36 Release:        1
37 Epoch:          1
38 License:        GPL v2
39 Group:          Applications/Networking
40 # github gives different archive on each download
41 # http://www.elinks.cz/download/%{name}-current-%{version}.tar.bz2
42 Source0:        %{name}-current-%{version}.tar.bz2
43 # Source0-md5:  efc9918d90cb03a4d1c4d36ef1c36101
44 Source1:        %{name}.desktop
45 Source2:        links.png
46 Patch0:         %{name}-home_etc.patch
47 Patch1:         %{name}-lua40.patch
48 Patch2:         %{name}-date-format.patch
49 Patch3:         %{name}-old_incremental.patch
50 Patch4:         %{name}-0.10.0-0.9.3-typeahead-beginning.patch
51 Patch5:         %{name}-double-esc.patch
52 URL:            http://www.elinks.cz/
53 BuildRequires:  autoconf >= 2.61
54 BuildRequires:  automake
55 BuildRequires:  bzip2-devel
56 BuildRequires:  expat-devel
57 %{?with_fsp:BuildRequires:      fsplib-devel}
58 #BuildRequires: gc-devel
59 BuildRequires:  gettext-devel
60 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
61 BuildRequires:  gpm-devel
62 %{?with_guile:BuildRequires: guile-devel}
63 #BuildRequires: heimdal-devel
64 %{?with_js:BuildRequires:       js185-devel}
65 %{?with_idn:BuildRequires:      libidn-devel}
66 %{?with_smb:BuildRequires:      libsmbclient-devel}
67 %{?with_lua:BuildRequires:      lua50-devel}
68 %{?with_lzma:BuildRequires:     lzma-devel}
69 BuildRequires:  ncurses-devel >= 5.1
70 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
71 %{?with_perl:BuildRequires:     perl-devel}
72 BuildRequires:  pkgconfig
73 %{?with_python:BuildRequires:   python-devel}
74 %{?with_ruby:BuildRequires:     ruby-devel}
75 BuildRequires:  tre-devel
76 BuildRequires:  which
77 BuildRequires:  zlib-devel
78 Suggests:       mailcap
79 Provides:       webclient
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _sysconfdir     /etc/elinks
83 %define         specflags_ia32  -fomit-frame-pointer
84
85 %description
86 This is the elinks tree - intended to provide feature-rich version of
87 links, however not rock-stable and dedicated mainly for testing. Its
88 purpose is to make alternative to links, until Mikulas will have some
89 time to maintain it, and to test and tune various patches for Mikulas
90 to be able to include them in the official links releases.
91
92 %description -l es.UTF-8
93 Links es un browser WWW modo texto, similar al Lynx. El links muestra
94 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
95 keepalive.
96
97 %description -l pl.UTF-8
98 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
99 elinks jednak jest dedykowana głównie do testowania.
100
101 %description -l pt_BR.UTF-8
102 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
103 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
104 keepalive.
105
106 %prep
107 %setup -q -n %{name}-%{version}-20120604
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111 %if %{with olderisbetter}
112 %patch3 -p1
113 %patch4 -p1
114 %patch5 -p1
115 %endif
116
117 %build
118 %{__aclocal}
119 %{__autoconf}
120 %{__autoheader}
121 %configure \
122         %{?with_smb:--enable-smb} \
123         --disable-no-root \
124         %{!?debug:--enable-fastmem} \
125         %{?debug:--enable-debug} \
126         %{!?with_ipv6:--disable-ipv6} \
127         %{?with_bittorrent:--enable-bittorrent} \
128         %{?with_cgi:--enable-cgi} \
129         --enable-finger \
130         --enable-gopher \
131         --enable-nntp \
132         --enable-88-colors \
133         %{?with_256:--enable-256-colors} \
134         --enable-true-color \
135         --enable-exmode \
136         %{?with_fsp:--enable-fsp} \
137         %{?with_leds:--enable-leds} \
138         --enable-marks \
139         --enable-html-highlight \
140         %{!?with_idn:--without-idn} \
141         %{?with_guile:--with-guile} \
142         %{?with_perl:--with-perl} \
143         %{!?with_lua:--without-lua} \
144         %{?with_python:--with-python} \
145         %{?with_ruby:--with-ruby} \
146         %{!?with_js:--without-spidermonkey} \
147         %{?with_gnutls:--with-gnutls} \
148         %{!?with_openssl:--without-openssl} \
149         --with%{!?with_x:out}-x \
150         %{!?with_lzma:--without-lzma}
151 # xterm -e is default, one might want to change it to
152 # something else
153 #       --with-xterm="xterm -e"
154
155 %{__make} %{?with_verbose:V=1}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT%{_desktopdir} \
160         $RPM_BUILD_ROOT%{_datadir}/%{name} \
161         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
162
163 %{__make} install %{?with_verbose:V=1} \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 rm $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
167
168 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
169 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
170
171 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
172
173 %find_lang %{name}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %files -f %{name}.lang
179 %defattr(644,root,root,755)
180 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO doc/html/*.html
181 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh}
182 %attr(755,root,root) %{_bindir}/elinks
183 %{_mandir}/man1/elinks.1*
184 %{_mandir}/man5/elinks.conf.5*
185 %{_mandir}/man5/elinkskeys.5*
186 %{_desktopdir}/elinks.desktop
187 %{_pixmapsdir}/elinks.png
188 %if %{with lua}
189 %dir %{_sysconfdir}
190 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
191 %endif
This page took 0.079519 seconds and 3 git commands to generate.