]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- updated to 0.10rc1
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 %bcond_with     x       # Use the X Windows System
4 %bcond_without  cgi     # Disable Local CGI support
5 %bcond_without  ipv6    # Disable IPv6 Support
6 %bcond_without  led     # Disable LEDs
7 %bcond_without  256     # Disable 256 colors support
8 %bcond_without  lua     # Disable Lua scripting
9 #
10 Summary:        Experimantal Links (text WWW browser)
11 Summary(es):    El links es un browser para modo texto, similar a lynx
12 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
13 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
14 Name:           elinks
15 Version:        0.9.3
16 Release:        2
17 Epoch:          1
18 License:        GPL
19 Group:          Applications/Networking
20 #Source0Download:       http://elinks.or.cz/download.html
21 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
22 # Source0-md5:  c9d1ea15b8286ba055ad5babdfb94664
23 Source1:        %{name}.desktop
24 Source2:        links.png
25 #Patch0:                %{name}-pl.po.patch
26 Patch1:         %{name}-home_etc.patch
27 Patch2:         %{name}-lua40.patch
28 Patch3:         %{name}-locale_names.patch
29 Patch4:         %{name}-content-type.patch
30 URL:            http://elinks.or.cz/
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  bzip2-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  gpm-devel
37 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
38 BuildRequires:  ncurses-devel => 5.1
39 BuildRequires:  openssl-devel >= 0.9.7d
40 BuildRequires:  tetex
41 BuildRequires:  zlib-devel
42 Provides:       webclient
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sysconfdir     /etc/elinks
46 %define         specflags_ia32  -fomit-frame-pointer
47
48 %description
49 This is the elinks tree - intended to provide feature-rich version of
50 links, however not rock-stable and dedicated mainly for testing. Its
51 purpose is to make alternative to links, until Mikulas will have some
52 time to maintain it, and to test and tune various patches for Mikulas
53 to be able to include them in the official links releases.
54
55 %description -l es
56 Links es un browser WWW modo texto, similar al Lynx. El links muestra
57 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
58 keepalive.
59
60 %description -l pl
61 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
62 elinks jednak jest dedykowana g³ównie do testowania.
63
64 %description -l pt_BR
65 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
66 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
67 keepalive.
68
69 %prep
70 %setup -q
71 #%patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74 %patch3 -p1
75 %patch4 -p1
76
77 mv -f po/{no,nb}.po
78
79 %build
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85 %{!?debug:      --enable-fastmem} \
86 %{?debug:       --enable-debug} \
87         %{!?with_ipv6:--disable-ipv6} \
88         %{!?with_lua:--without-lua} \
89         --with%{!?with_x:out}-x
90 %{?with_led:echo    '#define CONFIG_LEDS' >> feature.h}
91 %{?with_256:echo    '#define CONFIG_256_COLORS' >> feature.h}
92 %{?with_cgi:echo -e "#ifdef HAVE_SETENV\n\t#define CONFIG_CGI\n#endif" >> feature.h}
93 %{__make}
94
95 cd doc
96 texi2html elinks-lua.texi
97 cd ..
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT%{_desktopdir} \
102         $RPM_BUILD_ROOT%{_datadir}/%{name} \
103         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
109 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
110
111 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
121 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
122 %doc contrib/conv/{*awk,*.pl,*.sh}
123 %doc doc/{*.txt,*.html}
124 %attr(755,root,root) %{_bindir}/*
125 %{_mandir}/man*/*
126 %{_desktopdir}/*
127 %{_pixmapsdir}/*
128 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.14038 seconds and 3 git commands to generate.