]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- outdated
[packages/elinks.git] / elinks.spec
1 # Conditional build:
2 %bcond_with     x       # Use the X Windows System
3 %bcond_without  cgi     # Disable Local CGI support
4 %bcond_without  ipv6    # Disable IPv6 Support
5 %bcond_without  led     # Disable LEDs
6 %bcond_without  256     # Disable 256 colors support
7 %bcond_without  lua     # Disable Lua scripting
8 #
9 Summary:        Experimantal Links (text WWW browser)
10 Summary(es):    El links es un browser para modo texto, similar a lynx
11 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
12 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
13 Name:           elinks
14 Version:        0.9.2
15 %define _ver    rc7
16 Release:        1
17 Epoch:          1
18 License:        GPL
19 Group:          Applications/Networking
20 #Source0Download:       http://elinks.or.cz/download.html
21 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
22 # Source0-md5:  2bd5f150ed91628bd2b64ad7d2d1edfd
23 Source1:        %{name}.desktop
24 Source2:        links.png
25 #Patch0:                %{name}-pl.po.patch
26 Patch1:         %{name}-home_etc.patch
27 Patch2:         %{name}-lua40.patch
28 Patch3:         %{name}-locale_names.patch
29 URL:            http://elinks.or.cz/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  bzip2-devel
33 BuildRequires:  expat-devel
34 BuildRequires:  gettext-devel
35 BuildRequires:  gpm-devel
36 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
37 BuildRequires:  ncurses-devel => 5.1
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  tetex
40 BuildRequires:  zlib-devel
41 Provides:       webclient
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _sysconfdir     /etc/elinks
45 %define         specflags_ia32  -fomit-frame-pointer
46
47 %description
48 This is the elinks tree - intended to provide feature-rich version of
49 links, however not rock-stable and dedicated mainly for testing. Its
50 purpose is to make alternative to links, until Mikulas will have some
51 time to maintain it, and to test and tune various patches for Mikulas
52 to be able to include them in the official links releases.
53
54 %description -l es
55 Links es un browser WWW modo texto, similar al Lynx. El links muestra
56 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
57 keepalive.
58
59 %description -l pl
60 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki www - links.
61 elinks jednak jest dedykowana g³ównie do testowania.
62
63 %description -l pt_BR
64 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
65 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
66 keepalive.
67
68 %prep
69 %setup -q
70 #%patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74
75 mv -f po/{no,nb}.po
76
77 %build
78 %{__aclocal}
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83 %{!?debug:      --enable-fastmem} \
84 %{?debug:       --enable-debug} \
85         %{!?with_ipv6:--disable-ipv6} \
86         %{!?with_lua:--without-lua} \
87         --with%{!?with_x:out}-x
88 %{?with_led:echo    '#define CONFIG_LEDS' >> feature.h}
89 %{?with_256:echo    '#define CONFIG_256_COLORS' >> feature.h}
90 %{?with_cgi:echo -e "#ifdef HAVE_SETENV\n\t#define CONFIG_CGI\n#endif" >> feature.h}
91 %{__make}
92
93 cd doc
94 texi2html elinks-lua.texi
95 cd ..
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_desktopdir} \
100         $RPM_BUILD_ROOT%{_datadir}/%{name} \
101         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
107 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
108
109 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
110
111 %find_lang %{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files -f %{name}.lang
117 %defattr(644,root,root,755)
118 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
119 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
120 %doc contrib/conv/{*awk,*.pl,*.sh}
121 %doc doc/{*.txt,*.html}
122 %attr(755,root,root) %{_bindir}/*
123 %{_mandir}/man*/*
124 %{_desktopdir}/*
125 %{_pixmapsdir}/*
126 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.054401 seconds and 3 git commands to generate.